Problems installing Windows updates on W2K3 servers



NicolasD
07-09-2005, 11:35 PM
Hello, just recently I cannot install Win updates on our W2K3 non SP1 servers.
The installation history is blank even though I have applied Win updates on
them last month and beyond? When I scan for updates it shows 0% complete and
doesnt move from there? I have tried proxycfg -p -d and still no activity on
our Proxy server. Our XP pro SP2 clients can update via the proxy but not the
servers?

Thanks,

Nicolas

MowGreen [MVP]
07-09-2005, 11:35 PM
NicolasD,

Give this a try :

Re-register the following files:
regsvr32 msscript.ocx
regsvr32 dispex.dll
regsvr32 vbscript.dll
regsvr32 scrrun.dll

1. Click "Start," and then click "Run."
2. Type regsvr32 msscript.ocx in the "Open" box and click "OK."
3. Repeat for dispex.dll,vbscript.dll, and scrrun.dll.

Next, make sure file (open) type .JS is properly associated:
1. In Control Panel, click "Folder Options," and then click "File Types."
2. Locate the .JS extension and click "Advanced."
3. Ensure that the box is check next to "Confirm open after is checked.
4. Under " Actions " click on "Open".
5. Click the "Edit" button. Make sure the "Application to perform
action" field contains:
C:\WINDOWS\System32\WScript.exe "%1" %*
Ensure there is a check in the box next to "Use DDE"
The Application listed is "WScript"
"DDE Application Not Running" box is blank.
Topic: System
Click OK. Click OK. Click Apply, OK.

MowGreen [MVP 2004-2005]
===============
*-343-* FDNY
Never Forgotten
===============


NicolasD wrote:

> Hello, just recently I cannot install Win updates on our W2K3 non SP1 servers.
> The installation history is blank even though I have applied Win updates on
> them last month and beyond? When I scan for updates it shows 0% complete and
> doesnt move from there? I have tried proxycfg -p -d and still no activity on
> our Proxy server. Our XP pro SP2 clients can update via the proxy but not the
> servers?
>
> Thanks,
>
> Nicolas

NicolasD
07-09-2005, 11:35 PM
Thanks for help but am still experiencing the same issues where it shows 0%
complete and no traffic appears on our proxy.

Nicolas

"MowGreen [MVP]" wrote:

> NicolasD,
>
> Give this a try :
>
> Re-register the following files:
> regsvr32 msscript.ocx
> regsvr32 dispex.dll
> regsvr32 vbscript.dll
> regsvr32 scrrun.dll
>
> 1. Click "Start," and then click "Run."
> 2. Type regsvr32 msscript.ocx in the "Open" box and click "OK."
> 3. Repeat for dispex.dll,vbscript.dll, and scrrun.dll.
>
> Next, make sure file (open) type .JS is properly associated:
> 1. In Control Panel, click "Folder Options," and then click "File Types."
> 2. Locate the .JS extension and click "Advanced."
> 3. Ensure that the box is check next to "Confirm open after is checked.
> 4. Under " Actions " click on "Open".
> 5. Click the "Edit" button. Make sure the "Application to perform
> action" field contains:
> C:\WINDOWS\System32\WScript.exe "%1" %*
> Ensure there is a check in the box next to "Use DDE"
> The Application listed is "WScript"
> "DDE Application Not Running" box is blank.
> Topic: System
> Click OK. Click OK. Click Apply, OK.
>
> MowGreen [MVP 2004-2005]
> ===============
> *-343-* FDNY
> Never Forgotten
> ===============
>
>
> NicolasD wrote:
>
> > Hello, just recently I cannot install Win updates on our W2K3 non SP1 servers.
> > The installation history is blank even though I have applied Win updates on
> > them last month and beyond? When I scan for updates it shows 0% complete and
> > doesnt move from there? I have tried proxycfg -p -d and still no activity on
> > our Proxy server. Our XP pro SP2 clients can update via the proxy but not the
> > servers?
> >
> > Thanks,
> >
> > Nicolas
>

MowGreen [MVP]
07-09-2005, 11:35 PM
NicolasD,

Show hidden files and folders via Folder Options in the Control Panel,
View tab. Navigate to the WINDOWS directory and open the
WindowsUpdate.log. Scroll down towards the bottom for the most recent
entries. If you see this entry and error code-
2005-05-12 15:07:49-0700 800 530 CEventCacheFile::Init failed = 80070002
then go here and follow the recommended steps :
http://v5.windowsupdate.microsoft.com/v5consumer/showarticle.aspx?articleid=17&ln=en

If that does not resolve the issue then suspect it may stem from:
1) Damaged/corrupted installation of the XML parser
http://www.microsoft.com/downloads/details.aspx?FamilyID=4a3ad088-a893-4f0b-a932-5e024e74519f&DisplayLang=en
2) Blocking of scripts being run at WU (AV related)
3) Proxy or firewall blocking access to WU

Sorry. That's about all I can offer you. :(

MowGreen [MVP 2004-2005]
===============
*-343-* FDNY
Never Forgotten
===============


NicolasD wrote:

> Thanks for help but am still experiencing the same issues where it shows 0%
> complete and no traffic appears on our proxy.
>
> Nicolas
>
> "MowGreen [MVP]" wrote:
>
>
>>NicolasD,
>>
>>Give this a try :
>>
>>Re-register the following files:
>> regsvr32 msscript.ocx
>> regsvr32 dispex.dll
>> regsvr32 vbscript.dll
>> regsvr32 scrrun.dll
>>
>>1. Click "Start," and then click "Run."
>>2. Type regsvr32 msscript.ocx in the "Open" box and click "OK."
>>3. Repeat for dispex.dll,vbscript.dll, and scrrun.dll.
>>
>>Next, make sure file (open) type .JS is properly associated:
>>1. In Control Panel, click "Folder Options," and then click "File Types."
>>2. Locate the .JS extension and click "Advanced."
>>3. Ensure that the box is check next to "Confirm open after is checked.
>>4. Under " Actions " click on "Open".
>>5. Click the "Edit" button. Make sure the "Application to perform
>>action" field contains:
>>C:\WINDOWS\System32\WScript.exe "%1" %*
>>Ensure there is a check in the box next to "Use DDE"
>>The Application listed is "WScript"
>>"DDE Application Not Running" box is blank.
>>Topic: System
>>Click OK. Click OK. Click Apply, OK.
>>
>>MowGreen [MVP 2004-2005]
>>===============
>> *-343-* FDNY
>>Never Forgotten
>>===============
>>
>>
>>NicolasD wrote:
>>
>>
>>>Hello, just recently I cannot install Win updates on our W2K3 non SP1 servers.
>>>The installation history is blank even though I have applied Win updates on
>>>them last month and beyond? When I scan for updates it shows 0% complete and
>>>doesnt move from there? I have tried proxycfg -p -d and still no activity on
>>>our Proxy server. Our XP pro SP2 clients can update via the proxy but not the
>>>servers?
>>>
>>>Thanks,
>>>
>>>Nicolas
>>


Problems installing Windows updates on W2K3 servers