Re: 0x800a0046 Windows Update Error



Peter Lapic
07-09-2005, 10:35 PM
For reference I will assign your suggestion as F which is the next letter
after the previous suggestions below.
I have tried suggestion F and I still keep getting the error.
So you know, "Everyone" already had Full Control in HKEY_CLASSES_ROOT hive

Regards
Peter

"TaurArian" <taurarianREMOVECAPS@hotmail.com> wrote in message
news:ehWKOaUVFHA.3760@TK2MSFTNGP15.phx.gbl...
> Hi Peter, this information is from my notes, it appears you have tried
> everything else:-
>
> In addition, this issue may occur if you don't have the correct
> permissions set on the HKEY_CLASSES_ROOT hive in the registry.
>
> 1. Click Start > Run
> 2. Enter regedit into the Run field and click OK
> 3. Right-Click on the HKEY_CLASSES_ROOT item and select Permissions
> 4. Please write down the items listed under Group or user name
> 5. Make sure that the Full Control check box under Allow is checked for
> the Administrators group.
> 6. If the only group listed is everyone, make sure Full Control under
> Allow is checked
> 7. Uncheck any boxes that are currently checked in the Deny column
> 8. Click OK
> 9. Register the following DLLs
> wuapi.dll
> wuaueng1.dll
> wuaueng.dll
> wucltui.dll
> 10. Restart the Automatic Updates service by running the following
> commands
> net stop wuauserv
> net start wuauserv
> 11. Restart the BITS service by running the following commands
> net stop bits
> net start bits
>
> http://support.microsoft.com/default.aspx?scid=kb;EN-US;322756
> HOW TO: Back Up, Edit, and Restore the Registry in Windows XP
> Disclaimer: Modifying the registry can cause serious problems that may
> require you to reinstall your operating system. Use the information
> provided at your own risk.
>
>
>
> Peter Lapic wrote:
>> Ever since I updated Windows XP to SP2 am I unable to run Windows
>> Update as I keep getting 0x800a0046 errors.
>> I have even tried Version 6 of Windows Update but I still get the
>> error.
>> I have tried the following suggestions below and NONE of them has
>> fixed my problem. If you can suggest a possible solution that has
>> worked please append it to the end of the list.
>> Regards
>> Peter
>>
>> A. Remove the user account that is experiencing difficulty from the
>> Guests or Limited account groups:
>>
>> 1. Click Start, click Run, type control admintools, and then click OK.
>> 2. Click Computer Management.
>> 3. Expand Local Users and Groups.
>> 4. Select Users.
>> 5. Open the account that is used to access Windows Update.
>> 6. Click the Member Of tab.
>> 7. Select the user account that you want to remove, and then click
>> Remove.
>>
>> B. Set the Security Descriptor:
>> 1. First stop the Automatic Update Service
>>
>> 2. Click Start
>> 3. Choose Run
>> 4. Type cmd and then click OK. Type:
>>
>> sc sdset bits
>>
>> "D:(A;;CCLCSWRPWPDTLOCRRC;;;SY­)(A;;CCDCLCSWRPWPDTLOCRSDRCWDW­O;;;BA)(A;;CCLCSWLOCRRC;;;AU)(­A;;CCLCSWRPWPDTLOCRRC;;;PU)"
>>
>> sc sdset wuauserv D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)
>> (A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)
>> (A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)
>>
>> and then press ENTER.
>>
>> You will receive a "Success" message.
>> 5. Type Exit to close the command prompt.
>> 6. Start Automatic Update Service and try Windows Update again.
>>
>> (NB - You should be able to confirm that this has worked by typing:
>> sc sdshow wuauserv in a command prompt!)
>>
>> C. Verify the Local Administrator and Service account are added to
>> the "Impersonate a client after authentication" security policy.
>>
>> 1. Click Start.
>> 2. Point to Programs.
>> 3. Point to Administrative Tools.
>> 4. Choose Local Security Policy.
>> 5. Expand Local Policies.
>> 6. Choose User Rights Assignment.
>> 7. Double-click to open the Impersonate a client after authentication
>> policy.
>> 8. On the Local Security Setting tab, add the Service and
>> Administrator to the list of Users and Groups.
>> 9. Click OK.
>> 10. Restart the system.
>>
>> D. The "Automatic Updates" service is not running as the correct user.
>> 1. To check/fix this, find "Automatic Updates" in the services list
>> and choose "properties".
>> 2. Then select the "Log On" tab and make sure the button for "Local
>> System Account" is selected.
>> 3. If it isn't, then close the window and restart the system.
>>
>> E. Enable Userdata Persistence in Internet Explorer
>> 1.. Start Internet Explorer.
>> 2.. On the Tools menu, click Internet Options.
>> 3.. Select the Security tab.
>> 4.. Select the Internet Web zone icon.
>> 5.. To adjust the security level, click Custom Level.
>> 6.. Under Miscellaneous enable Userdata persistence.
>> 7.. The Are you sure you want to change the security settings for
>> this zone dialog box opens.
>> 8.. Click Yes.
>> 9.. Click OK.
>> 10.. Try Windows Update again.
>

TaurArian
07-09-2005, 10:35 PM
Hope you have better luck with suggestion "G"
Kaylene

"Peter Lapic" wrote:

> For reference I will assign your suggestion as F which is the next letter
> after the previous suggestions below.
> I have tried suggestion F and I still keep getting the error.
> So you know, "Everyone" already had Full Control in HKEY_CLASSES_ROOT hive
>
> Regards
> Peter
>
> "TaurArian" <taurarianREMOVECAPS@hotmail.com> wrote in message
> news:ehWKOaUVFHA.3760@TK2MSFTNGP15.phx.gbl...
> > Hi Peter, this information is from my notes, it appears you have tried
> > everything else:-
> >
> > In addition, this issue may occur if you don't have the correct
> > permissions set on the HKEY_CLASSES_ROOT hive in the registry.
> >
> > 1. Click Start > Run
> > 2. Enter regedit into the Run field and click OK
> > 3. Right-Click on the HKEY_CLASSES_ROOT item and select Permissions
> > 4. Please write down the items listed under Group or user name
> > 5. Make sure that the Full Control check box under Allow is checked for
> > the Administrators group.
> > 6. If the only group listed is everyone, make sure Full Control under
> > Allow is checked
> > 7. Uncheck any boxes that are currently checked in the Deny column
> > 8. Click OK
> > 9. Register the following DLLs
> > wuapi.dll
> > wuaueng1.dll
> > wuaueng.dll
> > wucltui.dll
> > 10. Restart the Automatic Updates service by running the following
> > commands
> > net stop wuauserv
> > net start wuauserv
> > 11. Restart the BITS service by running the following commands
> > net stop bits
> > net start bits
> >
> > http://support.microsoft.com/default.aspx?scid=kb;EN-US;322756
> > HOW TO: Back Up, Edit, and Restore the Registry in Windows XP
> > Disclaimer: Modifying the registry can cause serious problems that may
> > require you to reinstall your operating system. Use the information
> > provided at your own risk.
> >
> >
> >
> > Peter Lapic wrote:
> >> Ever since I updated Windows XP to SP2 am I unable to run Windows
> >> Update as I keep getting 0x800a0046 errors.
> >> I have even tried Version 6 of Windows Update but I still get the
> >> error.
> >> I have tried the following suggestions below and NONE of them has
> >> fixed my problem. If you can suggest a possible solution that has
> >> worked please append it to the end of the list.
> >> Regards
> >> Peter
> >>
> >> A. Remove the user account that is experiencing difficulty from the
> >> Guests or Limited account groups:
> >>
> >> 1. Click Start, click Run, type control admintools, and then click OK.
> >> 2. Click Computer Management.
> >> 3. Expand Local Users and Groups.
> >> 4. Select Users.
> >> 5. Open the account that is used to access Windows Update.
> >> 6. Click the Member Of tab.
> >> 7. Select the user account that you want to remove, and then click
> >> Remove.
> >>
> >> B. Set the Security Descriptor:
> >> 1. First stop the Automatic Update Service
> >>
> >> 2. Click Start
> >> 3. Choose Run
> >> 4. Type cmd and then click OK. Type:
> >>
> >> sc sdset bits
> >>
> >> "D:(A;;CCLCSWRPWPDTLOCRRC;;;SY­)(A;;CCDCLCSWRPWPDTLOCRSDRCWDW­O;;;BA)(A;;CCLCSWLOCRRC;;;AU)(­A;;CCLCSWRPWPDTLOCRRC;;;PU)"
> >>
> >> sc sdset wuauserv D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)
> >> (A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)
> >> (A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)
> >>
> >> and then press ENTER.
> >>
> >> You will receive a "Success" message.
> >> 5. Type Exit to close the command prompt.
> >> 6. Start Automatic Update Service and try Windows Update again.
> >>
> >> (NB - You should be able to confirm that this has worked by typing:
> >> sc sdshow wuauserv in a command prompt!)
> >>
> >> C. Verify the Local Administrator and Service account are added to
> >> the "Impersonate a client after authentication" security policy.
> >>
> >> 1. Click Start.
> >> 2. Point to Programs.
> >> 3. Point to Administrative Tools.
> >> 4. Choose Local Security Policy.
> >> 5. Expand Local Policies.
> >> 6. Choose User Rights Assignment.
> >> 7. Double-click to open the Impersonate a client after authentication
> >> policy.
> >> 8. On the Local Security Setting tab, add the Service and
> >> Administrator to the list of Users and Groups.
> >> 9. Click OK.
> >> 10. Restart the system.
> >>
> >> D. The "Automatic Updates" service is not running as the correct user.
> >> 1. To check/fix this, find "Automatic Updates" in the services list
> >> and choose "properties".
> >> 2. Then select the "Log On" tab and make sure the button for "Local
> >> System Account" is selected.
> >> 3. If it isn't, then close the window and restart the system.
> >>
> >> E. Enable Userdata Persistence in Internet Explorer
> >> 1.. Start Internet Explorer.
> >> 2.. On the Tools menu, click Internet Options.
> >> 3.. Select the Security tab.
> >> 4.. Select the Internet Web zone icon.
> >> 5.. To adjust the security level, click Custom Level.
> >> 6.. Under Miscellaneous enable Userdata persistence.
> >> 7.. The Are you sure you want to change the security settings for
> >> this zone dialog box opens.
> >> 8.. Click Yes.
> >> 9.. Click OK.
> >> 10.. Try Windows Update again.
> >
>
>
>


Re: 0x800a0046 Windows Update Error