Problem with Flash and https on IE6



Edika
07-09-2005, 10:17 PM
I have a problem to view a flash file on Internet Explorer 6 with https.
If I try to see the page with normal http protocol the flash file run correctly, if I try to open the same page with https protocol the flash does not appear and looks like continue loading
infinitely. This only with IE6, if I tra to open with mozilla or Firefox everything is ok.
Look at this link to a test page.

http://secure.luxornet.com/flash.html this run correctly
https://secure.luxornet.com/flash.html this doesn't run at all

Do you know any known problem about that?

Thanks

Edika

Jon Kennedy
07-09-2005, 10:17 PM
I believe this is a security-related issue - I'm seeing the same thing here
as you are - that the .swf movie might be being called from a https://
server.
Try setting the MovieName property to
"https://www.mywebsite.com/mymovie.swf.

http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=tn_18860
http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=tn_14213
http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=tn_16629

Cross-browser info for Flash:
http://developer-test.mozilla.org/en/docs/Using_the_Right_Markup_to_Invoke_Plugins
--

Jon R. Kennedy
Charlotte, NC, USA
jkennedy2@carolina.rr.com

"Edika" <webmaster@luxornet.com> wrote in message
news:6m0nc156d47iaikdsrmg81od50fdml4kdi@4ax.com...
>I have a problem to view a flash file on Internet Explorer 6 with https.
> If I try to see the page with normal http protocol the flash file run
> correctly, if I try to open the same page with https protocol the flash
> does not appear and looks like continue loading
> infinitely. This only with IE6, if I tra to open with mozilla or Firefox
> everything is ok.
> Look at this link to a test page.
>
> http://secure.luxornet.com/flash.html this run correctly
> https://secure.luxornet.com/flash.html this doesn't run at all
>
> Do you know any known problem about that?
>
> Thanks
>
> Edika


Problem with Flash and https on IE6