Internet Explorer opens links in new windows...



alba1314
07-09-2005, 10:16 PM
I am running Internet Explorer version 6.0.2900.2180.xpsp_sp2_gdr.050301-1519
and find that, recently, Internet Explorer opens links in new windows... How
can I stop this from happening?

I have looked at Internet Options> Advanced and there does not appear to be
any option here to either give IE permission to open new windows from links,
or to stop IE from opening new windows from links?!

Can anyone please advise?

Frank Saunders, MS-MVP IE/OE
07-09-2005, 10:16 PM
"alba1314" <alba1314@discussions.microsoft.com> wrote in message
news:5718B46F-C934-4EB1-B60E-BA9DB97F62DE@microsoft.com
> I am running Internet Explorer version
> 6.0.2900.2180.xpsp_sp2_gdr.050301-1519 and find that, recently,
> Internet Explorer opens links in new windows... How can I stop this
> from happening?
>
> I have looked at Internet Options> Advanced and there does not appear
> to be any option here to either give IE permission to open new
> windows from links, or to stop IE from opening new windows from
> links?!
>
> Can anyone please advise?

Make sure the option is checked to "Reuse windows for launching shortcuts".

--
Frank Saunders, MS-MVP, IE/OE
Please respond in Newsgroup only. Do not send email
http://www.fjsmjs.com
Protect your PC
http://www.microsoft.com./athome/security/protect/default.aspx
http://defendingyourmachine.blogspot.com/

alba1314
07-09-2005, 10:16 PM
Hi Frank,

Thanks for the reply - Unfortunately, this did not help. I already had
"Reuse windows for launching shortcuts" checked, so I unchecked it, clicked
"Apply" and closed IE. I then opened IE again and clicked a link... It
opened in another IE window!

I then went back and checked "Reuse windows for launching shortcuts" and
clicked on "Apply" before closing IE down again and opened it up again to
click on a different link again - But, it opened in another IE window?!

Any other suggestions?



"Frank Saunders, MS-MVP IE/OE" wrote:

> "alba1314" <alba1314@discussions.microsoft.com> wrote in message
> news:5718B46F-C934-4EB1-B60E-BA9DB97F62DE@microsoft.com
> > I am running Internet Explorer version
> > 6.0.2900.2180.xpsp_sp2_gdr.050301-1519 and find that, recently,
> > Internet Explorer opens links in new windows... How can I stop this
> > from happening?
> >
> > I have looked at Internet Options> Advanced and there does not appear
> > to be any option here to either give IE permission to open new
> > windows from links, or to stop IE from opening new windows from
> > links?!
> >
> > Can anyone please advise?
>
> Make sure the option is checked to "Reuse windows for launching shortcuts".
>
> --
> Frank Saunders, MS-MVP, IE/OE
> Please respond in Newsgroup only. Do not send email
> http://www.fjsmjs.com
> Protect your PC
> http://www.microsoft.com./athome/security/protect/default.aspx
> http://defendingyourmachine.blogspot.com/
>
>
>

Peter Foldes
07-09-2005, 10:17 PM
Do you have a Tweaking program such as X-Setup installed and the option set in there

--
Peter

Please Reply to Newsgroup for the benefit of others
Requests for assistance by email can not and will not be acknowledged.

"alba1314" <alba1314@discussions.microsoft.com> wrote in message news:FF99D184-C6F3-49F7-8080-4144A6F44458@microsoft.com...
> Hi Frank,
>
> Thanks for the reply - Unfortunately, this did not help. I already had
> "Reuse windows for launching shortcuts" checked, so I unchecked it, clicked
> "Apply" and closed IE. I then opened IE again and clicked a link... It
> opened in another IE window!
>
> I then went back and checked "Reuse windows for launching shortcuts" and
> clicked on "Apply" before closing IE down again and opened it up again to
> click on a different link again - But, it opened in another IE window?!
>
> Any other suggestions?
>
>
>
> "Frank Saunders, MS-MVP IE/OE" wrote:
>
> > "alba1314" <alba1314@discussions.microsoft.com> wrote in message
> > news:5718B46F-C934-4EB1-B60E-BA9DB97F62DE@microsoft.com
> > > I am running Internet Explorer version
> > > 6.0.2900.2180.xpsp_sp2_gdr.050301-1519 and find that, recently,
> > > Internet Explorer opens links in new windows... How can I stop this
> > > from happening?
> > >
> > > I have looked at Internet Options> Advanced and there does not appear
> > > to be any option here to either give IE permission to open new
> > > windows from links, or to stop IE from opening new windows from
> > > links?!
> > >
> > > Can anyone please advise?
> >
> > Make sure the option is checked to "Reuse windows for launching shortcuts".
> >
> > --
> > Frank Saunders, MS-MVP, IE/OE
> > Please respond in Newsgroup only. Do not send email
> > http://www.fjsmjs.com
> > Protect your PC
> > http://www.microsoft.com./athome/security/protect/default.aspx
> > http://defendingyourmachine.blogspot.com/
> >
> >
> >

alba1314
07-09-2005, 10:17 PM
Nothing at all like that, Peter.

I vaguely recall a Microsoft site - definitely Microsoft - that I visited
where I might have chosen to open links in new pages. This will most
probably have been done whilst installing Microsoft Updates, but I cannot
remember the page where I may have selected this change??

"Peter Foldes" wrote:

> Do you have a Tweaking program such as X-Setup installed and the option set in there
>
> --
> Peter
>
> Please Reply to Newsgroup for the benefit of others
> Requests for assistance by email can not and will not be acknowledged.
>
> "alba1314" <alba1314@discussions.microsoft.com> wrote in message news:FF99D184-C6F3-49F7-8080-4144A6F44458@microsoft.com...
> > Hi Frank,
> >
> > Thanks for the reply - Unfortunately, this did not help. I already had
> > "Reuse windows for launching shortcuts" checked, so I unchecked it, clicked
> > "Apply" and closed IE. I then opened IE again and clicked a link... It
> > opened in another IE window!
> >
> > I then went back and checked "Reuse windows for launching shortcuts" and
> > clicked on "Apply" before closing IE down again and opened it up again to
> > click on a different link again - But, it opened in another IE window?!
> >
> > Any other suggestions?
> >
> >
> >
> > "Frank Saunders, MS-MVP IE/OE" wrote:
> >
> > > "alba1314" <alba1314@discussions.microsoft.com> wrote in message
> > > news:5718B46F-C934-4EB1-B60E-BA9DB97F62DE@microsoft.com
> > > > I am running Internet Explorer version
> > > > 6.0.2900.2180.xpsp_sp2_gdr.050301-1519 and find that, recently,
> > > > Internet Explorer opens links in new windows... How can I stop this
> > > > from happening?
> > > >
> > > > I have looked at Internet Options> Advanced and there does not appear
> > > > to be any option here to either give IE permission to open new
> > > > windows from links, or to stop IE from opening new windows from
> > > > links?!
> > > >
> > > > Can anyone please advise?
> > >
> > > Make sure the option is checked to "Reuse windows for launching shortcuts".
> > >
> > > --
> > > Frank Saunders, MS-MVP, IE/OE
> > > Please respond in Newsgroup only. Do not send email
> > > http://www.fjsmjs.com
> > > Protect your PC
> > > http://www.microsoft.com./athome/security/protect/default.aspx
> > > http://defendingyourmachine.blogspot.com/
> > >
> > >
> > >
>

Robert Aldwinckle
07-09-2005, 10:17 PM
"alba1314" <alba1314@discussions.microsoft.com> wrote in message
news:FF99D184-C6F3-49F7-8080-4144A6F44458@microsoft.com...
> Hi Frank,
>
> Thanks for the reply - Unfortunately, this did not help. I already had
> "Reuse windows for launching shortcuts" checked, so I unchecked it, clicked
> "Apply" and closed IE. I then opened IE again and clicked a link... It
> opened in another IE window!
>
> I then went back and checked "Reuse windows for launching shortcuts" and
> clicked on "Apply" before closing IE down again and opened it up again to
> click on a different link again - But, it opened in another IE window?!
>
> Any other suggestions?


Try the list of regsvr32 commands given in KB831429
It represents a significant subset of the old IE Repair (ref. KB194177)
plus the suggestion to re-register shell32.dll and msjava.dll
Note: msjava.dll may not be installed if you don't have MS Java

The re-initialization which will most likely fix your symptom is:

regsvr32 /i shdocvw.dll


---


>
>
>
> "Frank Saunders, MS-MVP IE/OE" wrote:
>
>> "alba1314" <alba1314@discussions.microsoft.com> wrote in message
>> news:5718B46F-C934-4EB1-B60E-BA9DB97F62DE@microsoft.com
>> > I am running Internet Explorer version
>> > 6.0.2900.2180.xpsp_sp2_gdr.050301-1519 and find that, recently,
>> > Internet Explorer opens links in new windows... How can I stop this
>> > from happening?
>> >
>> > I have looked at Internet Options> Advanced and there does not appear
>> > to be any option here to either give IE permission to open new
>> > windows from links, or to stop IE from opening new windows from
>> > links?!
>> >
>> > Can anyone please advise?
>>
>> Make sure the option is checked to "Reuse windows for launching shortcuts".
>>
>> --
>> Frank Saunders, MS-MVP, IE/OE
>> Please respond in Newsgroup only. Do not send email
>> http://www.fjsmjs.com
>> Protect your PC
>> http://www.microsoft.com./athome/security/protect/default.aspx
>> http://defendingyourmachine.blogspot.com/
>>
>>
>>

alba1314
07-09-2005, 10:17 PM
I appreciate the reply, Robert and have saved it to copy, as I am pleased to
say that the problem seems to have resolved itself?! I don't know how it did
so, but now links appear to open in same IE browser, rather than separate
windows... I'm glad to report!

To all who replied, my thanks!!

"Robert Aldwinckle" wrote:

> "alba1314" <alba1314@discussions.microsoft.com> wrote in message
> news:FF99D184-C6F3-49F7-8080-4144A6F44458@microsoft.com...
> > Hi Frank,
> >
> > Thanks for the reply - Unfortunately, this did not help. I already had
> > "Reuse windows for launching shortcuts" checked, so I unchecked it, clicked
> > "Apply" and closed IE. I then opened IE again and clicked a link... It
> > opened in another IE window!
> >
> > I then went back and checked "Reuse windows for launching shortcuts" and
> > clicked on "Apply" before closing IE down again and opened it up again to
> > click on a different link again - But, it opened in another IE window?!
> >
> > Any other suggestions?
>
>
> Try the list of regsvr32 commands given in KB831429
> It represents a significant subset of the old IE Repair (ref. KB194177)
> plus the suggestion to re-register shell32.dll and msjava.dll
> Note: msjava.dll may not be installed if you don't have MS Java
>
> The re-initialization which will most likely fix your symptom is:
>
> regsvr32 /i shdocvw.dll
>
>
> ---
>
>
> >
> >
> >
> > "Frank Saunders, MS-MVP IE/OE" wrote:
> >
> >> "alba1314" <alba1314@discussions.microsoft.com> wrote in message
> >> news:5718B46F-C934-4EB1-B60E-BA9DB97F62DE@microsoft.com
> >> > I am running Internet Explorer version
> >> > 6.0.2900.2180.xpsp_sp2_gdr.050301-1519 and find that, recently,
> >> > Internet Explorer opens links in new windows... How can I stop this
> >> > from happening?
> >> >
> >> > I have looked at Internet Options> Advanced and there does not appear
> >> > to be any option here to either give IE permission to open new
> >> > windows from links, or to stop IE from opening new windows from
> >> > links?!
> >> >
> >> > Can anyone please advise?
> >>
> >> Make sure the option is checked to "Reuse windows for launching shortcuts".
> >>
> >> --
> >> Frank Saunders, MS-MVP, IE/OE
> >> Please respond in Newsgroup only. Do not send email
> >> http://www.fjsmjs.com
> >> Protect your PC
> >> http://www.microsoft.com./athome/security/protect/default.aspx
> >> http://defendingyourmachine.blogspot.com/
> >>
> >>
> >>
>
>
>
>


Internet Explorer opens links in new windows...