USMT Error Code 487



Dominik_Vienna
07-10-2005, 02:15 AM
Dear all,

I've a problem using USMT to migrate profiles from Windows NT to Windows XP
Pro and hopefully you can help me, cause I'm under pressure to solve the
situation.

I'm migrating ~200 PCs from NT to XP using USMT.
The strange thing is, that on half of the systems USMT is working really fine.
But sometimes the migration engine cannot start due to failure 487 - cannot
access specific address or something like that.

I'm migrating Windows NT 4 SP 6 German Version to Windows XP Pro SP 1
English Version with German LanguagePack.

See the following log:

Info Command line used: \\jonny\dip$\tools\USMT\scanstate.exe
\\smart\alle\scanstate\atnetzfe\edering /i
\\jonny\dip$\tools\USMT\migsys.inf /i
\\jonny\dip$\tools\USMT\miguser.inf /i
\\jonny\dip$\tools\USMT\sysfiles.inf /l:x:\scanstate.log /v:7
/user:atnetzfe\edering

Status scanstate.exe: 5.2.3790.1265 U
Status Environment variable %ComSpec% is set to
"C:\WINNT\system32\cmd.exe" on the destination platform for NT
AUTHORITY\SYSTEM.

[...]


Info Total accounts: 9
Info Failed to determine: 1
*S-1-5-21-132666782-920464196-1691616715-1287


Info Interactive accounts: 8
CPQ020813001\adminsys
ATNETZFE\BEGUTTER
ATNETZFE\HRUBEC
ATNETZFE\Firzinge
ATNETZFE\KROTTEND
ATNETZFE\WOLFJ
ATNETZFE\EDERING
ATNETZ\AIGNER


Status Environment variable %ComSpec% is set to
"C:\WINNT\system32\cmd.exe" on the source platform for NT
AUTHORITY\SYSTEM.

[...]

Status Environment variable %CSIDL_SYSTEM% is set to
"C:\WINNT\System32" on the source platform for ATNETZFE\EDERING.

Status Environment variable %CSIDL_SYSTEMX86% is set to
"C:\WINNT\System32" on the source platform for ATNETZFE\EDERING.

Status Environment variable %CSIDL_WINDOWS% is set to "C:\WINNT" on
the
source platform for ATNETZFE\EDERING.

Info User ATNETZFE\Firzinge is not a selected user, skipping.
Info User ATNETZFE\HRUBEC is not a selected user, skipping.
Info User ATNETZFE\KROTTEND is not a selected user, skipping.
Info User ATNETZFE\WOLFJ is not a selected user, skipping.
Info User CPQ020813001\adminsys is not a selected user, skipping.
Warning Cannot register module SCRIPT because LoadLibrary failed
Info Error 487: Es wurde versucht, auf eine unzulässige Adresse
zuzugreifen.


Info Module SCRIPT will not be processed
Warning Cannot register module CERTIFICATES because LoadLibrary failed
Info Error 487: Es wurde versucht, auf eine unzulässige Adresse
zuzugreifen.


Info Module CERTIFICATES will not be processed
Warning Cannot register module ACCESSIBILITY because LoadLibrary failed
Info Error 487: Es wurde versucht, auf eine unzulässige Adresse
zuzugreifen.


Info Module ACCESSIBILITY will not be processed
Warning Cannot register module COOKIES because LoadLibrary failed
Info Error 487: Es wurde versucht, auf eine unzulässige Adresse
zuzugreifen.


Info Module COOKIES will not be processed
Warning Cannot register module PRINTERS because LoadLibrary failed
Info Error 487: Es wurde versucht, auf eine unzulässige Adresse
zuzugreifen.


Info Module PRINTERS will not be processed
Warning Cannot register module RAS because LoadLibrary failed
Info Error 487: Es wurde versucht, auf eine unzulässige Adresse
zuzugreifen.


Info Module RAS will not be processed
Warning Cannot register module NETDRIVES because LoadLibrary failed
Info Error 487: Es wurde versucht, auf eine unzulässige Adresse
zuzugreifen.


Info Module NETDRIVES will not be processed
Fatal Error An error occurred starting the migration engine type modules.
[ERROR=2]

Info Error 2: Das System kann die angegebene Datei nicht finden.

Info Scanstate is exiting.


So, whats that error and what is it, that the system wants to access??

Hope, you can help me!!

Regards Dominik

Michael Niehaus [MS]
07-10-2005, 02:15 AM
I believe you need to add MIGISM.INF to your command line, as the modules
that the log is complaining about are all defined in that INF.

-Michael Niehaus
Senior Consultant
MCS US Centers of Excellence - Deployment AOS
mniehaus@microsoft.com
This posting is provided "AS IS" with no warranties, and confers no rights.

"Dominik_Vienna" <Dominik_Vienna@discussions.microsoft.com> wrote in message
news:C63C27EB-DBAB-46FE-B80F-F8EA8EA5E26D@microsoft.com...
> Dear all,
>
> I've a problem using USMT to migrate profiles from Windows NT to Windows
> XP
> Pro and hopefully you can help me, cause I'm under pressure to solve the
> situation.
>
> I'm migrating ~200 PCs from NT to XP using USMT.
> The strange thing is, that on half of the systems USMT is working really
> fine.
> But sometimes the migration engine cannot start due to failure 487 -
> cannot
> access specific address or something like that.
>
> I'm migrating Windows NT 4 SP 6 German Version to Windows XP Pro SP 1
> English Version with German LanguagePack.
>
> See the following log:
>
> Info Command line used: \\jonny\dip$\tools\USMT\scanstate.exe
> \\smart\alle\scanstate\atnetzfe\edering /i
> \\jonny\dip$\tools\USMT\migsys.inf /i
> \\jonny\dip$\tools\USMT\miguser.inf /i
> \\jonny\dip$\tools\USMT\sysfiles.inf /l:x:\scanstate.log /v:7
> /user:atnetzfe\edering
>
> Status scanstate.exe: 5.2.3790.1265 U
> Status Environment variable %ComSpec% is set to
> "C:\WINNT\system32\cmd.exe" on the destination platform for
> NT
> AUTHORITY\SYSTEM.
>
> [...]
>
>
> Info Total accounts: 9
> Info Failed to determine: 1
> *S-1-5-21-132666782-920464196-1691616715-1287
>
>
> Info Interactive accounts: 8
> CPQ020813001\adminsys
> ATNETZFE\BEGUTTER
> ATNETZFE\HRUBEC
> ATNETZFE\Firzinge
> ATNETZFE\KROTTEND
> ATNETZFE\WOLFJ
> ATNETZFE\EDERING
> ATNETZ\AIGNER
>
>
> Status Environment variable %ComSpec% is set to
> "C:\WINNT\system32\cmd.exe" on the source platform for NT
> AUTHORITY\SYSTEM.
>
> [...]
>
> Status Environment variable %CSIDL_SYSTEM% is set to
> "C:\WINNT\System32" on the source platform for
> ATNETZFE\EDERING.
>
> Status Environment variable %CSIDL_SYSTEMX86% is set to
> "C:\WINNT\System32" on the source platform for
> ATNETZFE\EDERING.
>
> Status Environment variable %CSIDL_WINDOWS% is set to "C:\WINNT" on
> the
> source platform for ATNETZFE\EDERING.
>
> Info User ATNETZFE\Firzinge is not a selected user, skipping.
> Info User ATNETZFE\HRUBEC is not a selected user, skipping.
> Info User ATNETZFE\KROTTEND is not a selected user, skipping.
> Info User ATNETZFE\WOLFJ is not a selected user, skipping.
> Info User CPQ020813001\adminsys is not a selected user, skipping.
> Warning Cannot register module SCRIPT because LoadLibrary failed
> Info Error 487: Es wurde versucht, auf eine unzulssige Adresse
> zuzugreifen.
>
>
> Info Module SCRIPT will not be processed
> Warning Cannot register module CERTIFICATES because LoadLibrary
> failed
> Info Error 487: Es wurde versucht, auf eine unzulssige Adresse
> zuzugreifen.
>
>
> Info Module CERTIFICATES will not be processed
> Warning Cannot register module ACCESSIBILITY because LoadLibrary
> failed
> Info Error 487: Es wurde versucht, auf eine unzulssige Adresse
> zuzugreifen.
>
>
> Info Module ACCESSIBILITY will not be processed
> Warning Cannot register module COOKIES because LoadLibrary failed
> Info Error 487: Es wurde versucht, auf eine unzulssige Adresse
> zuzugreifen.
>
>
> Info Module COOKIES will not be processed
> Warning Cannot register module PRINTERS because LoadLibrary failed
> Info Error 487: Es wurde versucht, auf eine unzulssige Adresse
> zuzugreifen.
>
>
> Info Module PRINTERS will not be processed
> Warning Cannot register module RAS because LoadLibrary failed
> Info Error 487: Es wurde versucht, auf eine unzulssige Adresse
> zuzugreifen.
>
>
> Info Module RAS will not be processed
> Warning Cannot register module NETDRIVES because LoadLibrary failed
> Info Error 487: Es wurde versucht, auf eine unzulssige Adresse
> zuzugreifen.
>
>
> Info Module NETDRIVES will not be processed
> Fatal Error An error occurred starting the migration engine type
> modules.
> [ERROR=2]
>
> Info Error 2: Das System kann die angegebene Datei nicht finden.
>
> Info Scanstate is exiting.
>
>
> So, whats that error and what is it, that the system wants to access??
>
> Hope, you can help me!!
>
> Regards Dominik

Dominik_Vienna
07-10-2005, 02:15 AM
Thanks for the answer, but inserting the migism.inf didn't solve the problem.
Same failure, no difference.

Dominik

"Michael Niehaus [MS]" wrote:

> I believe you need to add MIGISM.INF to your command line, as the modules
> that the log is complaining about are all defined in that INF.
>
> -Michael Niehaus
> Senior Consultant
> MCS US Centers of Excellence - Deployment AOS
> mniehaus@microsoft.com
> This posting is provided "AS IS" with no warranties, and confers no rights.
>
> "Dominik_Vienna" <Dominik_Vienna@discussions.microsoft.com> wrote in message
> news:C63C27EB-DBAB-46FE-B80F-F8EA8EA5E26D@microsoft.com...
> > Dear all,
> >
> > I've a problem using USMT to migrate profiles from Windows NT to Windows
> > XP
> > Pro and hopefully you can help me, cause I'm under pressure to solve the
> > situation.
> >
> > I'm migrating ~200 PCs from NT to XP using USMT.
> > The strange thing is, that on half of the systems USMT is working really
> > fine.
> > But sometimes the migration engine cannot start due to failure 487 -
> > cannot
> > access specific address or something like that.
> >
> > I'm migrating Windows NT 4 SP 6 German Version to Windows XP Pro SP 1
> > English Version with German LanguagePack.
> >
> > See the following log:
> >
> > Info Command line used: \\jonny\dip$\tools\USMT\scanstate.exe
> > \\smart\alle\scanstate\atnetzfe\edering /i
> > \\jonny\dip$\tools\USMT\migsys.inf /i
> > \\jonny\dip$\tools\USMT\miguser.inf /i
> > \\jonny\dip$\tools\USMT\sysfiles.inf /l:x:\scanstate.log /v:7
> > /user:atnetzfe\edering
> >
> > Status scanstate.exe: 5.2.3790.1265 U
> > Status Environment variable %ComSpec% is set to
> > "C:\WINNT\system32\cmd.exe" on the destination platform for
> > NT
> > AUTHORITY\SYSTEM.
> >
> > [...]
> >
> >
> > Info Total accounts: 9
> > Info Failed to determine: 1
> > *S-1-5-21-132666782-920464196-1691616715-1287
> >
> >
> > Info Interactive accounts: 8
> > CPQ020813001\adminsys
> > ATNETZFE\BEGUTTER
> > ATNETZFE\HRUBEC
> > ATNETZFE\Firzinge
> > ATNETZFE\KROTTEND
> > ATNETZFE\WOLFJ
> > ATNETZFE\EDERING
> > ATNETZ\AIGNER
> >
> >
> > Status Environment variable %ComSpec% is set to
> > "C:\WINNT\system32\cmd.exe" on the source platform for NT
> > AUTHORITY\SYSTEM.
> >
> > [...]
> >
> > Status Environment variable %CSIDL_SYSTEM% is set to
> > "C:\WINNT\System32" on the source platform for
> > ATNETZFE\EDERING.
> >
> > Status Environment variable %CSIDL_SYSTEMX86% is set to
> > "C:\WINNT\System32" on the source platform for
> > ATNETZFE\EDERING.
> >
> > Status Environment variable %CSIDL_WINDOWS% is set to "C:\WINNT" on
> > the
> > source platform for ATNETZFE\EDERING.
> >
> > Info User ATNETZFE\Firzinge is not a selected user, skipping.
> > Info User ATNETZFE\HRUBEC is not a selected user, skipping.
> > Info User ATNETZFE\KROTTEND is not a selected user, skipping.
> > Info User ATNETZFE\WOLFJ is not a selected user, skipping.
> > Info User CPQ020813001\adminsys is not a selected user, skipping.
> > Warning Cannot register module SCRIPT because LoadLibrary failed
> > Info Error 487: Es wurde versucht, auf eine unzulässige Adresse
> > zuzugreifen.
> >
> >
> > Info Module SCRIPT will not be processed
> > Warning Cannot register module CERTIFICATES because LoadLibrary
> > failed
> > Info Error 487: Es wurde versucht, auf eine unzulässige Adresse
> > zuzugreifen.
> >
> >
> > Info Module CERTIFICATES will not be processed
> > Warning Cannot register module ACCESSIBILITY because LoadLibrary
> > failed
> > Info Error 487: Es wurde versucht, auf eine unzulässige Adresse
> > zuzugreifen.
> >
> >
> > Info Module ACCESSIBILITY will not be processed
> > Warning Cannot register module COOKIES because LoadLibrary failed
> > Info Error 487: Es wurde versucht, auf eine unzulässige Adresse
> > zuzugreifen.
> >
> >
> > Info Module COOKIES will not be processed
> > Warning Cannot register module PRINTERS because LoadLibrary failed
> > Info Error 487: Es wurde versucht, auf eine unzulässige Adresse
> > zuzugreifen.
> >
> >
> > Info Module PRINTERS will not be processed
> > Warning Cannot register module RAS because LoadLibrary failed
> > Info Error 487: Es wurde versucht, auf eine unzulässige Adresse
> > zuzugreifen.
> >
> >
> > Info Module RAS will not be processed
> > Warning Cannot register module NETDRIVES because LoadLibrary failed
> > Info Error 487: Es wurde versucht, auf eine unzulässige Adresse
> > zuzugreifen.
> >
> >
> > Info Module NETDRIVES will not be processed
> > Fatal Error An error occurred starting the migration engine type
> > modules.
> > [ERROR=2]
> >
> > Info Error 2: Das System kann die angegebene Datei nicht finden.
> >
> > Info Scanstate is exiting.
> >
> >
> > So, whats that error and what is it, that the system wants to access??
> >
> > Hope, you can help me!!
> >
> > Regards Dominik
>
>
>

Michael Niehaus [MS]
07-10-2005, 02:16 AM
The only other time I've seen an error like this is when there are files
missing from the folder you are running USMT 2.6 from. (There should be 21
files in total, including EXE's, DLL's, and INF's.) The errors indicate
that it can't load a DLL.

If you have all of these files and are still having issues, I would suggest
contact Microsoft product support. (You could also use something like
Sysinternal's FileMon to see what DLL it is trying to load that results in
the error.)

-Michael Niehaus
Senior Consultant
MCS US Centers of Excellence - Deployment AOS
mniehaus@microsoft.com
This posting is provided "AS IS" with no warranties, and confers no rights.

"Dominik_Vienna" <DominikVienna@discussions.microsoft.com> wrote in message
news:4B704E9E-8E72-4F53-96E8-9880A35C08F1@microsoft.com...
> Thanks for the answer, but inserting the migism.inf didn't solve the
> problem.
> Same failure, no difference.
>
> Dominik
>
> "Michael Niehaus [MS]" wrote:
>
>> I believe you need to add MIGISM.INF to your command line, as the modules
>> that the log is complaining about are all defined in that INF.
>>
>> -Michael Niehaus
>> Senior Consultant
>> MCS US Centers of Excellence - Deployment AOS
>> mniehaus@microsoft.com
>> This posting is provided "AS IS" with no warranties, and confers no
>> rights.
>>
>> "Dominik_Vienna" <Dominik_Vienna@discussions.microsoft.com> wrote in
>> message
>> news:C63C27EB-DBAB-46FE-B80F-F8EA8EA5E26D@microsoft.com...
>> > Dear all,
>> >
>> > I've a problem using USMT to migrate profiles from Windows NT to
>> > Windows
>> > XP
>> > Pro and hopefully you can help me, cause I'm under pressure to solve
>> > the
>> > situation.
>> >
>> > I'm migrating ~200 PCs from NT to XP using USMT.
>> > The strange thing is, that on half of the systems USMT is working
>> > really
>> > fine.
>> > But sometimes the migration engine cannot start due to failure 487 -
>> > cannot
>> > access specific address or something like that.
>> >
>> > I'm migrating Windows NT 4 SP 6 German Version to Windows XP Pro SP 1
>> > English Version with German LanguagePack.
>> >
>> > See the following log:
>> >
>> > Info Command line used: \\jonny\dip$\tools\USMT\scanstate.exe
>> > \\smart\alle\scanstate\atnetzfe\edering /i
>> > \\jonny\dip$\tools\USMT\migsys.inf /i
>> > \\jonny\dip$\tools\USMT\miguser.inf /i
>> > \\jonny\dip$\tools\USMT\sysfiles.inf /l:x:\scanstate.log
>> > /v:7
>> > /user:atnetzfe\edering
>> >
>> > Status scanstate.exe: 5.2.3790.1265 U
>> > Status Environment variable %ComSpec% is set to
>> > "C:\WINNT\system32\cmd.exe" on the destination platform
>> > for
>> > NT
>> > AUTHORITY\SYSTEM.
>> >
>> > [...]
>> >
>> >
>> > Info Total accounts: 9
>> > Info Failed to determine: 1
>> > *S-1-5-21-132666782-920464196-1691616715-1287
>> >
>> >
>> > Info Interactive accounts: 8
>> > CPQ020813001\adminsys
>> > ATNETZFE\BEGUTTER
>> > ATNETZFE\HRUBEC
>> > ATNETZFE\Firzinge
>> > ATNETZFE\KROTTEND
>> > ATNETZFE\WOLFJ
>> > ATNETZFE\EDERING
>> > ATNETZ\AIGNER
>> >
>> >
>> > Status Environment variable %ComSpec% is set to
>> > "C:\WINNT\system32\cmd.exe" on the source platform for NT
>> > AUTHORITY\SYSTEM.
>> >
>> > [...]
>> >
>> > Status Environment variable %CSIDL_SYSTEM% is set to
>> > "C:\WINNT\System32" on the source platform for
>> > ATNETZFE\EDERING.
>> >
>> > Status Environment variable %CSIDL_SYSTEMX86% is set to
>> > "C:\WINNT\System32" on the source platform for
>> > ATNETZFE\EDERING.
>> >
>> > Status Environment variable %CSIDL_WINDOWS% is set to "C:\WINNT"
>> > on
>> > the
>> > source platform for ATNETZFE\EDERING.
>> >
>> > Info User ATNETZFE\Firzinge is not a selected user, skipping.
>> > Info User ATNETZFE\HRUBEC is not a selected user, skipping.
>> > Info User ATNETZFE\KROTTEND is not a selected user, skipping.
>> > Info User ATNETZFE\WOLFJ is not a selected user, skipping.
>> > Info User CPQ020813001\adminsys is not a selected user,
>> > skipping.
>> > Warning Cannot register module SCRIPT because LoadLibrary failed
>> > Info Error 487: Es wurde versucht, auf eine unzulssige
>> > Adresse
>> > zuzugreifen.
>> >
>> >
>> > Info Module SCRIPT will not be processed
>> > Warning Cannot register module CERTIFICATES because LoadLibrary
>> > failed
>> > Info Error 487: Es wurde versucht, auf eine unzulssige
>> > Adresse
>> > zuzugreifen.
>> >
>> >
>> > Info Module CERTIFICATES will not be processed
>> > Warning Cannot register module ACCESSIBILITY because LoadLibrary
>> > failed
>> > Info Error 487: Es wurde versucht, auf eine unzulssige
>> > Adresse
>> > zuzugreifen.
>> >
>> >
>> > Info Module ACCESSIBILITY will not be processed
>> > Warning Cannot register module COOKIES because LoadLibrary failed
>> > Info Error 487: Es wurde versucht, auf eine unzulssige
>> > Adresse
>> > zuzugreifen.
>> >
>> >
>> > Info Module COOKIES will not be processed
>> > Warning Cannot register module PRINTERS because LoadLibrary
>> > failed
>> > Info Error 487: Es wurde versucht, auf eine unzulssige
>> > Adresse
>> > zuzugreifen.
>> >
>> >
>> > Info Module PRINTERS will not be processed
>> > Warning Cannot register module RAS because LoadLibrary failed
>> > Info Error 487: Es wurde versucht, auf eine unzulssige
>> > Adresse
>> > zuzugreifen.
>> >
>> >
>> > Info Module RAS will not be processed
>> > Warning Cannot register module NETDRIVES because LoadLibrary
>> > failed
>> > Info Error 487: Es wurde versucht, auf eine unzulssige
>> > Adresse
>> > zuzugreifen.
>> >
>> >
>> > Info Module NETDRIVES will not be processed
>> > Fatal Error An error occurred starting the migration engine type
>> > modules.
>> > [ERROR=2]
>> >
>> > Info Error 2: Das System kann die angegebene Datei nicht
>> > finden.
>> >
>> > Info Scanstate is exiting.
>> >
>> >
>> > So, whats that error and what is it, that the system wants to access??
>> >
>> > Hope, you can help me!!
>> >
>> > Regards Dominik
>>
>>
>>


USMT Error Code 487