Want to force TCP Connection, not Proxy HTTP



Ariel
07-09-2005, 10:48 PM
Hi !!

When I´m connected to the internet and the VPN Client is stopped, my
messanger connects directly without problems, but when I start the VPN,
connects through Proxy HTTP, and uses the proxy the VPN has, so, the
connection is entering the tunnel and reaching the internet by my company
connection, instead mine connection...

ICQ is forced to use TCP connection, but can´t configure Messanger to do the
same (besides I choose TCP in Advance Connections it seems to use the proxy
HTTP anyway...)

Is there a way to force the TCP connection?

Thanks,

Ariel

Jonathan Kay [MVP]
07-09-2005, 10:48 PM
Greetings Ariel,

If you're referring to MSN Messenger, yes you can force TCP. To do so, make sure you have
the latest version (MSN Messenger 7; http://messenger.msn.com/Download), click the Tools
menu, then Options, then Connection category, then Advanced Settings button, make sure all
checkboxes except TCP are selected and then click OK to the open dialogs.
____________________________________________
Jonathan Kay
Microsoft MVP - Windows Messenger/MSN Messenger
Associate Expert
http://www.microsoft.com/windowsxp/expertzone/
Messenger Resources - http://messenger.jonathankay.com
All posts unless otherwise specified are (c) 2005 Jonathan Kay.
You *must* contact me for redistribution rights.

"Ariel" <Ariel@discussions.microsoft.com> wrote in message
news:2B1623CC-2813-4060-8F7C-CEE20CBFAD35@microsoft.com...
> Hi !!
>
> When Im connected to the internet and the VPN Client is stopped, my
> messanger connects directly without problems, but when I start the VPN,
> connects through Proxy HTTP, and uses the proxy the VPN has, so, the
> connection is entering the tunnel and reaching the internet by my company
> connection, instead mine connection...
>
> ICQ is forced to use TCP connection, but cant configure Messanger to do the
> same (besides I choose TCP in Advance Connections it seems to use the proxy
> HTTP anyway...)
>
> Is there a way to force the TCP connection?
>
> Thanks,
>
> Ariel

Ariel
07-09-2005, 10:48 PM
Hi Jonathan,

Let me see if I understand... in advance options, all checkboxes must be
selected except the one I want to use (in this example, TCP connection) ??

Kinds regards,

Ariel

"Jonathan Kay [MVP]" wrote:

> Greetings Ariel,
>
> If you're referring to MSN Messenger, yes you can force TCP. To do so, make sure you have
> the latest version (MSN Messenger 7; http://messenger.msn.com/Download), click the Tools
> menu, then Options, then Connection category, then Advanced Settings button, make sure all
> checkboxes except TCP are selected and then click OK to the open dialogs.
> ____________________________________________
> Jonathan Kay
> Microsoft MVP - Windows Messenger/MSN Messenger
> Associate Expert
> http://www.microsoft.com/windowsxp/expertzone/
> Messenger Resources - http://messenger.jonathankay.com
> All posts unless otherwise specified are (c) 2005 Jonathan Kay.
> You *must* contact me for redistribution rights.
>
> "Ariel" <Ariel@discussions.microsoft.com> wrote in message
> news:2B1623CC-2813-4060-8F7C-CEE20CBFAD35@microsoft.com...
> > Hi !!
> >
> > When I´m connected to the internet and the VPN Client is stopped, my
> > messanger connects directly without problems, but when I start the VPN,
> > connects through Proxy HTTP, and uses the proxy the VPN has, so, the
> > connection is entering the tunnel and reaching the internet by my company
> > connection, instead mine connection...
> >
> > ICQ is forced to use TCP connection, but can´t configure Messanger to do the
> > same (besides I choose TCP in Advance Connections it seems to use the proxy
> > HTTP anyway...)
> >
> > Is there a way to force the TCP connection?
> >
> > Thanks,
> >
> > Ariel
>
>
>

Jonathan Kay [MVP]
07-09-2005, 10:48 PM
Hi Ariel,

No the other way around -- TCP is all you want checked.
____________________________________________
Jonathan Kay
Microsoft MVP - Windows Messenger/MSN Messenger
Associate Expert
http://www.microsoft.com/windowsxp/expertzone/
Messenger Resources - http://messenger.jonathankay.com
All posts unless otherwise specified are (c) 2005 Jonathan Kay.
You *must* contact me for redistribution rights.

"Ariel" <Ariel@discussions.microsoft.com> wrote in message
news:AEDC3F58-18BB-4FCD-B0CC-F0DD264AB99A@microsoft.com...
> Hi Jonathan,
>
> Let me see if I understand... in advance options, all checkboxes must be
> selected except the one I want to use (in this example, TCP connection) ??
>
> Kinds regards,
>
> Ariel
>
> "Jonathan Kay [MVP]" wrote:
>
>> Greetings Ariel,
>>
>> If you're referring to MSN Messenger, yes you can force TCP. To do so, make sure you have
>> the latest version (MSN Messenger 7; http://messenger.msn.com/Download), click the Tools
>> menu, then Options, then Connection category, then Advanced Settings button, make sure all
>> checkboxes except TCP are selected and then click OK to the open dialogs.
>> ____________________________________________
>> Jonathan Kay
>> Microsoft MVP - Windows Messenger/MSN Messenger
>> Associate Expert
>> http://www.microsoft.com/windowsxp/expertzone/
>> Messenger Resources - http://messenger.jonathankay.com
>> All posts unless otherwise specified are (c) 2005 Jonathan Kay.
>> You *must* contact me for redistribution rights.
>>
>> "Ariel" <Ariel@discussions.microsoft.com> wrote in message
>> news:2B1623CC-2813-4060-8F7C-CEE20CBFAD35@microsoft.com...
>> > Hi !!
>> >
>> > When Im connected to the internet and the VPN Client is stopped, my
>> > messanger connects directly without problems, but when I start the VPN,
>> > connects through Proxy HTTP, and uses the proxy the VPN has, so, the
>> > connection is entering the tunnel and reaching the internet by my company
>> > connection, instead mine connection...
>> >
>> > ICQ is forced to use TCP connection, but cant configure Messanger to do the
>> > same (besides I choose TCP in Advance Connections it seems to use the proxy
>> > HTTP anyway...)
>> >
>> > Is there a way to force the TCP connection?
>> >
>> > Thanks,
>> >
>> > Ariel
>>
>>
>>

Ariel
07-09-2005, 10:48 PM
Jonhatan,

That´s what I did but did not work... it seems to connect via Proxy HTTP
anyway... :-(

Know any another way?

Thanks,

Ariel

"Jonathan Kay [MVP]" wrote:

> Hi Ariel,
>
> No the other way around -- TCP is all you want checked.
> ____________________________________________
> Jonathan Kay
> Microsoft MVP - Windows Messenger/MSN Messenger
> Associate Expert
> http://www.microsoft.com/windowsxp/expertzone/
> Messenger Resources - http://messenger.jonathankay.com
> All posts unless otherwise specified are (c) 2005 Jonathan Kay.
> You *must* contact me for redistribution rights.
>
> "Ariel" <Ariel@discussions.microsoft.com> wrote in message
> news:AEDC3F58-18BB-4FCD-B0CC-F0DD264AB99A@microsoft.com...
> > Hi Jonathan,
> >
> > Let me see if I understand... in advance options, all checkboxes must be
> > selected except the one I want to use (in this example, TCP connection) ??
> >
> > Kinds regards,
> >
> > Ariel
> >
> > "Jonathan Kay [MVP]" wrote:
> >
> >> Greetings Ariel,
> >>
> >> If you're referring to MSN Messenger, yes you can force TCP. To do so, make sure you have
> >> the latest version (MSN Messenger 7; http://messenger.msn.com/Download), click the Tools
> >> menu, then Options, then Connection category, then Advanced Settings button, make sure all
> >> checkboxes except TCP are selected and then click OK to the open dialogs.
> >> ____________________________________________
> >> Jonathan Kay
> >> Microsoft MVP - Windows Messenger/MSN Messenger
> >> Associate Expert
> >> http://www.microsoft.com/windowsxp/expertzone/
> >> Messenger Resources - http://messenger.jonathankay.com
> >> All posts unless otherwise specified are (c) 2005 Jonathan Kay.
> >> You *must* contact me for redistribution rights.
> >>
> >> "Ariel" <Ariel@discussions.microsoft.com> wrote in message
> >> news:2B1623CC-2813-4060-8F7C-CEE20CBFAD35@microsoft.com...
> >> > Hi !!
> >> >
> >> > When I´m connected to the internet and the VPN Client is stopped, my
> >> > messanger connects directly without problems, but when I start the VPN,
> >> > connects through Proxy HTTP, and uses the proxy the VPN has, so, the
> >> > connection is entering the tunnel and reaching the internet by my company
> >> > connection, instead mine connection...
> >> >
> >> > ICQ is forced to use TCP connection, but can´t configure Messanger to do the
> >> > same (besides I choose TCP in Advance Connections it seems to use the proxy
> >> > HTTP anyway...)
> >> >
> >> > Is there a way to force the TCP connection?
> >> >
> >> > Thanks,
> >> >
> >> > Ariel
> >>
> >>
> >>
>
>
>


Want to force TCP Connection, not Proxy HTTP