Connecting to a external firewall/router



Chico Martinez
07-10-2005, 01:51 AM
I have an XP home box with a direct connection to a Linux box configured as a
firewall/router/dhcp/gateway. I can ping back and forth. And dhcp works
fine. The problem that I am having is that the XP box will not connect to
the Linux box to access the Internet. Why?

Chuck
07-10-2005, 01:51 AM
On Thu, 12 May 2005 07:48:06 -0700, "Chico Martinez" <DOnotSPAM@Me.org> wrote:

>I have an XP home box with a direct connection to a Linux box configured as a
>firewall/router/dhcp/gateway. I can ping back and forth. And dhcp works
>fine. The problem that I am having is that the XP box will not connect to
>the Linux box to access the Internet. Why?

Chico,

What is the IP address of the Linux box? Is the Default Gateway on the XP box
set to that value? By any chance, is your browser the problem?

If you're using Internet Explorer (it would be better if you weren't, but that's
my opinion), check Tools - Internet Options - Connections. Make sure that
"Never dial..." is selected. Under LAN Settings, make sure that nothing is
checked.

Provide ipconfig information for the XP computer, as a start.
1) Start - Run - "cmd".
2) Type "ipconfig /all >c:\ipconfig.txt" into the command window.
3) Open Notepad, make sure that Format - Word Wrap is NOT checked!.
4) Open file c:\ipconfig.txt from Notepad.
5) Copy and paste entire contents of the file into your next post.
6) Identify operating system (by name, version, and Service Pack level) with
each ipconfig listing.

--
Cheers,
Chuck
http://nitecruzr.blogspot.com/
Paranoia is not necessarily a bad thing - it comes from experience.
My email is AT DOT
actual address pchuck sonic net.

Chico Martinez
07-10-2005, 01:51 AM
I had to turn off dhcp because it was causing problems on my Linux box.
c:\ipconfig.txt

Windows IP Configuration

Host Name . . . . . . . . . . . . : POLARIS
Primary Dns Suffix . . . . . . . : Martinez.org
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : Martinez.org

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast
Ethernet NIC
Physical Address. . . . . . . . . : 00-11-D8-85-59-9E
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 83.89.82.75
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 83.89.82.77

PPP adapter EarthLink syrm@earthlink.net:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
Physical Address. . . . . . . . . : 00-53-45-00-00-00
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . :
Subnet Mask . . . . . . . . . . . :
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . :

NetBIOS over Tcpip. . . . . . . . : Disabled

Red Hat Linux kernel: version 2.4.20 ( Other wise known as Red Hat 9)
IP Address. . . . . . . . . . . . : 83.89.82.77
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : modem


Even after assigning static IPs, the XP box will not initialize the modem on
the Linux box.
Modem is set at on demand.


"Chuck" wrote:

> On Thu, 12 May 2005 07:48:06 -0700, "Chico Martinez" <DOnotSPAM@Me.org> wrote:
>
> >I have an XP home box with a direct connection to a Linux box configured as a
> >firewall/router/dhcp/gateway. I can ping back and forth. And dhcp works
> >fine. The problem that I am having is that the XP box will not connect to
> >the Linux box to access the Internet. Why?
>
> Chico,
>
> What is the IP address of the Linux box? Is the Default Gateway on the XP box
> set to that value? By any chance, is your browser the problem?
>
> If you're using Internet Explorer (it would be better if you weren't, but that's
> my opinion), check Tools - Internet Options - Connections. Make sure that
> "Never dial..." is selected. Under LAN Settings, make sure that nothing is
> checked.
>
> Provide ipconfig information for the XP computer, as a start.
> 1) Start - Run - "cmd".
> 2) Type "ipconfig /all >c:\ipconfig.txt" into the command window.
> 3) Open Notepad, make sure that Format - Word Wrap is NOT checked!.
> 4) Open file c:\ipconfig.txt from Notepad.
> 5) Copy and paste entire contents of the file into your next post.
> 6) Identify operating system (by name, version, and Service Pack level) with
> each ipconfig listing.
>
> --
> Cheers,
> Chuck
> http://nitecruzr.blogspot.com/
> Paranoia is not necessarily a bad thing - it comes from experience.
> My email is AT DOT
> actual address pchuck sonic net.
>

Chuck
07-10-2005, 01:51 AM
On Fri, 13 May 2005 23:09:01 -0700, "Chico Martinez" <DOnotSPAM@Me.org> wrote:

>"Chuck" wrote:
>
>> On Thu, 12 May 2005 07:48:06 -0700, "Chico Martinez" <DOnotSPAM@Me.org> wrote:
>>
>> >I have an XP home box with a direct connection to a Linux box configured as a
>> >firewall/router/dhcp/gateway. I can ping back and forth. And dhcp works
>> >fine. The problem that I am having is that the XP box will not connect to
>> >the Linux box to access the Internet. Why?
>>
>> Chico,
>>
>> What is the IP address of the Linux box? Is the Default Gateway on the XP box
>> set to that value? By any chance, is your browser the problem?
>>
>> If you're using Internet Explorer (it would be better if you weren't, but that's
>> my opinion), check Tools - Internet Options - Connections. Make sure that
>> "Never dial..." is selected. Under LAN Settings, make sure that nothing is
>> checked.
>>
>> Provide ipconfig information for the XP computer, as a start.
>> 1) Start - Run - "cmd".
>> 2) Type "ipconfig /all >c:\ipconfig.txt" into the command window.
>> 3) Open Notepad, make sure that Format - Word Wrap is NOT checked!.
>> 4) Open file c:\ipconfig.txt from Notepad.
>> 5) Copy and paste entire contents of the file into your next post.
>> 6) Identify operating system (by name, version, and Service Pack level) with
>> each ipconfig listing.
>I had to turn off dhcp because it was causing problems on my Linux box.
>c:\ipconfig.txt

<SNIP>

>Even after assigning static IPs, the XP box will not initialize the modem on
>the Linux box.
>Modem is set at on demand.

OK, I presume that you checked the browser settings, and found no problem there?

TCP/IP settings look good.

If you can ping back and forth, how do you know that the XP computer isn't
connecting to the Linux computer? Could it be connecting, but the Linux
computer not properly setup? Have you addressed this in a Linux forum? Are
there any other computers that you could use to test this setup?

--
Cheers,
Chuck
http://nitecruzr.blogspot.com/
Paranoia is not necessarily a bad thing - it comes from experience.
My email is AT DOT
actual address pchuck sonic net.


Connecting to a external firewall/router