Can not change default gateway(URGENT!!!)



Wings Tiger
07-10-2005, 01:51 AM
Everytime after reboot my PC, the default gateway is set to 10.64.x.x in the
TCP/IP properities(correct default gateway should be 10.128.x.1). I was try
the following actions:
1. Enable DHCP, my PC can get correct IP, DNS & WINS address, but the
default gateway is still set to 10.64.x.1.
2. Use static IP, but after reboot, all static IP, DNS & WINS address are
gone, only see the default gateway is 10.64.x.1 in TCP/IP properities.
3. run "netsh interface reset *", it's still not work after reboot.
4. Remove LAN adapter and reinstall it, still not work after reboot.
5. delete Winsock &Winsock32 from the Registry, still not work after reboot.
6. remove default gateway 10.64.x.1 under active LAN adapter from the
Registry, it's working before reboot, and not working after reboot.
7. delete all entries in
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run, still not
work.

In other words, if I change the default gateway manually, it's working. But,
it will change back to 10.64.x.1 every time after reboot. It's seems that a
program will overwrite the default gateway every time at Windows startup
point.

My PC's config.:
- IBM Thinkpad T42
- Intel Pro/1000 MT mobile connection with latest driver
- Windows XP pro with SP2(Firewall disabled)
- Macafee anti-virus
- ctrixic client
- blackberry desktop program
- Other common applications such as MS Office 2000.

Any Idea?

JohnE
07-10-2005, 01:51 AM
Not sure why the config is reseting, but have you tried adding a default
route with a lower metric. Add it with -p to make it persistant.

ROUTE PRINT (to see routes and default metric)

ROUTE ADD 0.0.0.0 MASK 0.0.0.0 10.128.x.1 METRIC 5 -p

I think that is the syntax. Try ROUTE -? if it fails.

Doesn't resolve the problem, but may get round it for the time being.

Wings Tiger
07-10-2005, 01:51 AM
Adding a default gatway can solve this problem temporary. Thanks a lot!

But, any idea to solve it permanently?

And, I found every time after reboot, the default gateway will change back
to 10.64.x.1 about 20 seconds later, it means that I have 20 seconds correct
TCP/IP settings every time after reboot. any idea?

"JohnE" wrote:

> Not sure why the config is reseting, but have you tried adding a default
> route with a lower metric. Add it with -p to make it persistant.
>
> ROUTE PRINT (to see routes and default metric)
>
> ROUTE ADD 0.0.0.0 MASK 0.0.0.0 10.128.x.1 METRIC 5 -p
>
> I think that is the syntax. Try ROUTE -? if it fails.
>
> Doesn't resolve the problem, but may get round it for the time being.

Wings Tiger
07-10-2005, 01:51 AM
FYI, use "ROUTE ADD 0.0.0.0 MASK 0.0.0.0 10.128.x.1 METRIC 5 -p" is NOT work,
it's work when I run above command without -p.

"Wings Tiger" wrote:

> Adding a default gatway can solve this problem temporary. Thanks a lot!
>
> But, any idea to solve it permanently?
>
> And, I found every time after reboot, the default gateway will change back
> to 10.64.x.1 about 20 seconds later, it means that I have 20 seconds correct
> TCP/IP settings every time after reboot. any idea?
>
> "JohnE" wrote:
>
> > Not sure why the config is reseting, but have you tried adding a default
> > route with a lower metric. Add it with -p to make it persistant.
> >
> > ROUTE PRINT (to see routes and default metric)
> >
> > ROUTE ADD 0.0.0.0 MASK 0.0.0.0 10.128.x.1 METRIC 5 -p
> >
> > I think that is the syntax. Try ROUTE -? if it fails.
> >
> > Doesn't resolve the problem, but may get round it for the time being.

JohnE
07-10-2005, 01:51 AM
Sorry, the -p should be between the ROUTE and ADD. This makes it persistant
so should be there on reboot.

Syntax
route [-f] [-p] [Command [Destination] [mask Netmask] [Gateway] [metric
Metric]] [if Interface]]

Parameters
-f
Clears the routing table of all entries that are not host routes (routes
with a netmask of 255.255.255.255), the loopback network route (routes with a
destination of 127.0.0.0 and a netmask of 255.0.0.0), or a multicast route
(routes with a destination of 224.0.0.0 and a netmask of 240.0.0.0). If this
is used in conjunction with one of the commands (such as add, change, or
delete), the table is cleared prior to running the command.
-p
When used with the add command, the specified route is added to the registry
and is used to initialize the IP routing table whenever the TCP/IP protocol
is started. By default, added routes are not preserved when the TCP/IP
protocol is started. When used with the print command, the list of persistent
routes is displayed. This parameter is ignored for all other commands.
Persistent routes are stored in the registry location
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\PersistentRoutes.

-------------------------------
It seem like the information is being picked up from a DHCP server. I am
not sure whether a group policy could be forcing the DHCP or default route.

"Wings Tiger" wrote:

> FYI, use "ROUTE ADD 0.0.0.0 MASK 0.0.0.0 10.128.x.1 METRIC 5 -p" is NOT work,
> it's work when I run above command without -p.
>

Wings Tiger
07-10-2005, 01:52 AM
It's still not work for useing persistant route.

FYI, I found the short term solution with the following steps:
1. After reboot, wait for other 20 seconds,
2. Make sure the route "0.0.0.0 0.0.0.0 10.64.x.1" is automatically
added into the routing table(run "route print")
3. Delete the route for 10.64.x1 manually.
4. Add a general route "route add 0.0.0.0 mask 0.0.0.0 10.128.x.1 metric 1"
into routing table.

Interesting, isn't it? It seems like a program is running at backgroud every
time after you reboot.
And, I found that, if I manually disable the DHCP client, it'll
automatically re-enabled by the system(or an unknow program) every time after
reboot.

I have already scaned my computer with the latest anti-virus program(NAV 8)
and the anti-spyware program(MS Anti-spyware).

Any idea?


"JohnE" wrote:

> Sorry, the -p should be between the ROUTE and ADD. This makes it persistant
> so should be there on reboot.
>
> Syntax
> route [-f] [-p] [Command [Destination] [mask Netmask] [Gateway] [metric
> Metric]] [if Interface]]
>
> Parameters
> -f
> Clears the routing table of all entries that are not host routes (routes
> with a netmask of 255.255.255.255), the loopback network route (routes with a
> destination of 127.0.0.0 and a netmask of 255.0.0.0), or a multicast route
> (routes with a destination of 224.0.0.0 and a netmask of 240.0.0.0). If this
> is used in conjunction with one of the commands (such as add, change, or
> delete), the table is cleared prior to running the command.
> -p
> When used with the add command, the specified route is added to the registry
> and is used to initialize the IP routing table whenever the TCP/IP protocol
> is started. By default, added routes are not preserved when the TCP/IP
> protocol is started. When used with the print command, the list of persistent
> routes is displayed. This parameter is ignored for all other commands.
> Persistent routes are stored in the registry location
> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\PersistentRoutes.
>
> -------------------------------
> It seem like the information is being picked up from a DHCP server. I am
> not sure whether a group policy could be forcing the DHCP or default route.
>
> "Wings Tiger" wrote:
>
> > FYI, use "ROUTE ADD 0.0.0.0 MASK 0.0.0.0 10.128.x.1 METRIC 5 -p" is NOT work,
> > it's work when I run above command without -p.
> >
>


Can not change default gateway(URGENT!!!)