Re: Disable DMA



Ted
07-10-2005, 01:40 AM
"NoNoBadDog!" <mysocks_bjsledge_AT_pixi.com> wrote in
news:#VpqQh0XEHA.716@TK2MSFTNGP11.phx.gbl:

> If you have an Intel based Mobo, uninstall the Intell Application
> Accelerator. Then change the Drives for DMA to PIO. Reboot. The
> only reason I can think of that might require you to do this is a
> firmware flash.
>
> Bobby
>
>
> "Andrew" <Andrew@discussions.microsoft.com> wrote in message
> news:7B76B677-788D-4DFE-AC6C-81CD7241285E@microsoft.com...
>>I want to be able to disable DMA. My problem is that I don't have an
>>"Advanced Settings" tab in my Device Manager->IDE ATA/ATAPI
>>Controller.
>>
>> Does anybody know why I don't have an "Advanced Settings" tab?
>> Does anybody know how else I can disable the DMA?
>>
>> Thanks,
>> Andrew
>
>

I have a different problem: I can't enable DMA and do not have the
advanced tab. Uninstalling the accelerator did not create the tab. My
Mobo is DFI NB730-EA with an intel 845E chipset. It only came to my
attention when I reinstalled my ATI all-in-Wonder graphics card software
and was advised that some performance may be compromised because of the
lack of enabled DMA on my hard drives. I have researched MS knowledge-
base docs and am aware of the degrading of drive I/O thru crc and other
errors, but that does not seem to be my problem. The advanced tab under
device manager for ide controlers just does not exist. Any suggestions?

Anna
07-10-2005, 01:40 AM
"Ted" <ted597632@aol.com> wrote in message
news:csKdnZvvQahAQlffRVn-rg@usa2net.net...

> (Snip): I can't enable DMA and do not have the
> advanced tab. Uninstalling the accelerator did not create the tab. My
> Mobo is DFI NB730-EA with an intel 845E chipset. It only came to my
> attention when I reinstalled my ATI all-in-Wonder graphics card software
> and was advised that some performance may be compromised because of the
> lack of enabled DMA on my hard drives. I have researched MS knowledge-
> base docs and am aware of the degrading of drive I/O thru crc and other
> errors, but that does not seem to be my problem. The advanced tab under
> device manager for ide controlers just does not exist. Any suggestions?


Ted:
I take it from what you've stated that you disabled your Intel Application
Accelerator. Am I correct about this and if so, can you tell me *why* you
did so?

Ordinarily one uses the IAA with the Intel 845E Chipset. When the IAA is
installed it modifies Device Manager's IDE Properties sheet for the IDE
controllers by eliminating the DMA/PIO info & settings. Info & settings re
this item can be found in Program Files > Intel > Intel Application
Accelerator >intelata.exe file. Access that file and you will see the
"Current Transfer Mode" of the device connected to the IDE channel in which
you're interested. Ordinarily, the IAA automatically configures your
IDE/ATAPI devices for the *maximum* transfer mode possible. Assuming we're
dealing with a relatively modern drive capable of UDMA-5 or 6, the "Transfer
Mode Limit" item should show "No Limit" and the "Current Transfer Mode"
should reflect the device is working at that maximum mode. If it's not,
theoretically you can change the "Transfer Mode Limit" to that maximum mode,
but if there's a problem with the device - it's defective in some way,
mechanically/electrically, incorrect connection/configuration, operating
system file corruption, etc - the change won't stick. You've got to find the
underlying reason for the reason why the device is not operating at its full
UDMA potential.
Anna

Ted
07-10-2005, 01:41 AM
"Anna" <myname@myisp.net> wrote in
news:#Pm8mLagFHA.2424@TK2MSFTNGP09.phx.gbl:

>
> "Ted" <ted597632@aol.com> wrote in message
> news:csKdnZvvQahAQlffRVn-rg@usa2net.net...
>
>> (Snip): I can't enable DMA and do not have the
>> advanced tab. Uninstalling the accelerator did not create the tab.
>> My Mobo is DFI NB730-EA with an intel 845E chipset. It only came to
>> my attention when I reinstalled my ATI all-in-Wonder graphics card
>> software and was advised that some performance may be compromised
>> because of the lack of enabled DMA on my hard drives. I have
>> researched MS knowledge- base docs and am aware of the degrading of
>> drive I/O thru crc and other errors, but that does not seem to be my
>> problem. The advanced tab under device manager for ide controlers
>> just does not exist. Any suggestions?
>
>
> Ted:
> I take it from what you've stated that you disabled your Intel
> Application Accelerator. Am I correct about this and if so, can you
> tell me *why* you did so?

Yes, I disabled the Intel Application Accelerator as an extrapolation of
the discussion initiated in this thread (suggestion of "NoNoBadDog!").
Subsequently I have reinstalled the IAA.

>
> Ordinarily one uses the IAA with the Intel 845E Chipset. When the IAA
> is installed it modifies Device Manager's IDE Properties sheet for
> the IDE controllers by eliminating the DMA/PIO info & settings. Info &
> settings re this item can be found in Program Files > Intel > Intel
> Application Accelerator >intelata.exe file. Access that file and you
> will see the "Current Transfer Mode" of the device connected to the
> IDE channel in which you're interested. Ordinarily, the IAA
> automatically configures your IDE/ATAPI devices for the *maximum*
> transfer mode possible. Assuming we're dealing with a relatively
> modern drive capable of UDMA-5 or 6, the "Transfer Mode Limit" item
> should show "No Limit" and the "Current Transfer Mode" should reflect
> the device is working at that maximum mode. If it's not, theoretically
> you can change the "Transfer Mode Limit" to that maximum mode, but if
> there's a problem with the device - it's defective in some way,
> mechanically/electrically, incorrect connection/configuration,
> operating system file corruption, etc - the change won't stick. You've
> got to find the underlying reason for the reason why the device is not
> operating at its full UDMA potential.
> Anna
>
>

Access to the IAA .exe file did indeed identify the Transfer Mode Limit
as "No Limit" and the Current Transfer Rate as UDMA-5 for the hard
drives and UDMA-2 for the DVD writer drive. So I guess things are as
they should be. Thanks for the assistance.
Ted


Re: Disable DMA