Context Menu Problem



Gary
07-10-2005, 01:38 AM
Hi All,

I am running XP Pro SP2.

My problem is this: When I go to explorer and right click on a folder in
the right pane, the context menu that comes up has as the first 3 choices:

1.Search (bold print)
2.explore (normal print) and 3. open (normal print)
also when I 2x left click a search window comes up.

How do I make open or explore the default action??


Gary

Ricky
07-10-2005, 01:38 AM
Have a look here..
http://www.dougknox.com/xp/scripts_desc/xp_folder_open.htm

"Gary" <Gary@nospam.net> wrote in message
news:%23M%23aNR3fFHA.1048@tk2msftngp13.phx.gbl...
| Hi All,
|
| I am running XP Pro SP2.
|
| My problem is this: When I go to explorer and right click on a
folder in
| the right pane, the context menu that comes up has as the first 3
choices:
|
| 1.Search (bold print)
| 2.explore (normal print) and 3. open (normal print)
| also when I 2x left click a search window comes up.
|
| How do I make open or explore the default action??
|
|
| Gary

Ramesh, MS-MVP
07-10-2005, 01:38 AM
This problem occurs when you alter the "Drive" / "File Folders" entries via
File Types dialog, to add a "Command Prompt here" or "Print Directory"
feature for folders. (example)

http://support.microsoft.com/?kbid=321379
http://support.microsoft.com/?kbid=321186

Resolution:

Click Start/Run and type this command to fix this problem:
(Tip from David Candy)

regsvr32 /i shell32.dll

-or-

To fix this manually via registry:

If this problem is seen for Drives:

HKEY_CLASSES_ROOT\Drive\shell
Set (default) to "none" (without ")

If this problem is seen for folders:

[HKEY_CLASSES_ROOT\Directory\shell]
Set (default) to "none" (without ")

--
Ramesh, MS-MVP
Windows Shell/User

Windows XP Troubleshooting
http://www.winhelponline.com
http://windowsxp.mvps.org

Windows XP Newsgroup Setup Instructions for Outlook Express:
http://www.microsoft.com/windowsxp/expertzone/newsgroupsetup.mspx


"Gary" <Gary@nospam.net> wrote in message
news:%23M%23aNR3fFHA.1048@tk2msftngp13.phx.gbl...
> Hi All,
>
> I am running XP Pro SP2.
>
> My problem is this: When I go to explorer and right click on a folder in
> the right pane, the context menu that comes up has as the first 3 choices:
>
> 1.Search (bold print)
> 2.explore (normal print) and 3. open (normal print)
> also when I 2x left click a search window comes up.
>
> How do I make open or explore the default action??
>
>
> Gary

Gary
07-10-2005, 01:38 AM
Ramesh, MS-MVP wrote:
> This problem occurs when you alter the "Drive" / "File Folders" entries
> via File Types dialog, to add a "Command Prompt here" or "Print
> Directory" feature for folders. (example)
>
> http://support.microsoft.com/?kbid=321379
> http://support.microsoft.com/?kbid=321186
>
> Resolution:
>
> Click Start/Run and type this command to fix this problem:
> (Tip from David Candy)
>
> regsvr32 /i shell32.dll
>
> -or-
>
> To fix this manually via registry:
>
> If this problem is seen for Drives:
>
> HKEY_CLASSES_ROOT\Drive\shell
> Set (default) to "none" (without ")
>
> If this problem is seen for folders:
>
> [HKEY_CLASSES_ROOT\Directory\shell]
> Set (default) to "none" (without ")
>
YOU GUYS ARE THE BEST. Thanks to all who replied--PROBLEM SOLVED

What would the computing world do without your help and this newsgroup??

Gary

Ramesh, MS-MVP
07-10-2005, 01:38 AM
You're welcome Gary :-)

--
Ramesh, MS-MVP
Windows Shell/User

Windows XP Troubleshooting
http://www.winhelponline.com
http://windowsxp.mvps.org

Windows XP Newsgroup Setup Instructions for Outlook Express:
http://www.microsoft.com/windowsxp/expertzone/newsgroupsetup.mspx


"Gary" <Gary@nospam.net> wrote in message
news:ehRlDF5fFHA.3428@TK2MSFTNGP09.phx.gbl...
> Ramesh, MS-MVP wrote:
>> This problem occurs when you alter the "Drive" / "File Folders" entries
>> via File Types dialog, to add a "Command Prompt here" or "Print
>> Directory" feature for folders. (example)
>>
>> http://support.microsoft.com/?kbid=321379
>> http://support.microsoft.com/?kbid=321186
>>
>> Resolution:
>>
>> Click Start/Run and type this command to fix this problem:
>> (Tip from David Candy)
>>
>> regsvr32 /i shell32.dll
>>
>> -or-
>>
>> To fix this manually via registry:
>>
>> If this problem is seen for Drives:
>>
>> HKEY_CLASSES_ROOT\Drive\shell
>> Set (default) to "none" (without ")
>>
>> If this problem is seen for folders:
>>
>> [HKEY_CLASSES_ROOT\Directory\shell]
>> Set (default) to "none" (without ")
>>
> YOU GUYS ARE THE BEST. Thanks to all who replied--PROBLEM SOLVED
>
> What would the computing world do without your help and this newsgroup??
>
> Gary


Context Menu Problem