Resetting NTFS Permissions



crash_sc
07-10-2005, 02:33 AM
Using XP Home, I got a dumbass idea in my head and went through Safe Mode to
alter NTFS permissions for my USB HD. Not sure how, but I managed to lock
myself (admin) out of it. Since I no longer had access to the HD XP wouldn't
let me modify the permissions, but it did let me take ownership. I've
restored the permissions for the HD, but XP still won't let me regain access
to ZIP files I keep there (I have too many to count). Is there any way I can
set all of the HD's permissions back to default? System Restore didn't do
it.

WTC
07-10-2005, 02:33 AM
"crash_sc" <coxmarshall@bellsouth.net> wrote in message
news:r0Ive.10181$wm.1567@bignews4.bellsouth.net...
> Using XP Home, I got a dumbass idea in my head and went through Safe
> Mode to alter NTFS permissions for my USB HD. Not sure how, but I
> managed to lock myself (admin) out of it. Since I no longer had access
> to the HD XP wouldn't let me modify the permissions, but it did let me
> take ownership. I've restored the permissions for the HD, but XP still
> won't let me regain access to ZIP files I keep there (I have too many
> to count). Is there any way I can set all of the HD's permissions back
> to default? System Restore didn't do it.
>


This may help you,

How To Reset Security Settings Back to the Defaults
http://support.microsoft.com/?kbid=313222

--
William

crash_sc
07-10-2005, 02:33 AM
Ok, I tried using the specified command, but recieved an error message
saying "secedit" could not be found. I figured out that I can go back into
Safe Mode and retake ownership of all my files, but for some reason it won't
work on subfolders and files so I have to do everything one at a time. I'd
really rather take a shortcut.

Kerry Brown
07-10-2005, 02:33 AM
"crash_sc" <coxmarshall@bellsouth.net> wrote in message
news:XfTve.9011$Zo.8948@bignews3.bellsouth.net...
> Ok, I tried using the specified command, but recieved an error message
> saying "secedit" could not be found. I figured out that I can go back
> into Safe Mode and retake ownership of all my files, but for some reason
> it won't work on subfolders and files so I have to do everything one at a
> time. I'd really rather take a shortcut.
>

On the screen where you take ownership make sure there is a tick in the box
that says "Replace owner on subcontainers and objects"

Kerry

crash_sc
07-10-2005, 02:33 AM
> On the screen where you take ownership make sure there is a tick in the
> box
> that says "Replace owner on subcontainers and objects"
>
> Kerry
>


Yep, thats what I've been doing. It worked for folders and subfolders with
only data files (images, videos, text files...) but it refuses to change the
ownership of any folder with zip or exe files.

crash_sc
07-10-2005, 02:33 AM
Well, not sure how I did it, but it looks like I have full control over all
of the zip files again. But the exe files are still causing problems. Under
the security properties it shows me as having full control, but when I try
to run one of the programs it says that the file cannot be found, and to
make sure I have permission to access it.

Kerry Brown
07-10-2005, 02:33 AM
"crash_sc" <coxmarshall@bellsouth.net> wrote in message
news:DRUve.12046$Bm.1595@bignews5.bellsouth.net...
>
>> On the screen where you take ownership make sure there is a tick in the
>> box
>> that says "Replace owner on subcontainers and objects"
>>
>> Kerry
>>
>
>
> Yep, thats what I've been doing. It worked for folders and subfolders with
> only data files (images, videos, text files...) but it refuses to change
> the ownership of any folder with zip or exe files.
>

You could try the xcacls command line tool. This will allow you to change
the permissions for taking ownership.

http://www.microsoft.com/downloads/details.aspx?FamilyID=49ae8576-9bb9-4126-9761-ba8011fabf38&displaylang=en

Kerry

crash_sc
07-10-2005, 02:33 AM
> You could try the xcacls command line tool. This will allow you to change
> the permissions for taking ownership.


I tried to use it to assign myself full control over the HD, but I get an
"access denied" message.

Kerry Brown
07-10-2005, 02:33 AM
"crash_sc" <coxmarshall@bellsouth.net> wrote in message
news:hWXve.9607$Zo.5339@bignews3.bellsouth.net...
>
>> You could try the xcacls command line tool. This will allow you to change
>> the permissions for taking ownership.
>
>
> I tried to use it to assign myself full control over the HD, but I get an
> "access denied" message.
>

Are the files encrypted with EFS? That's just a guess. At this point I'm out
of suggestions

Kerry

crash_sc
07-10-2005, 02:33 AM
> Are the files encrypted with EFS? That's just a guess. At this point I'm
> out
> of suggestions
>


Nope. Thanks for all your help just the same. The one thing I don't
understand is that the drive and the specific files show me as having
ownership and full control. But when I go to open or copy one of the files
it says I don't have permission. As far as I can tell its just a random
group of programs and ISO files that are affected, everything else is fine.

Kerry Brown
07-10-2005, 02:33 AM
"crash_sc" <coxmarshall@bellsouth.net> wrote in message
news:OoZve.11783$gr.788@bignews1.bellsouth.net...
>
>> Are the files encrypted with EFS? That's just a guess. At this point I'm
>> out
>> of suggestions
>>
>
>
> Nope. Thanks for all your help just the same. The one thing I don't
> understand is that the drive and the specific files show me as having
> ownership and full control. But when I go to open or copy one of the files
> it says I don't have permission. As far as I can tell its just a random
> group of programs and ISO files that are affected, everything else is
> fine.
>

Can you then take ownership of that file and access it?

Kerry

crash_sc
07-10-2005, 02:34 AM
> Can you then take ownership of that file and access it?
>


With the ISO file, as far as I can tell I have ownership of it, at least
thats what it says in the security settings. It also shows me as having full
control of it, but when I try to copy it I get a message saying I don't have
permission. The several exe files affected are the same way. It shows me as
having ownership and full control but when I try to run them the message
says the file cannot be found and to make sure I have permission and that
the file is not write-protected. Accessing the NTFS settings through Safe
Mode in XP Home is the same as the settings you can access with Pro isn't
it?

Kerry Brown
07-10-2005, 02:34 AM
"crash_sc" <coxmarshall@bellsouth.net> wrote in message
news:Er%ve.13228$Bm.12106@bignews5.bellsouth.net...
>
>
>> Can you then take ownership of that file and access it?
>>
>
>
> With the ISO file, as far as I can tell I have ownership of it, at least
> thats what it says in the security settings. It also shows me as having
> full control of it, but when I try to copy it I get a message saying I
> don't have permission. The several exe files affected are the same way. It
> shows me as having ownership and full control but when I try to run them
> the message says the file cannot be found and to make sure I have
> permission and that the file is not write-protected. Accessing the NTFS
> settings through Safe Mode in XP Home is the same as the settings you can
> access with Pro isn't it?
>

Something weird going on for sure. Try setting it so the everyone group has
full control. Set the owner to administrator. Make sure there are no deny
permissions set for any user or group. Deny over rides everything. Deny may
be set for some group you are a member of. It's a stab in the dark.

Kerry

crash_sc
07-10-2005, 02:34 AM
> Something weird going on for sure. Try setting it so the everyone group
> has
> full control. Set the owner to administrator. Make sure there are no deny
> permissions set for any user or group. Deny over rides everything. Deny
> may be set for some group you are a member of. It's a stab in the dark.


Ok, not sure why or how but the computer removed or hid the Everyone group.
I added back and set all of its permissions for the drive to Allow. Looks
like I have full control over everything now. Thanks again for all your
help, I was not looking forward to d/ling 20 gigs of crap all over again.

Kerry Brown
07-10-2005, 02:34 AM
"crash_sc" <coxmarshall@bellsouth.net> wrote in message
news:pA1we.23711$qm.15303@bignews6.bellsouth.net...
>
>> Something weird going on for sure. Try setting it so the everyone group
>> has
>> full control. Set the owner to administrator. Make sure there are no deny
>> permissions set for any user or group. Deny over rides everything. Deny
>> may be set for some group you are a member of. It's a stab in the dark.
>
>
> Ok, not sure why or how but the computer removed or hid the Everyone
> group. I added back and set all of its permissions for the drive to Allow.
> Looks like I have full control over everything now. Thanks again for all
> your help, I was not looking forward to d/ling 20 gigs of crap all over
> again.
>

Glad you got it working.

Kerry


Resetting NTFS Permissions