* Windows XP does not boot after SP2 *



Kumaran
07-10-2005, 02:21 AM
Dear Experts,

Initially I had Windows XP professional + SP2 installed on my Compaq
Presario Laptop.
It was working great. But, later I have given my laptop to Compaq service
for BIOS upgrade that
improves battery runtime. After the BIOS update, to my horror Compaq had
reverted everything to their default installation, XP Home + SP1.

I reformatted and installed XP professional again with SP1 and it was
working fine.
Then I have installed all the available security patches from windows update
and proceeded to install SP2.
Everything was fine during installation of SP2 but after restart it did not
boot, just froze at XP logo screen (with running progress bar). I tried
using safe mode, but no use, safe mode also failed to load, just froze.

So I have reverted back to SP1 using XP repair installation, system starts
fine.
But control panel and windows explorer crashes often with an exception in
ntdll.dll.

What could be wrong with my SP2 installation, how can I fix this SP2
installation problem.
Any patches to fix the ntdll.dll corruption problem ?

Experts, Kindly help me.

Best Regards
Kumaran

lucyfer
07-10-2005, 02:21 AM
It sounds amazing. You may try to install from a CD with Windows XP+SP2, if
possible.

From your description,this issue seems to relate to your BIOS's update. You
may ask for MotherBoard's manufacture for assistance.

Additionally, you may replace ntdll.dll in recovery console. Follow the
article as below:

307654 How to install and use the Recovery Console in Windows XP

http://support.microsoft.com/?id=307654

you may also perform a repair installation as following article said:
http://support.microsoft.com/default.aspx?scid=kb;en-us;315341


"Kumaran" <subbarayan.elangkumaran@de.bosch.com> 写入消息新闻:d86ftd$efv$1@ns2.fe.internet.bosch.com...
> Dear Experts,
>
> Initially I had Windows XP professional + SP2 installed on my Compaq
> Presario Laptop.
> It was working great. But, later I have given my laptop to Compaq service
> for BIOS upgrade that
> improves battery runtime. After the BIOS update, to my horror Compaq had
> reverted everything to their default installation, XP Home + SP1.
>
> I reformatted and installed XP professional again with SP1 and it was
> working fine.
> Then I have installed all the available security patches from windows
> update
> and proceeded to install SP2.
> Everything was fine during installation of SP2 but after restart it did
> not
> boot, just froze at XP logo screen (with running progress bar). I tried
> using safe mode, but no use, safe mode also failed to load, just froze.
>
> So I have reverted back to SP1 using XP repair installation, system starts
> fine.
> But control panel and windows explorer crashes often with an exception in
> ntdll.dll.
>
> What could be wrong with my SP2 installation, how can I fix this SP2
> installation problem.
> Any patches to fix the ntdll.dll corruption problem ?
>
> Experts, Kindly help me.
>
> Best Regards
> Kumaran
>
>

Phillips
07-10-2005, 02:21 AM
Did you check your BIOS settings - ex. enable HyperThreading etc. Make sure
you have the most conservative (standard) settings - have no idea how those
BIOS are on your machine. Try various Power Save options that might be in
the BIOS.
From what you say, it might be that the correct hal.dll is not formated
according to your hardware. It takes too long to explain it here - google
for "xp change hal.dll" or similar.
Michael

"Kumaran" <subbarayan.elangkumaran@de.bosch.com> wrote in message
news:d86ftd$efv$1@ns2.fe.internet.bosch.com...
> Dear Experts,
>
> Initially I had Windows XP professional + SP2 installed on my Compaq
> Presario Laptop.
> It was working great. But, later I have given my laptop to Compaq service
> for BIOS upgrade that
> improves battery runtime. After the BIOS update, to my horror Compaq had
> reverted everything to their default installation, XP Home + SP1.
>
> I reformatted and installed XP professional again with SP1 and it was
> working fine.
> Then I have installed all the available security patches from windows
> update
> and proceeded to install SP2.
> Everything was fine during installation of SP2 but after restart it did
> not
> boot, just froze at XP logo screen (with running progress bar). I tried
> using safe mode, but no use, safe mode also failed to load, just froze.
>
> So I have reverted back to SP1 using XP repair installation, system starts
> fine.
> But control panel and windows explorer crashes often with an exception in
> ntdll.dll.
>
> What could be wrong with my SP2 installation, how can I fix this SP2
> installation problem.
> Any patches to fix the ntdll.dll corruption problem ?
>
> Experts, Kindly help me.
>
> Best Regards
> Kumaran
>
>

Harry Ohrn
07-10-2005, 02:21 AM
check here http://www.dll-files.com/dllindex/dll-files.shtml?ntdll

--

Harry Ohrn MS-MVP [Shell/User]
www.webtree.ca/windowsxp


"Kumaran" <subbarayan.elangkumaran@de.bosch.com> wrote in message
news:d86ftd$efv$1@ns2.fe.internet.bosch.com...
> Dear Experts,
>
> Initially I had Windows XP professional + SP2 installed on my Compaq
> Presario Laptop.
> It was working great. But, later I have given my laptop to Compaq service
> for BIOS upgrade that
> improves battery runtime. After the BIOS update, to my horror Compaq had
> reverted everything to their default installation, XP Home + SP1.
>
> I reformatted and installed XP professional again with SP1 and it was
> working fine.
> Then I have installed all the available security patches from windows
update
> and proceeded to install SP2.
> Everything was fine during installation of SP2 but after restart it did
not
> boot, just froze at XP logo screen (with running progress bar). I tried
> using safe mode, but no use, safe mode also failed to load, just froze.
>
> So I have reverted back to SP1 using XP repair installation, system starts
> fine.
> But control panel and windows explorer crashes often with an exception in
> ntdll.dll.
>
> What could be wrong with my SP2 installation, how can I fix this SP2
> installation problem.
> Any patches to fix the ntdll.dll corruption problem ?
>
> Experts, Kindly help me.
>
> Best Regards
> Kumaran
>
>

WTC
07-10-2005, 02:21 AM
"Kumaran" <subbarayan.elangkumaran@de.bosch.com> wrote in message
news:d86ftd$efv$1@ns2.fe.internet.bosch.com...
> Dear Experts,
>
> Initially I had Windows XP professional + SP2 installed on my Compaq
> Presario Laptop.
> It was working great. But, later I have given my laptop to Compaq
> service
> for BIOS upgrade that
> improves battery runtime. After the BIOS update, to my horror Compaq
> had
> reverted everything to their default installation, XP Home + SP1.
>
> I reformatted and installed XP professional again with SP1 and it was
> working fine.
> Then I have installed all the available security patches from windows
> update
> and proceeded to install SP2.
> Everything was fine during installation of SP2 but after restart it
> did not
> boot, just froze at XP logo screen (with running progress bar). I
> tried
> using safe mode, but no use, safe mode also failed to load, just
> froze.
>
> So I have reverted back to SP1 using XP repair installation, system
> starts
> fine.
> But control panel and windows explorer crashes often with an exception
> in
> ntdll.dll.
>
> What could be wrong with my SP2 installation, how can I fix this SP2
> installation problem.
> Any patches to fix the ntdll.dll corruption problem ?
>
> Experts, Kindly help me.
>

[Courtesy of MVP Ramesh Srinivasan]
How to uninstall a hotfix or Service Pack via the Recovery Console ?
http://windowsxp.mvps.org/spuninst.htm

--
William

cquirke (MVP Windows shell/user)
07-10-2005, 02:22 AM
On Wed, 8 Jun 2005 12:05:33 +0200, "Kumaran"

>Everything was fine during installation of SP2 but after restart it did not
>boot, just froze at XP logo screen (with running progress bar). I tried
>using safe mode, but no use, safe mode also failed to load, just froze.

That failure pattern sounds like the Prescott issue:

http://cquirke.mvps.org/sp2intel.htm

It's hard to imaging a "new" BIOS that's not Prescott-ready (for a
Prescott-capable mobo) in June 2005, but it's possible. It's also
possible that this failure pattern may apply to other processor
issues, such as HyperThreading etc.

You have a bland lame PC, and bland lame vendors tend to weasel out of
ongoing compatibility issues by only supporting their hardware with
the specific version of OS that it shipped with. Compaq may even
snivel that your model is only meant to work with XP Gold or XP SP1,
and not SP2 - if so, all the more reason to avoid them in future.



>------------------------ ---- --- -- - - - -
Forget http://cquirke.blogspot.com and check out a
better one at http://topicdrift.blogspot.com instead!
>------------------------ ---- --- -- - - - -

Kumaran
07-10-2005, 02:22 AM
Dear Experts,
I have installed XP Pro on D: partition and replaced hal.dll, ntldr,
ntdetect in the C: partition from SP2 "service packfiles" .
But still doesn't boot. May be I have to look for Prescott.
Any other ideas ?

Best Regards
Kumaran

> That failure pattern sounds like the Prescott issue:
>
> http://cquirke.mvps.org/sp2intel.htm
>
> It's hard to imaging a "new" BIOS that's not Prescott-ready (for a
> Prescott-capable mobo) in June 2005, but it's possible. It's also
> possible that this failure pattern may apply to other processor
> issues, such as HyperThreading etc.
>
> You have a bland lame PC, and bland lame vendors tend to weasel out of
> ongoing compatibility issues by only supporting their hardware with
> the specific version of OS that it shipped with. Compaq may even
> snivel that your model is only meant to work with XP Gold or XP SP1,
> and not SP2 - if so, all the more reason to avoid them in future.
>

Kumaran
07-10-2005, 02:26 AM
Dear Experts,

I tried all the options; replacing hal.dll, ntdll.dll, latest BIOS update
etc., and Prescott issue doesn't apply to my processor.

Still SP2 did not boot. Finally I reverted back to SP1 and happy with it.

I thank you all for your time in suggesting me.

Best Regards,

Kumaran


* Windows XP does not boot after SP2 *