wrong characters being displayed



Mike
07-10-2005, 01:14 AM
I can no longer use IE 6 or Microsoft Word because my keyboard mappings
appear to be broken. When I type 'd' the character 'e' is displayed,
likewise, when I type 'w', the '.' character is displayed. I can use
Mozilla Firefox without a problem, hence this email was typed using a
weblink to this newsgroup via firefox. My language is set to English
and the keyboard is set to US. Nothing in language or keyboard
settings appear to be wrong. Is my box infected with something? I've
run virus scans and pest patrol, cleaned up a few things but the
problem remains. Any clues? Thanks in advance...

Byte
07-10-2005, 01:14 AM
Turn PC off. Disconnect keyboard. Reboot PC. It will now pop up a balloon
that "no keyboard was connected". Shutdown again by turning off main
power to PC. Connect keyboard and reboot. This procedure may solve your
problem to reset the keyboard drivers and remap. If not, then try the
on-screen keyboard and see if that also gives incorrect type.
Start>All Programs>Accessories>Accessibility>On-Screen Keyboard.
If still not corrected, check the below website for more info:
The FreeBSD Diary -- Changing your keyboard mapping
http://www.freebsddiary.org/kbdcontrol.php
--
Some days you're the windshield,
some days you're the bug.


"Mike" wrote:

> I can no longer use IE 6 or Microsoft Word because my keyboard mappings
> appear to be broken. When I type 'd' the character 'e' is displayed,
> likewise, when I type 'w', the '.' character is displayed. I can use
> Mozilla Firefox without a problem, hence this email was typed using a
> weblink to this newsgroup via firefox. My language is set to English
> and the keyboard is set to US. Nothing in language or keyboard
> settings appear to be wrong. Is my box infected with something? I've
> run virus scans and pest patrol, cleaned up a few things but the
> problem remains. Any clues? Thanks in advance...
>
>

Mike
07-10-2005, 01:14 AM
turning pc on and off didn't work. On-Screen Keyboard shows the
"wrong" key mappings (i.e., the characters displayed are not the same
as the physical keyboard for the same keys). The website you suggested
appears to offer unix solutions only.

Mike
07-10-2005, 01:14 AM
The problem was that my keyboard setting was for United States -
Dvorak. I turned on the language bar (settings->control
panel->regional options->Input Locales->change->Language Bar->"show on
desktop" and noticed the keyboard settings noted in the language bar
would change from US to US-Dvorak when I moused over Explorer. I then
removed US_Dvorak from the keyboard settings so that US was the only
option...

problem solved


wrong characters being displayed