DVD audio choppy



Bigdaddyhen
07-10-2005, 02:14 AM
When playing DVD's, the audio is choppy. I have tried several programs
PowerDVD WMP as well as Real Player. It is choppy on all of them. I have no
problem with any streaming video or other music. But I did have some music
playing in WMP when I tried to load a DVD with PowerDVD, and both the DVD
audio and the WMP music became choppy as well, but went back to normal when I
stopped the DVD. Is this the DVD player itself, or is there something I am
missing?

Sandal
07-10-2005, 02:14 AM
Hi,
Try this,In Windows 2000 / XP:
---------------------
Go to Start - > Settings - > Control Panel - > System - > Hardware tab - >
Device Manager. Expand the tree for "IDE ATA/ATAPI controllers", click on
the controller your DVD drive is using, then click on the 'Advanced Settings'
tab. Select "DMA if available" in the "Transfer Mode" drop-down menu.
OR
www.daniweb.com/techtalkforums/ nextoldesttothread14356.html

If none of these help, suspect your DVD drive as it can't be a dirty disk
as you will have checked this?
Hope this helps

--
Sandal


"Bigdaddyhen" wrote:

> When playing DVD's, the audio is choppy. I have tried several programs
> PowerDVD WMP as well as Real Player. It is choppy on all of them. I have no
> problem with any streaming video or other music. But I did have some music
> playing in WMP when I tried to load a DVD with PowerDVD, and both the DVD
> audio and the WMP music became choppy as well, but went back to normal when I
> stopped the DVD. Is this the DVD player itself, or is there something I am
> missing?

Bigdaddyhen
07-10-2005, 02:14 AM
I did swicth everything to DMA if available already, one of the things
windows suggested, still didn't help. I have tried several disk, and still
no help. Also it is not just the audio, it appears the whole thing is in
fast forward, audio and video.

"Sandal" wrote:

> Hi,
> Try this,In Windows 2000 / XP:
> ---------------------
> Go to Start - > Settings - > Control Panel - > System - > Hardware tab - >
> Device Manager. Expand the tree for "IDE ATA/ATAPI controllers", click on
> the controller your DVD drive is using, then click on the 'Advanced Settings'
> tab. Select "DMA if available" in the "Transfer Mode" drop-down menu.
> OR
> www.daniweb.com/techtalkforums/ nextoldesttothread14356.html
>
> If none of these help, suspect your DVD drive as it can't be a dirty disk
> as you will have checked this?
> Hope this helps
>
> --
> Sandal
>
>
> "Bigdaddyhen" wrote:
>
> > When playing DVD's, the audio is choppy. I have tried several programs
> > PowerDVD WMP as well as Real Player. It is choppy on all of them. I have no
> > problem with any streaming video or other music. But I did have some music
> > playing in WMP when I tried to load a DVD with PowerDVD, and both the DVD
> > audio and the WMP music became choppy as well, but went back to normal when I
> > stopped the DVD. Is this the DVD player itself, or is there something I am
> > missing?

Sandal
07-10-2005, 02:14 AM
Bigdaddyhen

On seconds thoughts I would be surprised if it were a faulty player, however
check:
All Ram is working properly,( note ), anything less then 512 is not adequate.
It might be your IDE cable.
Have you done a recent upgrade to SP2, that can cause problems?
I assume you player is region free or that the disk is not faulty?
Are you playing ones you ripped yourself ?
Consider enabling onboard sound, see if that improves anything.
Last resort, I had to do this, ( same problem, it worked for me ), uninstall
all sound card components and re-install.
--
Sandal


"Bigdaddyhen" wrote:

> I did swicth everything to DMA if available already, one of the things
> windows suggested, still didn't help. I have tried several disk, and still
> no help. Also it is not just the audio, it appears the whole thing is in
> fast forward, audio and video.
>
> "Sandal" wrote:
>
> > Hi,
> > Try this,In Windows 2000 / XP:
> > ---------------------
> > Go to Start - > Settings - > Control Panel - > System - > Hardware tab - >
> > Device Manager. Expand the tree for "IDE ATA/ATAPI controllers", click on
> > the controller your DVD drive is using, then click on the 'Advanced Settings'
> > tab. Select "DMA if available" in the "Transfer Mode" drop-down menu.
> > OR
> > www.daniweb.com/techtalkforums/ nextoldesttothread14356.html
> >
> > If none of these help, suspect your DVD drive as it can't be a dirty disk
> > as you will have checked this?
> > Hope this helps
> >
> > --
> > Sandal
> >
> >
> > "Bigdaddyhen" wrote:
> >
> > > When playing DVD's, the audio is choppy. I have tried several programs
> > > PowerDVD WMP as well as Real Player. It is choppy on all of them. I have no
> > > problem with any streaming video or other music. But I did have some music
> > > playing in WMP when I tried to load a DVD with PowerDVD, and both the DVD
> > > audio and the WMP music became choppy as well, but went back to normal when I
> > > stopped the DVD. Is this the DVD player itself, or is there something I am
> > > missing?

Ben Foster
07-10-2005, 02:14 AM
Hi, i'm having the same problem with choppy audio, but I have noticed it
when I'm accessing my DVD drive and playing music, haven't tested it with a
DVD video yet.
My hard drive is set on the Primary IDE channel, currently using Ultra DMA
mode 5. My DVD drive is on the secondary IDE channel, but only using the PIO
transfer mode. I have the option to change that to DMA (if available), but
just need to double check if I do try this it isn't going to cause more
problems?

Also with what Sandal previously posted, all my RAM, IDE cables etc are fine
though I have updated to SP2, but not sure if the problem occured before or
after the upgrade.

Many Thanks,
Ben Foster

"Sandal" <Sandal@discussions.microsoft.com> wrote in message
news:F96C9FD2-78B9-4B54-B0EA-C24421F1A895@microsoft.com...
> Bigdaddyhen
>
> On seconds thoughts I would be surprised if it were a faulty player,
> however
> check:
> All Ram is working properly,( note ), anything less then 512 is not
> adequate.
> It might be your IDE cable.
> Have you done a recent upgrade to SP2, that can cause problems?
> I assume you player is region free or that the disk is not faulty?
> Are you playing ones you ripped yourself ?
> Consider enabling onboard sound, see if that improves anything.
> Last resort, I had to do this, ( same problem, it worked for me ),
> uninstall
> all sound card components and re-install.
> --
> Sandal
>
>
> "Bigdaddyhen" wrote:
>
>> I did swicth everything to DMA if available already, one of the things
>> windows suggested, still didn't help. I have tried several disk, and
>> still
>> no help. Also it is not just the audio, it appears the whole thing is in
>> fast forward, audio and video.
>>
>> "Sandal" wrote:
>>
>> > Hi,
>> > Try this,In Windows 2000 / XP:
>> > ---------------------
>> > Go to Start - > Settings - > Control Panel - > System - > Hardware
>> > tab - >
>> > Device Manager. Expand the tree for "IDE ATA/ATAPI controllers",
>> > click on
>> > the controller your DVD drive is using, then click on the 'Advanced
>> > Settings'
>> > tab. Select "DMA if available" in the "Transfer Mode" drop-down menu.
>> > OR
>> > www.daniweb.com/techtalkforums/ nextoldesttothread14356.html
>> >
>> > If none of these help, suspect your DVD drive as it can't be a dirty
>> > disk
>> > as you will have checked this?
>> > Hope this helps
>> >
>> > --
>> > Sandal
>> >
>> >
>> > "Bigdaddyhen" wrote:
>> >
>> > > When playing DVD's, the audio is choppy. I have tried several
>> > > programs
>> > > PowerDVD WMP as well as Real Player. It is choppy on all of them. I
>> > > have no
>> > > problem with any streaming video or other music. But I did have some
>> > > music
>> > > playing in WMP when I tried to load a DVD with PowerDVD, and both the
>> > > DVD
>> > > audio and the WMP music became choppy as well, but went back to
>> > > normal when I
>> > > stopped the DVD. Is this the DVD player itself, or is there
>> > > something I am
>> > > missing?

Ben Foster
07-10-2005, 02:14 AM
Hey, am not sure if we have exactly the same problem, but i fixed mine by
looking on this website:
http://www.michna.com/kb/WxDMA.htm
It talks about deleting a certain registry key so that Win XP redetects the
DMA capabilities of that IDE channel.

Hope this helps
Ben Foster

"Ben Foster" <ben.foster@****zooM**/-.co.uk> wrote in message
news:d7hjei$5j1$1@news7.svr.pol.co.uk...
> Hi, i'm having the same problem with choppy audio, but I have noticed it
> when I'm accessing my DVD drive and playing music, haven't tested it with
> a DVD video yet.
> My hard drive is set on the Primary IDE channel, currently using Ultra DMA
> mode 5. My DVD drive is on the secondary IDE channel, but only using the
> PIO transfer mode. I have the option to change that to DMA (if available),
> but just need to double check if I do try this it isn't going to cause
> more problems?
>
> Also with what Sandal previously posted, all my RAM, IDE cables etc are
> fine though I have updated to SP2, but not sure if the problem occured
> before or after the upgrade.
>
> Many Thanks,
> Ben Foster
>
> "Sandal" <Sandal@discussions.microsoft.com> wrote in message
> news:F96C9FD2-78B9-4B54-B0EA-C24421F1A895@microsoft.com...
>> Bigdaddyhen
>>
>> On seconds thoughts I would be surprised if it were a faulty player,
>> however
>> check:
>> All Ram is working properly,( note ), anything less then 512 is not
>> adequate.
>> It might be your IDE cable.
>> Have you done a recent upgrade to SP2, that can cause problems?
>> I assume you player is region free or that the disk is not faulty?
>> Are you playing ones you ripped yourself ?
>> Consider enabling onboard sound, see if that improves anything.
>> Last resort, I had to do this, ( same problem, it worked for me ),
>> uninstall
>> all sound card components and re-install.
>> --
>> Sandal
>>
>>
>> "Bigdaddyhen" wrote:
>>
>>> I did swicth everything to DMA if available already, one of the things
>>> windows suggested, still didn't help. I have tried several disk, and
>>> still
>>> no help. Also it is not just the audio, it appears the whole thing is
>>> in
>>> fast forward, audio and video.
>>>
>>> "Sandal" wrote:
>>>
>>> > Hi,
>>> > Try this,In Windows 2000 / XP:
>>> > ---------------------
>>> > Go to Start - > Settings - > Control Panel - > System - > Hardware
>>> > tab - >
>>> > Device Manager. Expand the tree for "IDE ATA/ATAPI controllers",
>>> > click on
>>> > the controller your DVD drive is using, then click on the 'Advanced
>>> > Settings'
>>> > tab. Select "DMA if available" in the "Transfer Mode" drop-down menu.
>>> > OR
>>> > www.daniweb.com/techtalkforums/ nextoldesttothread14356.html
>>> >
>>> > If none of these help, suspect your DVD drive as it can't be a dirty
>>> > disk
>>> > as you will have checked this?
>>> > Hope this helps
>>> >
>>> > --
>>> > Sandal
>>> >
>>> >
>>> > "Bigdaddyhen" wrote:
>>> >
>>> > > When playing DVD's, the audio is choppy. I have tried several
>>> > > programs
>>> > > PowerDVD WMP as well as Real Player. It is choppy on all of them.
>>> > > I have no
>>> > > problem with any streaming video or other music. But I did have
>>> > > some music
>>> > > playing in WMP when I tried to load a DVD with PowerDVD, and both
>>> > > the DVD
>>> > > audio and the WMP music became choppy as well, but went back to
>>> > > normal when I
>>> > > stopped the DVD. Is this the DVD player itself, or is there
>>> > > something I am
>>> > > missing?
>
>

Sandal
07-10-2005, 02:15 AM
Hi BIgdaddyhen
Try this as well
Un-installing you CD burning software , remove the drives from device manger
and reboot allowing them to be detected and reinstalled, then reinstall your
CD Burning software.
Try swapping your drives around it has been know to resolve skipping &
choping issues.
Did you know
XP can by itself reset the mode of your CD/DVD drives if it thinks they are
wrong.
Windows XP will turn off DMA mode for a device after encountering five
errors during data transfer or playback operations, ( dirty disks ect ),
Windows will turn off DMA and use only PIO mode on that device.
Also if possible, the operating system will step down one UDMA mode at a
time (from UDMA mode 4 to UDMA mode 3, and so on), this will effect sound and
picture.
This is about the limit of my experience, I hope it has been of some use to
you.
Sandal


"Bigdaddyhen" wrote:

> I did swicth everything to DMA if available already, one of the things
> windows suggested, still didn't help. I have tried several disk, and still
> no help. Also it is not just the audio, it appears the whole thing is in
> fast forward, audio and video.
>
> "Sandal" wrote:
>
> > Hi,
> > Try this,In Windows 2000 / XP:
> > ---------------------
> > Go to Start - > Settings - > Control Panel - > System - > Hardware tab - >
> > Device Manager. Expand the tree for "IDE ATA/ATAPI controllers", click on
> > the controller your DVD drive is using, then click on the 'Advanced Settings'
> > tab. Select "DMA if available" in the "Transfer Mode" drop-down menu.
> > OR
> > www.daniweb.com/techtalkforums/ nextoldesttothread14356.html
> >
> > If none of these help, suspect your DVD drive as it can't be a dirty disk
> > as you will have checked this?
> > Hope this helps
> >
> > --
> > Sandal
> >
> >
> > "Bigdaddyhen" wrote:
> >
> > > When playing DVD's, the audio is choppy. I have tried several programs
> > > PowerDVD WMP as well as Real Player. It is choppy on all of them. I have no
> > > problem with any streaming video or other music. But I did have some music
> > > playing in WMP when I tried to load a DVD with PowerDVD, and both the DVD
> > > audio and the WMP music became choppy as well, but went back to normal when I
> > > stopped the DVD. Is this the DVD player itself, or is there something I am
> > > missing?

Sandal
07-10-2005, 02:15 AM
Hi Ben,
In answer to your question, I don't know, I see know reason why not.
I will never know what caused my problem it was resolved by un-installing
and re-installing all sound components.
IF you are still having problems, try,
Un-installing you CD burning software , remove the drives from device manger
and reboot allowing them to be detected and reinstalled, then reinstall your
CD Burning software.
Try swapping your drives around it has been know to resolve skipping &
choping issues.
XP can by itself reset the mode of your CD/DVD drives if it thinks they are
wrong.
Windows XP will turn off DMA mode for a device after encountering five
errors during data transfer or playback operations, ( dirty disks ect ),
Windows will turn off DMA and use only PIO mode on that device.
Also if possible, the operating system will step down one UDMA mode at a
time (from UDMA mode 4 to UDMA mode 3, and so on), this will effect sound and
picture.
The registry tweek you mention works well for XP PRO but there are issues
when using it for XP Home although it can work.
Anybody reading these posts who undertakes the registery hack mentioned,
PLEASE, BACK UP YOUR REGISTRY BEFORE UNDERTAKING IT.
This is about the limit of my experience, I hope it has been of some use to
you.
--
Sandal


"Ben Foster" wrote:

> Hey, am not sure if we have exactly the same problem, but i fixed mine by
> looking on this website:
> http://www.michna.com/kb/WxDMA.htm
> It talks about deleting a certain registry key so that Win XP redetects the
> DMA capabilities of that IDE channel.
>
> Hope this helps
> Ben Foster
>
> "Ben Foster" <ben.foster@****zooM**/-.co.uk> wrote in message
> news:d7hjei$5j1$1@news7.svr.pol.co.uk...
> > Hi, i'm having the same problem with choppy audio, but I have noticed it
> > when I'm accessing my DVD drive and playing music, haven't tested it with
> > a DVD video yet.
> > My hard drive is set on the Primary IDE channel, currently using Ultra DMA
> > mode 5. My DVD drive is on the secondary IDE channel, but only using the
> > PIO transfer mode. I have the option to change that to DMA (if available),
> > but just need to double check if I do try this it isn't going to cause
> > more problems?
> >
> > Also with what Sandal previously posted, all my RAM, IDE cables etc are
> > fine though I have updated to SP2, but not sure if the problem occured
> > before or after the upgrade.
> >
> > Many Thanks,
> > Ben Foster
> >
> > "Sandal" <Sandal@discussions.microsoft.com> wrote in message
> > news:F96C9FD2-78B9-4B54-B0EA-C24421F1A895@microsoft.com...
> >> Bigdaddyhen
> >>
> >> On seconds thoughts I would be surprised if it were a faulty player,
> >> however
> >> check:
> >> All Ram is working properly,( note ), anything less then 512 is not
> >> adequate.
> >> It might be your IDE cable.
> >> Have you done a recent upgrade to SP2, that can cause problems?
> >> I assume you player is region free or that the disk is not faulty?
> >> Are you playing ones you ripped yourself ?
> >> Consider enabling onboard sound, see if that improves anything.
> >> Last resort, I had to do this, ( same problem, it worked for me ),
> >> uninstall
> >> all sound card components and re-install.
> >> --
> >> Sandal
> >>
> >>
> >> "Bigdaddyhen" wrote:
> >>
> >>> I did swicth everything to DMA if available already, one of the things
> >>> windows suggested, still didn't help. I have tried several disk, and
> >>> still
> >>> no help. Also it is not just the audio, it appears the whole thing is
> >>> in
> >>> fast forward, audio and video.
> >>>
> >>> "Sandal" wrote:
> >>>
> >>> > Hi,
> >>> > Try this,In Windows 2000 / XP:
> >>> > ---------------------
> >>> > Go to Start - > Settings - > Control Panel - > System - > Hardware
> >>> > tab - >
> >>> > Device Manager. Expand the tree for "IDE ATA/ATAPI controllers",
> >>> > click on
> >>> > the controller your DVD drive is using, then click on the 'Advanced
> >>> > Settings'
> >>> > tab. Select "DMA if available" in the "Transfer Mode" drop-down menu.
> >>> > OR
> >>> > www.daniweb.com/techtalkforums/ nextoldesttothread14356.html
> >>> >
> >>> > If none of these help, suspect your DVD drive as it can't be a dirty
> >>> > disk
> >>> > as you will have checked this?
> >>> > Hope this helps
> >>> >
> >>> > --
> >>> > Sandal
> >>> >
> >>> >
> >>> > "Bigdaddyhen" wrote:
> >>> >
> >>> > > When playing DVD's, the audio is choppy. I have tried several
> >>> > > programs
> >>> > > PowerDVD WMP as well as Real Player. It is choppy on all of them.
> >>> > > I have no
> >>> > > problem with any streaming video or other music. But I did have
> >>> > > some music
> >>> > > playing in WMP when I tried to load a DVD with PowerDVD, and both
> >>> > > the DVD
> >>> > > audio and the WMP music became choppy as well, but went back to
> >>> > > normal when I
> >>> > > stopped the DVD. Is this the DVD player itself, or is there
> >>> > > something I am
> >>> > > missing?
> >
> >
>
>
>

Bigdaddyhen
07-10-2005, 02:15 AM
Well, that worked. I did notice while I had it set to DMA if available, it
was actually set to PIO

"Ben Foster" wrote:

> Hey, am not sure if we have exactly the same problem, but i fixed mine by
> looking on this website:
> http://www.michna.com/kb/WxDMA.htm
> It talks about deleting a certain registry key so that Win XP redetects the
> DMA capabilities of that IDE channel.
>
> Hope this helps
> Ben Foster
>
> "Ben Foster" <ben.foster@****zooM**/-.co.uk> wrote in message
> news:d7hjei$5j1$1@news7.svr.pol.co.uk...
> > Hi, i'm having the same problem with choppy audio, but I have noticed it
> > when I'm accessing my DVD drive and playing music, haven't tested it with
> > a DVD video yet.
> > My hard drive is set on the Primary IDE channel, currently using Ultra DMA
> > mode 5. My DVD drive is on the secondary IDE channel, but only using the
> > PIO transfer mode. I have the option to change that to DMA (if available),
> > but just need to double check if I do try this it isn't going to cause
> > more problems?
> >
> > Also with what Sandal previously posted, all my RAM, IDE cables etc are
> > fine though I have updated to SP2, but not sure if the problem occured
> > before or after the upgrade.
> >
> > Many Thanks,
> > Ben Foster
> >
> > "Sandal" <Sandal@discussions.microsoft.com> wrote in message
> > news:F96C9FD2-78B9-4B54-B0EA-C24421F1A895@microsoft.com...
> >> Bigdaddyhen
> >>
> >> On seconds thoughts I would be surprised if it were a faulty player,
> >> however
> >> check:
> >> All Ram is working properly,( note ), anything less then 512 is not
> >> adequate.
> >> It might be your IDE cable.
> >> Have you done a recent upgrade to SP2, that can cause problems?
> >> I assume you player is region free or that the disk is not faulty?
> >> Are you playing ones you ripped yourself ?
> >> Consider enabling onboard sound, see if that improves anything.
> >> Last resort, I had to do this, ( same problem, it worked for me ),
> >> uninstall
> >> all sound card components and re-install.
> >> --
> >> Sandal
> >>
> >>
> >> "Bigdaddyhen" wrote:
> >>
> >>> I did swicth everything to DMA if available already, one of the things
> >>> windows suggested, still didn't help. I have tried several disk, and
> >>> still
> >>> no help. Also it is not just the audio, it appears the whole thing is
> >>> in
> >>> fast forward, audio and video.
> >>>
> >>> "Sandal" wrote:
> >>>
> >>> > Hi,
> >>> > Try this,In Windows 2000 / XP:
> >>> > ---------------------
> >>> > Go to Start - > Settings - > Control Panel - > System - > Hardware
> >>> > tab - >
> >>> > Device Manager. Expand the tree for "IDE ATA/ATAPI controllers",
> >>> > click on
> >>> > the controller your DVD drive is using, then click on the 'Advanced
> >>> > Settings'
> >>> > tab. Select "DMA if available" in the "Transfer Mode" drop-down menu.
> >>> > OR
> >>> > www.daniweb.com/techtalkforums/ nextoldesttothread14356.html
> >>> >
> >>> > If none of these help, suspect your DVD drive as it can't be a dirty
> >>> > disk
> >>> > as you will have checked this?
> >>> > Hope this helps
> >>> >
> >>> > --
> >>> > Sandal
> >>> >
> >>> >
> >>> > "Bigdaddyhen" wrote:
> >>> >
> >>> > > When playing DVD's, the audio is choppy. I have tried several
> >>> > > programs
> >>> > > PowerDVD WMP as well as Real Player. It is choppy on all of them.
> >>> > > I have no
> >>> > > problem with any streaming video or other music. But I did have
> >>> > > some music
> >>> > > playing in WMP when I tried to load a DVD with PowerDVD, and both
> >>> > > the DVD
> >>> > > audio and the WMP music became choppy as well, but went back to
> >>> > > normal when I
> >>> > > stopped the DVD. Is this the DVD player itself, or is there
> >>> > > something I am
> >>> > > missing?
> >
> >
>
>
>


DVD audio choppy