Installation of SP2 Causes Re-Boot Failure



shanegarr
07-10-2005, 01:08 AM
I have installed the Win XPsp2 into my XP Pro system several times now only
to keep getting the same error when I re-start my computer. The error states
that "Windows could not start because the following file is missing or
corrupt: <windows root> \system32\hal.dll Please re-install a copy of the
above file". The file is still in the windows root so it isn't missing, I
copied the hal.dl_ file from the windows cd to the rood dir and renamed it
hal.dll. When I rebooted the system I received a different error, "load
needed dll's for kernel contact system administrator" and Windows will still
not start. I can't boot into safe mode, system restore, debugging or last
known good. I formated my hard drive, re-installed Win XP Pro and tried again
but this time I made a copy of hal.dll from my system before installing the
SP2, which is on a CD that I got from Microsoft not a downloaded version. I
got the same error so I copied my file into the Windows root and received the
same second error again. I'm going crazy trying to figure this out. I have
formatted my hard drive and re-installed Windows quite a few times and have
finally given up on installing the SP2 into my system. Can someone help me
out on this one?

Andrew E.
07-10-2005, 01:08 AM
Try installing the xp cd,exit the info page,then go to run,type:cmd In cmd
type:Sfc /Scannow When its thru,type:CHKDSK C: /F Agree to restart,then
type:EXIT Restart computer,remove xp cd,then reinstall SP2 You should also
set for CHKDSK C: /F To run after SP2 is installed

"shanegarr" wrote:

> I have installed the Win XPsp2 into my XP Pro system several times now only
> to keep getting the same error when I re-start my computer. The error states
> that "Windows could not start because the following file is missing or
> corrupt: <windows root> \system32\hal.dll Please re-install a copy of the
> above file". The file is still in the windows root so it isn't missing, I
> copied the hal.dl_ file from the windows cd to the rood dir and renamed it
> hal.dll. When I rebooted the system I received a different error, "load
> needed dll's for kernel contact system administrator" and Windows will still
> not start. I can't boot into safe mode, system restore, debugging or last
> known good. I formated my hard drive, re-installed Win XP Pro and tried again
> but this time I made a copy of hal.dll from my system before installing the
> SP2, which is on a CD that I got from Microsoft not a downloaded version. I
> got the same error so I copied my file into the Windows root and received the
> same second error again. I'm going crazy trying to figure this out. I have
> formatted my hard drive and re-installed Windows quite a few times and have
> finally given up on installing the SP2 into my system. Can someone help me
> out on this one?

shanegarr
07-10-2005, 01:08 AM
Thanks for the information. I will try that and see if it works. If it
doesn't I will have to re-install Windows again because after I get the
intial error, Nothing I do will bring back Windows. Not even the ASR disk.

"Andrew E." wrote:

> Try installing the xp cd,exit the info page,then go to run,type:cmd In cmd
> type:Sfc /Scannow When its thru,type:CHKDSK C: /F Agree to restart,then
> type:EXIT Restart computer,remove xp cd,then reinstall SP2 You should also
> set for CHKDSK C: /F To run after SP2 is installed
>
> "shanegarr" wrote:
>
> > I have installed the Win XPsp2 into my XP Pro system several times now only
> > to keep getting the same error when I re-start my computer. The error states
> > that "Windows could not start because the following file is missing or
> > corrupt: <windows root> \system32\hal.dll Please re-install a copy of the
> > above file". The file is still in the windows root so it isn't missing, I
> > copied the hal.dl_ file from the windows cd to the rood dir and renamed it
> > hal.dll. When I rebooted the system I received a different error, "load
> > needed dll's for kernel contact system administrator" and Windows will still
> > not start. I can't boot into safe mode, system restore, debugging or last
> > known good. I formated my hard drive, re-installed Win XP Pro and tried again
> > but this time I made a copy of hal.dll from my system before installing the
> > SP2, which is on a CD that I got from Microsoft not a downloaded version. I
> > got the same error so I copied my file into the Windows root and received the
> > same second error again. I'm going crazy trying to figure this out. I have
> > formatted my hard drive and re-installed Windows quite a few times and have
> > finally given up on installing the SP2 into my system. Can someone help me
> > out on this one?


Installation of SP2 Causes Re-Boot Failure