Re: CSV Downloads



Rod V
07-10-2005, 01:04 AM
Bank statements allegedly in CSV format downloaded correctly into Excel 97
SR-2 on a Windows 98 system but NOT when XP (home edition) is used because
then the rows of data occupy only one column. Applying the alternative fix
from Ramesh allows the file to be saved from the open spreadsheet in .txt
format. When this file is reopened a series of options allow the file to be
viewed correctly ( ie columns as well as rows ). There must be a better way.

"Ramesh, MS-MVP" wrote:

> Dave,
>
> Here is another method: (But the changes are applied to CSV, XLS AND other
> file types handled by MS Excel)
>
> 1. Open My Computer.
> 2. On the Tools menu (or the View menu), click Folder Options (or click
> Options).
> 3. Click the File Types tab.
> 4. In the Registered file types list, click "Microsoft Excel Worksheet", and
> then click Advanced (or click Edit).
> 5. In the Edit File Type dialog box, uncheck "Browse in same window" check
> box
> 6. Click OK.
>
> How to configure Internet Explorer to open Office documents in the
> appropriate Office program instead of in Internet Explorer:
> http://support.microsoft.com/default.aspx?scid=162059
>
> --
> Ramesh, Microsoft MVP
> Windows XP Shell/User
> http://windowsxp.mvps.org
>
>
> "Ramesh, MS-MVP" <ramesh@online.mvps.org> wrote in message
> news:O$qpSQFDFHA.3908@TK2MSFTNGP15.phx.gbl...
> > Hi Dave,
> >
> > This problem can be resolved by modifying a couple of registry values.
> >
> > 1. Create a System Restore point if you want to undo the following
> > operation
> > 2. Open Regedit and navigate to:
> >
> > [HKEY_CLASSES_ROOT\.CSV]
> >
> > 3. In the right-pane, double-click "Content Type" and delete it
> > 4. Navigate to:
> >
> > [HKEY_CLASSES_ROOT\Excel.CSV\CLSID]
> >
> > 5. Rename the key "CLSID" to "CLSID-"
> >
> >
> > NOTE: With missing Content Type value and missing Workbook CLSID,
> > Internet Explorer cannot execute the .CSV file, and you'll be presented
> > with the Open/Save As prompt when you click your bank statement (.CSV
> > file). Should you need to open a CSV file in Internet Explorer (embedded
> > document) in future, reverse the above steps.
> >
> > Hope this helps, and keep us posted!
> >
> > --
> > Ramesh, Microsoft MVP
> > Windows XP Shell/User
> > http://windowsxp.mvps.org
> >
> >
> > "Dave L" <DaveL@discussions.microsoft.com> wrote in message
> > news:E94CA24D-5E1B-4F5D-8E04-A3262C029E72@microsoft.com...
> >> Thanks for the replies,
> >> When I try to download my statement I am given the 5 options via a
> >> dropdown
> >> menu of - Microsoft Money, Quicken 2001, Quicken 98, Sage Line 50 (all
> >> OFX
> >> files) and Microsoft Excel (CSV file). On my Win2K machine I select CSV
> >> and
> >> am presented with a file download box. My option is where I would like to
> >> save it as a .csv file. On the XP machine I select CSV and Excel is
> >> opened in
> >> I.E. I do not appear to have any control over file associations. All I
> >> can
> >> then do is copy and paste the related data into a seperately opened excel
> >> workbook.
> >> I hope this explains things more clearly.
> >>
>
>

Ramesh, MS-MVP
07-10-2005, 01:04 AM
Rod,

Have you tried setting it to "Browse in same window" ?

--
Ramesh, Microsoft MVP
Windows XP Shell/User
http://windowsxp.mvps.org


"Rod V" <Rod V@discussions.microsoft.com> wrote in message
news:134D27E1-2358-48E2-914E-064EFCE39BD7@microsoft.com...
> Bank statements allegedly in CSV format downloaded correctly into Excel 97
> SR-2 on a Windows 98 system but NOT when XP (home edition) is used because
> then the rows of data occupy only one column. Applying the alternative fix
> from Ramesh allows the file to be saved from the open spreadsheet in .txt
> format. When this file is reopened a series of options allow the file to
> be
> viewed correctly ( ie columns as well as rows ). There must be a better
> way.
>
> "Ramesh, MS-MVP" wrote:
>
>> Dave,
>>
>> Here is another method: (But the changes are applied to CSV, XLS AND
>> other
>> file types handled by MS Excel)
>>
>> 1. Open My Computer.
>> 2. On the Tools menu (or the View menu), click Folder Options (or click
>> Options).
>> 3. Click the File Types tab.
>> 4. In the Registered file types list, click "Microsoft Excel Worksheet",
>> and
>> then click Advanced (or click Edit).
>> 5. In the Edit File Type dialog box, uncheck "Browse in same window"
>> check
>> box
>> 6. Click OK.
>>
>> How to configure Internet Explorer to open Office documents in the
>> appropriate Office program instead of in Internet Explorer:
>> http://support.microsoft.com/default.aspx?scid=162059
>>
>> --
>> Ramesh, Microsoft MVP
>> Windows XP Shell/User
>> http://windowsxp.mvps.org
>>
>>
>> "Ramesh, MS-MVP" <ramesh@online.mvps.org> wrote in message
>> news:O$qpSQFDFHA.3908@TK2MSFTNGP15.phx.gbl...
>> > Hi Dave,
>> >
>> > This problem can be resolved by modifying a couple of registry values.
>> >
>> > 1. Create a System Restore point if you want to undo the following
>> > operation
>> > 2. Open Regedit and navigate to:
>> >
>> > [HKEY_CLASSES_ROOT\.CSV]
>> >
>> > 3. In the right-pane, double-click "Content Type" and delete it
>> > 4. Navigate to:
>> >
>> > [HKEY_CLASSES_ROOT\Excel.CSV\CLSID]
>> >
>> > 5. Rename the key "CLSID" to "CLSID-"
>> >
>> >
>> > NOTE: With missing Content Type value and missing Workbook CLSID,
>> > Internet Explorer cannot execute the .CSV file, and you'll be presented
>> > with the Open/Save As prompt when you click your bank statement (.CSV
>> > file). Should you need to open a CSV file in Internet Explorer
>> > (embedded
>> > document) in future, reverse the above steps.
>> >
>> > Hope this helps, and keep us posted!
>> >
>> > --
>> > Ramesh, Microsoft MVP
>> > Windows XP Shell/User
>> > http://windowsxp.mvps.org
>> >
>> >
>> > "Dave L" <DaveL@discussions.microsoft.com> wrote in message
>> > news:E94CA24D-5E1B-4F5D-8E04-A3262C029E72@microsoft.com...
>> >> Thanks for the replies,
>> >> When I try to download my statement I am given the 5 options via a
>> >> dropdown
>> >> menu of - Microsoft Money, Quicken 2001, Quicken 98, Sage Line 50 (all
>> >> OFX
>> >> files) and Microsoft Excel (CSV file). On my Win2K machine I select
>> >> CSV
>> >> and
>> >> am presented with a file download box. My option is where I would like
>> >> to
>> >> save it as a .csv file. On the XP machine I select CSV and Excel is
>> >> opened in
>> >> I.E. I do not appear to have any control over file associations. All I
>> >> can
>> >> then do is copy and paste the related data into a seperately opened
>> >> excel
>> >> workbook.
>> >> I hope this explains things more clearly.
>> >>
>>
>>

Ramesh, MS-MVP
07-10-2005, 01:04 AM
Correction:

Have you tried unchecking the "Browse in same window" in folder options?

--
Ramesh, Microsoft MVP
Windows XP Shell/User
http://windowsxp.mvps.org


"Ramesh, MS-MVP" <ramesh@online.mvps.org> wrote in message
news:%23gzvahpWFHA.712@TK2MSFTNGP14.phx.gbl...
> Rod,
>
> Have you tried setting it to "Browse in same window" ?
>
> --
> Ramesh, Microsoft MVP
> Windows XP Shell/User
> http://windowsxp.mvps.org
>
>
> "Rod V" <Rod V@discussions.microsoft.com> wrote in message
> news:134D27E1-2358-48E2-914E-064EFCE39BD7@microsoft.com...
>> Bank statements allegedly in CSV format downloaded correctly into Excel
>> 97
>> SR-2 on a Windows 98 system but NOT when XP (home edition) is used
>> because
>> then the rows of data occupy only one column. Applying the alternative
>> fix
>> from Ramesh allows the file to be saved from the open spreadsheet in .txt
>> format. When this file is reopened a series of options allow the file to
>> be
>> viewed correctly ( ie columns as well as rows ). There must be a better
>> way.
>>
>> "Ramesh, MS-MVP" wrote:
>>
>>> Dave,
>>>
>>> Here is another method: (But the changes are applied to CSV, XLS AND
>>> other
>>> file types handled by MS Excel)
>>>
>>> 1. Open My Computer.
>>> 2. On the Tools menu (or the View menu), click Folder Options (or click
>>> Options).
>>> 3. Click the File Types tab.
>>> 4. In the Registered file types list, click "Microsoft Excel Worksheet",
>>> and
>>> then click Advanced (or click Edit).
>>> 5. In the Edit File Type dialog box, uncheck "Browse in same window"
>>> check
>>> box
>>> 6. Click OK.
>>>
>>> How to configure Internet Explorer to open Office documents in the
>>> appropriate Office program instead of in Internet Explorer:
>>> http://support.microsoft.com/default.aspx?scid=162059
>>>
>>> --
>>> Ramesh, Microsoft MVP
>>> Windows XP Shell/User
>>> http://windowsxp.mvps.org
>>>
>>>
>>> "Ramesh, MS-MVP" <ramesh@online.mvps.org> wrote in message
>>> news:O$qpSQFDFHA.3908@TK2MSFTNGP15.phx.gbl...
>>> > Hi Dave,
>>> >
>>> > This problem can be resolved by modifying a couple of registry values.
>>> >
>>> > 1. Create a System Restore point if you want to undo the following
>>> > operation
>>> > 2. Open Regedit and navigate to:
>>> >
>>> > [HKEY_CLASSES_ROOT\.CSV]
>>> >
>>> > 3. In the right-pane, double-click "Content Type" and delete it
>>> > 4. Navigate to:
>>> >
>>> > [HKEY_CLASSES_ROOT\Excel.CSV\CLSID]
>>> >
>>> > 5. Rename the key "CLSID" to "CLSID-"
>>> >
>>> >
>>> > NOTE: With missing Content Type value and missing Workbook CLSID,
>>> > Internet Explorer cannot execute the .CSV file, and you'll be
>>> > presented
>>> > with the Open/Save As prompt when you click your bank statement (.CSV
>>> > file). Should you need to open a CSV file in Internet Explorer
>>> > (embedded
>>> > document) in future, reverse the above steps.
>>> >
>>> > Hope this helps, and keep us posted!
>>> >
>>> > --
>>> > Ramesh, Microsoft MVP
>>> > Windows XP Shell/User
>>> > http://windowsxp.mvps.org
>>> >
>>> >
>>> > "Dave L" <DaveL@discussions.microsoft.com> wrote in message
>>> > news:E94CA24D-5E1B-4F5D-8E04-A3262C029E72@microsoft.com...
>>> >> Thanks for the replies,
>>> >> When I try to download my statement I am given the 5 options via a
>>> >> dropdown
>>> >> menu of - Microsoft Money, Quicken 2001, Quicken 98, Sage Line 50
>>> >> (all
>>> >> OFX
>>> >> files) and Microsoft Excel (CSV file). On my Win2K machine I select
>>> >> CSV
>>> >> and
>>> >> am presented with a file download box. My option is where I would
>>> >> like to
>>> >> save it as a .csv file. On the XP machine I select CSV and Excel is
>>> >> opened in
>>> >> I.E. I do not appear to have any control over file associations. All
>>> >> I
>>> >> can
>>> >> then do is copy and paste the related data into a seperately opened
>>> >> excel
>>> >> workbook.
>>> >> I hope this explains things more clearly.
>>> >>
>>>
>>>
>

Rod V
07-10-2005, 01:05 AM
Both .xlb and.xls file types of "Microsoft Excel Worksheet are unchecked for
"Browse in the Same Window" using the method Ramesh suggested ( the registry
has not been edited ).


"Ramesh, MS-MVP" wrote:

> Correction:
>
> Have you tried unchecking the "Browse in same window" in folder options?
>
> --
> Ramesh, Microsoft MVP
> Windows XP Shell/User
> http://windowsxp.mvps.org
>
>
> "Ramesh, MS-MVP" <ramesh@online.mvps.org> wrote in message
> news:%23gzvahpWFHA.712@TK2MSFTNGP14.phx.gbl...
> > Rod,
> >
> > Have you tried setting it to "Browse in same window" ?
> >
> > --
> > Ramesh, Microsoft MVP
> > Windows XP Shell/User
> > http://windowsxp.mvps.org
> >
> >
> > "Rod V" <Rod V@discussions.microsoft.com> wrote in message
> > news:134D27E1-2358-48E2-914E-064EFCE39BD7@microsoft.com...
> >> Bank statements allegedly in CSV format downloaded correctly into Excel
> >> 97
> >> SR-2 on a Windows 98 system but NOT when XP (home edition) is used
> >> because
> >> then the rows of data occupy only one column. Applying the alternative
> >> fix
> >> from Ramesh allows the file to be saved from the open spreadsheet in .txt
> >> format. When this file is reopened a series of options allow the file to
> >> be
> >> viewed correctly ( ie columns as well as rows ). There must be a better
> >> way.
> >>
> >> "Ramesh, MS-MVP" wrote:
> >>
> >>> Dave,
> >>>
> >>> Here is another method: (But the changes are applied to CSV, XLS AND
> >>> other
> >>> file types handled by MS Excel)
> >>>
> >>> 1. Open My Computer.
> >>> 2. On the Tools menu (or the View menu), click Folder Options (or click
> >>> Options).
> >>> 3. Click the File Types tab.
> >>> 4. In the Registered file types list, click "Microsoft Excel Worksheet",
> >>> and
> >>> then click Advanced (or click Edit).
> >>> 5. In the Edit File Type dialog box, uncheck "Browse in same window"
> >>> check
> >>> box
> >>> 6. Click OK.
> >>>
> >>> How to configure Internet Explorer to open Office documents in the
> >>> appropriate Office program instead of in Internet Explorer:
> >>> http://support.microsoft.com/default.aspx?scid=162059
> >>>
> >>> --
> >>> Ramesh, Microsoft MVP
> >>> Windows XP Shell/User
> >>> http://windowsxp.mvps.org
> >>>
> >>>
> >>> "Ramesh, MS-MVP" <ramesh@online.mvps.org> wrote in message
> >>> news:O$qpSQFDFHA.3908@TK2MSFTNGP15.phx.gbl...
> >>> > Hi Dave,
> >>> >
> >>> > This problem can be resolved by modifying a couple of registry values.
> >>> >
> >>> > 1. Create a System Restore point if you want to undo the following
> >>> > operation
> >>> > 2. Open Regedit and navigate to:
> >>> >
> >>> > [HKEY_CLASSES_ROOT\.CSV]
> >>> >
> >>> > 3. In the right-pane, double-click "Content Type" and delete it
> >>> > 4. Navigate to:
> >>> >
> >>> > [HKEY_CLASSES_ROOT\Excel.CSV\CLSID]
> >>> >
> >>> > 5. Rename the key "CLSID" to "CLSID-"
> >>> >
> >>> >
> >>> > NOTE: With missing Content Type value and missing Workbook CLSID,
> >>> > Internet Explorer cannot execute the .CSV file, and you'll be
> >>> > presented
> >>> > with the Open/Save As prompt when you click your bank statement (.CSV
> >>> > file). Should you need to open a CSV file in Internet Explorer
> >>> > (embedded
> >>> > document) in future, reverse the above steps.
> >>> >
> >>> > Hope this helps, and keep us posted!
> >>> >
> >>> > --
> >>> > Ramesh, Microsoft MVP
> >>> > Windows XP Shell/User
> >>> > http://windowsxp.mvps.org
> >>> >
> >>> >
> >>> > "Dave L" <DaveL@discussions.microsoft.com> wrote in message
> >>> > news:E94CA24D-5E1B-4F5D-8E04-A3262C029E72@microsoft.com...
> >>> >> Thanks for the replies,
> >>> >> When I try to download my statement I am given the 5 options via a
> >>> >> dropdown
> >>> >> menu of - Microsoft Money, Quicken 2001, Quicken 98, Sage Line 50
> >>> >> (all
> >>> >> OFX
> >>> >> files) and Microsoft Excel (CSV file). On my Win2K machine I select
> >>> >> CSV
> >>> >> and
> >>> >> am presented with a file download box. My option is where I would
> >>> >> like to
> >>> >> save it as a .csv file. On the XP machine I select CSV and Excel is
> >>> >> opened in
> >>> >> I.E. I do not appear to have any control over file associations. All
> >>> >> I
> >>> >> can
> >>> >> then do is copy and paste the related data into a seperately opened
> >>> >> excel
> >>> >> workbook.
> >>> >> I hope this explains things more clearly.
> >>> >>
> >>>
> >>>
> >
>
>

shakey
07-10-2005, 01:05 AM
Rod, I have not been following this thread but I would suggest a EXCEL site.
I had a similar, but different enough so I cant help, problem and they
helped.
SG
"Rod V" <RodV@discussions.microsoft.com> wrote in message
news:25E504EC-D369-4535-AB1E-C85021DB03EA@microsoft.com...
> Both .xlb and.xls file types of "Microsoft Excel Worksheet are unchecked
> for
> "Browse in the Same Window" using the method Ramesh suggested ( the
> registry
> has not been edited ).
>
>
> "Ramesh, MS-MVP" wrote:
>
>> Correction:
>>
>> Have you tried unchecking the "Browse in same window" in folder options?
>>
>> --
>> Ramesh, Microsoft MVP
>> Windows XP Shell/User
>> http://windowsxp.mvps.org
>>
>>
>> "Ramesh, MS-MVP" <ramesh@online.mvps.org> wrote in message
>> news:%23gzvahpWFHA.712@TK2MSFTNGP14.phx.gbl...
>> > Rod,
>> >
>> > Have you tried setting it to "Browse in same window" ?
>> >
>> > --
>> > Ramesh, Microsoft MVP
>> > Windows XP Shell/User
>> > http://windowsxp.mvps.org
>> >
>> >
>> > "Rod V" <Rod V@discussions.microsoft.com> wrote in message
>> > news:134D27E1-2358-48E2-914E-064EFCE39BD7@microsoft.com...
>> >> Bank statements allegedly in CSV format downloaded correctly into
>> >> Excel
>> >> 97
>> >> SR-2 on a Windows 98 system but NOT when XP (home edition) is used
>> >> because
>> >> then the rows of data occupy only one column. Applying the alternative
>> >> fix
>> >> from Ramesh allows the file to be saved from the open spreadsheet in
>> >> .txt
>> >> format. When this file is reopened a series of options allow the file
>> >> to
>> >> be
>> >> viewed correctly ( ie columns as well as rows ). There must be a
>> >> better
>> >> way.
>> >>
>> >> "Ramesh, MS-MVP" wrote:
>> >>
>> >>> Dave,
>> >>>
>> >>> Here is another method: (But the changes are applied to CSV, XLS AND
>> >>> other
>> >>> file types handled by MS Excel)
>> >>>
>> >>> 1. Open My Computer.
>> >>> 2. On the Tools menu (or the View menu), click Folder Options (or
>> >>> click
>> >>> Options).
>> >>> 3. Click the File Types tab.
>> >>> 4. In the Registered file types list, click "Microsoft Excel
>> >>> Worksheet",
>> >>> and
>> >>> then click Advanced (or click Edit).
>> >>> 5. In the Edit File Type dialog box, uncheck "Browse in same window"
>> >>> check
>> >>> box
>> >>> 6. Click OK.
>> >>>
>> >>> How to configure Internet Explorer to open Office documents in the
>> >>> appropriate Office program instead of in Internet Explorer:
>> >>> http://support.microsoft.com/default.aspx?scid=162059
>> >>>
>> >>> --
>> >>> Ramesh, Microsoft MVP
>> >>> Windows XP Shell/User
>> >>> http://windowsxp.mvps.org
>> >>>
>> >>>
>> >>> "Ramesh, MS-MVP" <ramesh@online.mvps.org> wrote in message
>> >>> news:O$qpSQFDFHA.3908@TK2MSFTNGP15.phx.gbl...
>> >>> > Hi Dave,
>> >>> >
>> >>> > This problem can be resolved by modifying a couple of registry
>> >>> > values.
>> >>> >
>> >>> > 1. Create a System Restore point if you want to undo the following
>> >>> > operation
>> >>> > 2. Open Regedit and navigate to:
>> >>> >
>> >>> > [HKEY_CLASSES_ROOT\.CSV]
>> >>> >
>> >>> > 3. In the right-pane, double-click "Content Type" and delete it
>> >>> > 4. Navigate to:
>> >>> >
>> >>> > [HKEY_CLASSES_ROOT\Excel.CSV\CLSID]
>> >>> >
>> >>> > 5. Rename the key "CLSID" to "CLSID-"
>> >>> >
>> >>> >
>> >>> > NOTE: With missing Content Type value and missing Workbook CLSID,
>> >>> > Internet Explorer cannot execute the .CSV file, and you'll be
>> >>> > presented
>> >>> > with the Open/Save As prompt when you click your bank statement
>> >>> > (.CSV
>> >>> > file). Should you need to open a CSV file in Internet Explorer
>> >>> > (embedded
>> >>> > document) in future, reverse the above steps.
>> >>> >
>> >>> > Hope this helps, and keep us posted!
>> >>> >
>> >>> > --
>> >>> > Ramesh, Microsoft MVP
>> >>> > Windows XP Shell/User
>> >>> > http://windowsxp.mvps.org
>> >>> >
>> >>> >
>> >>> > "Dave L" <DaveL@discussions.microsoft.com> wrote in message
>> >>> > news:E94CA24D-5E1B-4F5D-8E04-A3262C029E72@microsoft.com...
>> >>> >> Thanks for the replies,
>> >>> >> When I try to download my statement I am given the 5 options via a
>> >>> >> dropdown
>> >>> >> menu of - Microsoft Money, Quicken 2001, Quicken 98, Sage Line 50
>> >>> >> (all
>> >>> >> OFX
>> >>> >> files) and Microsoft Excel (CSV file). On my Win2K machine I
>> >>> >> select
>> >>> >> CSV
>> >>> >> and
>> >>> >> am presented with a file download box. My option is where I would
>> >>> >> like to
>> >>> >> save it as a .csv file. On the XP machine I select CSV and Excel
>> >>> >> is
>> >>> >> opened in
>> >>> >> I.E. I do not appear to have any control over file associations.
>> >>> >> All
>> >>> >> I
>> >>> >> can
>> >>> >> then do is copy and paste the related data into a seperately
>> >>> >> opened
>> >>> >> excel
>> >>> >> workbook.
>> >>> >> I hope this explains things more clearly.
>> >>> >>
>> >>>
>> >>>
>> >
>>
>>


Re: CSV Downloads