Udma disabled in WinXP



Defiant
07-10-2005, 12:58 AM
Hello
I just installed a new Maxtor 160 Gb harddrive in my computer and windows
will not let me enable UDMA in system control panel it's stuck in PIO mode.
I have also uninstalled the drivers in device manager several times and
still it won't go into Udma mode.
I have done the registry update from Microsoft and the Harddrive shows at
boot to be running at max 133 Udma.
I Am running Windows XP Sp2, using a K7AMA Ecs motherboard. Bios is 8/12/02
kinda old but still works fine.
can't find a newer one.
can't find any Ide drivers for this board either.
my old harddrive ran Udma fine, it was a Maxtor 30 Gb udma running udma mode
66 and it shows up as running Udma mode,
I copied all my files over from my old harddrive using Maxblast 4. I have
also ran defrag and Chkdsk using the /f option no problems found.
Any help would be appreciated


--
Defiant


Defiant till the end

Andrew E.
07-10-2005, 12:58 AM
If it shows the speed at 133 youre at the max,whats youre problem.

"Defiant" wrote:

> Hello
> I just installed a new Maxtor 160 Gb harddrive in my computer and windows
> will not let me enable UDMA in system control panel it's stuck in PIO mode.
> I have also uninstalled the drivers in device manager several times and
> still it won't go into Udma mode.
> I have done the registry update from Microsoft and the Harddrive shows at
> boot to be running at max 133 Udma.
> I Am running Windows XP Sp2, using a K7AMA Ecs motherboard. Bios is 8/12/02
> kinda old but still works fine.
> can't find a newer one.
> can't find any Ide drivers for this board either.
> my old harddrive ran Udma fine, it was a Maxtor 30 Gb udma running udma mode
> 66 and it shows up as running Udma mode,
> I copied all my files over from my old harddrive using Maxblast 4. I have
> also ran defrag and Chkdsk using the /f option no problems found.
> Any help would be appreciated
>
>
> --
> Defiant
>
>
> Defiant till the end
>
>
>

Defiant
07-10-2005, 12:58 AM
sorry I guess I should clarify, I meant only in the bios screen at boot, in
windows its running in PIO mode
Defiant
"Andrew E." <eckrichco@msn.com> wrote in message
news:CB69787A-9767-485C-847A-9B1E8E24C36B@microsoft.com...
> If it shows the speed at 133 youre at the max,whats youre problem.
>
> "Defiant" wrote:
>
> > Hello
> > I just installed a new Maxtor 160 Gb harddrive in my computer and
windows
> > will not let me enable UDMA in system control panel it's stuck in PIO
mode.
> > I have also uninstalled the drivers in device manager several times and
> > still it won't go into Udma mode.
> > I have done the registry update from Microsoft and the Harddrive shows
at
> > boot to be running at max 133 Udma.
> > I Am running Windows XP Sp2, using a K7AMA Ecs motherboard. Bios is
8/12/02
> > kinda old but still works fine.
> > can't find a newer one.
> > can't find any Ide drivers for this board either.
> > my old harddrive ran Udma fine, it was a Maxtor 30 Gb udma running udma
mode
> > 66 and it shows up as running Udma mode,
> > I copied all my files over from my old harddrive using Maxblast 4. I
have
> > also ran defrag and Chkdsk using the /f option no problems found.
> > Any help would be appreciated
> >
> >
> > --
> > Defiant
> >
> >
> > Defiant till the end
> >
> >
> >

barry
07-10-2005, 12:58 AM
"Defiant" <defiant4879@juno.com> wrote in message
news:uFxahdTfFHA.576@TK2MSFTNGP15.phx.gbl...
> Hello
> I just installed a new Maxtor 160 Gb harddrive in my computer and windows
> will not let me enable UDMA in system control panel it's stuck in PIO
> mode.
> I have also uninstalled the drivers in device manager several times and
> still it won't go into Udma mode.
> I have done the registry update from Microsoft and the Harddrive shows at
> boot to be running at max 133 Udma.
> I Am running Windows XP Sp2, using a K7AMA Ecs motherboard. Bios is
> 8/12/02 kinda old but still works fine.
> can't find a newer one.
> can't find any Ide drivers for this board either.
> my old harddrive ran Udma fine, it was a Maxtor 30 Gb udma running udma
> mode 66 and it shows up as running Udma mode,
> I copied all my files over from my old harddrive using Maxblast 4. I have
> also ran defrag and Chkdsk using the /f option no problems found.
> Any help would be appreciated
>
>
> --
> Defiant
>
>
> Defiant till the end
>

go to:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\
Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

delete the keys:
* MasterIdDataChecksum
* SlaveIdDataChecksum
From the appropriate number (eg, 0001 from the above path) for the drive.
The "MatchingDeviceId" under the number key shows which channel it is, then
delete the master or slave entry.

If you cant figure out which number corresponds to which drive and dont know
if its master / slave, just delete those two entries from all of the
numbered keys, it wont cause any harm.

Then reboot the PC.

Wesley Vogel
07-10-2005, 12:58 AM
IDE ATA and ATAPI disks use PIO mode after multiple time-out or CRC errors
occur
http://support.microsoft.com/?kbid=817472

DMA Reverts to PIO
http://www.michna.com/kb/WxDMA.htm

--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

In news:uFxahdTfFHA.576@TK2MSFTNGP15.phx.gbl,
Defiant <defiant4879@juno.com> hunted and pecked:
> Hello
> I just installed a new Maxtor 160 Gb harddrive in my computer and windows
> will not let me enable UDMA in system control panel it's stuck in PIO
> mode. I have also uninstalled the drivers in device manager several times
> and still it won't go into Udma mode.
> I have done the registry update from Microsoft and the Harddrive shows at
> boot to be running at max 133 Udma.
> I Am running Windows XP Sp2, using a K7AMA Ecs motherboard. Bios is
> 8/12/02 kinda old but still works fine.
> can't find a newer one.
> can't find any Ide drivers for this board either.
> my old harddrive ran Udma fine, it was a Maxtor 30 Gb udma running udma
> mode 66 and it shows up as running Udma mode,
> I copied all my files over from my old harddrive using Maxblast 4. I have
> also ran defrag and Chkdsk using the /f option no problems found.
> Any help would be appreciated
>
>
> --
> Defiant
>
>
> Defiant till the end

holdem9ball@hotmail.com
07-10-2005, 12:58 AM
Well i posted the same kind of problem yesterday too. I'll try to
update the bios first and i'll let you know!

See you!

John

Defiant
07-10-2005, 12:58 AM
> go to:
> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\
> Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x
>
> delete the keys:
> * MasterIdDataChecksum
> * SlaveIdDataChecksum
> From the appropriate number (eg, 0001 from the above path) for the drive.
> The "MatchingDeviceId" under the number key shows which channel it is,
then
> delete the master or slave entry.
>
> If you cant figure out which number corresponds to which drive and dont
know
> if its master / slave, just delete those two entries from all of the
> numbered keys, it wont cause any harm.
>
> Then reboot the PC.


nope didn't work tried it just like you said and it's still in pio mode.
I just don't understand this, it will not go into Udma mode even if it is a
slave drive I put my old drive back in and made this drive a slave and still
no Udma.
Anything else I can try? this is frustrating.
thanks again, Defiant
>
>

Yves Leclerc
07-10-2005, 12:58 AM
The majority of the fixes for this type of problem are:

1) Use a 80 wire/40 pin UDMA 133 IDE cable

2) Istalled the enhance Ultra DMA IDE drivers, which are normally part of
the motherbaord chipset drivers. The motherbaord manufacturer (ECS) should
have sent a CD with the motherboard. You should be able to download the
driver from ECS's web site.

Also, if the motherboard uses one of the standard chipset, you could
try drivers from the chipset maker:
Intel www.intel.com -- Note: Intel has
"split" the IDE driver off the chipset drivers. Now known as Intel
Application Accelerator.
VIA www.viatech.com
nVidia www.nvidia.com



"Defiant" <defiant4879@juno.com> wrote in message
news:uFxahdTfFHA.576@TK2MSFTNGP15.phx.gbl...
> Hello
> I just installed a new Maxtor 160 Gb harddrive in my computer and windows
> will not let me enable UDMA in system control panel it's stuck in PIO
> mode.
> I have also uninstalled the drivers in device manager several times and
> still it won't go into Udma mode.
> I have done the registry update from Microsoft and the Harddrive shows at
> boot to be running at max 133 Udma.
> I Am running Windows XP Sp2, using a K7AMA Ecs motherboard. Bios is
> 8/12/02 kinda old but still works fine.
> can't find a newer one.
> can't find any Ide drivers for this board either.
> my old harddrive ran Udma fine, it was a Maxtor 30 Gb udma running udma
> mode 66 and it shows up as running Udma mode,
> I copied all my files over from my old harddrive using Maxblast 4. I have
> also ran defrag and Chkdsk using the /f option no problems found.
> Any help would be appreciated
>
>
> --
> Defiant
>
>
> Defiant till the end
>

Defiant
07-10-2005, 12:59 AM
no updated drivers from ECS for Win XP for this board, I installed the Hard
drive cable that came with the harddrive from Maxtor.
and the Chip set is Acer and again I found no updated drivers for this
chipset.
Defiant
"Yves Leclerc" <yleclercNOSPAM@maysys.com> wrote in message
news:eNekPpbfFHA.2484@TK2MSFTNGP15.phx.gbl...
> The majority of the fixes for this type of problem are:
>
> 1) Use a 80 wire/40 pin UDMA 133 IDE cable
>
> 2) Istalled the enhance Ultra DMA IDE drivers, which are normally part of
> the motherbaord chipset drivers. The motherbaord manufacturer (ECS)
should
> have sent a CD with the motherboard. You should be able to download the
> driver from ECS's web site.
>
> Also, if the motherboard uses one of the standard chipset, you
could
> try drivers from the chipset maker:
> Intel www.intel.com -- Note: Intel has
> "split" the IDE driver off the chipset drivers. Now known as Intel
> Application Accelerator.
> VIA www.viatech.com
> nVidia www.nvidia.com
>
>
>
> "Defiant" <defiant4879@juno.com> wrote in message
> news:uFxahdTfFHA.576@TK2MSFTNGP15.phx.gbl...
> > Hello
> > I just installed a new Maxtor 160 Gb harddrive in my computer and
windows
> > will not let me enable UDMA in system control panel it's stuck in PIO
> > mode.
> > I have also uninstalled the drivers in device manager several times and
> > still it won't go into Udma mode.
> > I have done the registry update from Microsoft and the Harddrive shows
at
> > boot to be running at max 133 Udma.
> > I Am running Windows XP Sp2, using a K7AMA Ecs motherboard. Bios is
> > 8/12/02 kinda old but still works fine.
> > can't find a newer one.
> > can't find any Ide drivers for this board either.
> > my old harddrive ran Udma fine, it was a Maxtor 30 Gb udma running udma
> > mode 66 and it shows up as running Udma mode,
> > I copied all my files over from my old harddrive using Maxblast 4. I
have
> > also ran defrag and Chkdsk using the /f option no problems found.
> > Any help would be appreciated
> >
> >
> > --
> > Defiant
> >
> >
> > Defiant till the end
> >
>
>

Damo
07-10-2005, 12:59 AM
Looks pretty hopeless...here are some things I've learnt over the years to
try on the problem. I went onto the ECS website and I was disappointed to
find a lack of drivers for their older boards.

Try downloading the new VIA drivers from this URL (I think it may not be
your exact board, it has an extra 3 behind it but that might be a revision,
the VIA driver should be the same):
http://www.ecs.com.tw/ECSWeb/Downloads/ProductsDetail_Download.aspx?DetailID=424&DetailName=Driver&DetailDesc=K7AMA3(3.1)&MenuID=35&LanID=0

Reboot your system. If there is still a problem, unplug your computer, pull
off your case cover and unplug/replug the IDE cable a few times at the drive
and board ends. That is a trick a friend gave me when I had severe drive
detection problems with a WD drive at BIOS level. It fixed the problem.

Absolute last resort, flash the BIOS.

Damo
"Defiant" wrote:

> Hello
> I just installed a new Maxtor 160 Gb harddrive in my computer and windows
> will not let me enable UDMA in system control panel it's stuck in PIO mode.
> I have also uninstalled the drivers in device manager several times and
> still it won't go into Udma mode.
> I have done the registry update from Microsoft and the Harddrive shows at
> boot to be running at max 133 Udma.
> I Am running Windows XP Sp2, using a K7AMA Ecs motherboard. Bios is 8/12/02
> kinda old but still works fine.
> can't find a newer one.
> can't find any Ide drivers for this board either.
> my old harddrive ran Udma fine, it was a Maxtor 30 Gb udma running udma mode
> 66 and it shows up as running Udma mode,
> I copied all my files over from my old harddrive using Maxblast 4. I have
> also ran defrag and Chkdsk using the /f option no problems found.
> Any help would be appreciated
>
>
> --
> Defiant
>
>
> Defiant till the end
>
>
>


Udma disabled in WinXP