Hard disk PIO instead of DMA, why?



holdem9ball@hotmail.com
07-10-2005, 12:58 AM
In device manager under IDE ATA/ATAPI controllers ->
Primary Controller for Device 0 under advanced settings
the transfer mode is set to: DMA if avaliable, the
Current Mode is: PIO Mode. I have other devices that are
in Ultra DMA Mode 2 on my computer. The hard drive is a
WD8000JB which is on its own ide cable connected
to the primary connector on the motehrboard. I am using
windows XP Professional and the PCChips Motherboard
that can support max of DMA 66 I think.

Also, when i start up my computer and it detects the
devices for the hard drive it says its in Ultra DMA Mode 4
or 5 I don't remember, but in windows it isnt.

Thank You for your time and help.

John

Carey Frisch [MVP]
07-10-2005, 12:58 AM
IDE ATA and ATAPI disks use PIO mode after multiple time-out or CRC errors occur
http://support.microsoft.com/default.aspx?scid=kb;en-us;817472

--
Carey Frisch
Microsoft MVP
Windows XP - Shell/User
Microsoft Newsgroups

Get Windows XP Service Pack 2 with Advanced Security Technologies:
http://www.microsoft.com/athome/security/protect/windowsxp/choose.mspx

-------------------------------------------------------------------------------------------

"John" wrote:

| In device manager under IDE ATA/ATAPI controllers ->
| Primary Controller for Device 0 under advanced settings
| the transfer mode is set to: DMA if avaliable, the
| Current Mode is: PIO Mode. I have other devices that are
| in Ultra DMA Mode 2 on my computer. The hard drive is a
| WD8000JB which is on its own ide cable connected
| to the primary connector on the motehrboard. I am using
| windows XP Professional and the PCChips Motherboard
| that can support max of DMA 66 I think.
|
| Also, when i start up my computer and it detects the
| devices for the hard drive it says its in Ultra DMA Mode 4
| or 5 I don't remember, but in windows it isnt.
|
| Thank You for your time and help.
|
| John


Hard disk PIO instead of DMA, why?