Reassign COM ports in XP



matt
07-10-2005, 01:56 AM
I have a Bluetooth adaptor that i have connected to my USB port. It is
using very high com ports like COM16 through COM18. I'm trying to use
software that can't read above COM16. Is there a way to use the unassigned
COM ports below 16? I've tried moving the Bluetooth device to other USB
ports but it keeps using higher and higher com ports, its up to COM22. I
tried booting into Safe mode and checking out the devices and hidden
devices, but nothing is using the lower com ports except a serial port on
COM1 and a modem on COM4. I'm running Windows XP SP2.

Does anyone know how to reassign these COM ports?

Thanks!
-matt

Darrell Gorter[MSFT]
07-10-2005, 01:56 AM
Hello Matt,
open Device Manager
GoTo Ports
Select Bluetooth Serial Port and right-click on it.
Choose Properties
Port Settings tab
Then the Advanced button
You should be able to change the com port number from this dialog page
Thanks,
Darrell Gorter[MSFT]

This posting is provided "AS IS" with no warranties, and confers no rights
--------------------
<From: "matt" <guest@guest.com>
<Newsgroups: microsoft.public.windowsxp.hardware
<Subject: Reassign COM ports in XP
<Lines: 15
<X-Priority: 3
<X-MSMail-Priority: Normal
<X-Newsreader: Microsoft Outlook Express 6.00.2900.2527
<X-RFC2646: Format=Flowed; Original
<X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2527
<Message-ID: <qaote.136291$sy6.126298@lakeread04>
<Date: Sun, 19 Jun 2005 20:34:23 -0400
<NNTP-Posting-Host: 68.100.152.84
<X-Complaints-To: abuse@cox.net
<X-Trace: lakeread04 1119227670 68.100.152.84 (Sun, 19 Jun 2005 20:34:30
EDT)
<NNTP-Posting-Date: Sun, 19 Jun 2005 20:34:30 EDT
<Organization: Cox Communications
<Path:
TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.sul.t-online.de!t-onli
ne.de!news.glorb.com!cox.net!news-xfer.cox.net!p01!lakeread04.POSTED!53ab275
0!not-for-mail
<Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.windowsxp.hardware:57639
<X-Tomcat-NG: microsoft.public.windowsxp.hardware
<
<I have a Bluetooth adaptor that i have connected to my USB port. It is
<using very high com ports like COM16 through COM18. I'm trying to use
<software that can't read above COM16. Is there a way to use the unassigned
<COM ports below 16? I've tried moving the Bluetooth device to other USB
<ports but it keeps using higher and higher com ports, its up to COM22. I
<tried booting into Safe mode and checking out the devices and hidden
<devices, but nothing is using the lower com ports except a serial port on
<COM1 and a modem on COM4. I'm running Windows XP SP2.
<
<Does anyone know how to reassign these COM ports?
<
<Thanks!
<-matt
<
<
<

matt
07-10-2005, 01:56 AM
""Darrell Gorter[MSFT]"" <Darrellg@online.microsoft.com> wrote in message
news:aP8ddrgdFHA.2656@TK2MSFTNGXA01.phx.gbl...
> Hello Matt,
> open Device Manager
> GoTo Ports
> Select Bluetooth Serial Port and right-click on it.
> Choose Properties
> Port Settings tab
> Then the Advanced button
> You should be able to change the com port number from this dialog page
> Thanks,
> Darrell Gorter[MSFT]

Hi, thanks for your reply. I'm not sure where you see this, but my settings
don't have a place to change the com port.

Anyway, i found a solution. Turns out these ports were in use and i had to
follow these instructions to reveal them and uninstall them:
http://support.microsoft.com/default.aspx?scid=kb;en-us;315539

thanks, though.

Si Ballenger
07-10-2005, 01:57 AM
On Tue, 21 Jun 2005 07:08:20 -0400, "matt" <guest@guest.com>
wrote:

>
>""Darrell Gorter[MSFT]"" <Darrellg@online.microsoft.com> wrote in message
>news:aP8ddrgdFHA.2656@TK2MSFTNGXA01.phx.gbl...
>> Hello Matt,
>> open Device Manager
>> GoTo Ports
>> Select Bluetooth Serial Port and right-click on it.
>> Choose Properties
>> Port Settings tab
>> Then the Advanced button
>> You should be able to change the com port number from this dialog page
>> Thanks,
>> Darrell Gorter[MSFT]
>
>Hi, thanks for your reply. I'm not sure where you see this, but my settings
>don't have a place to change the com port.
>
>Anyway, i found a solution. Turns out these ports were in use and i had to
>follow these instructions to reveal them and uninstall them:
>http://support.microsoft.com/default.aspx?scid=kb;en-us;315539

It is a bluetooth/USB bug in XP. In the advanced section you can
just reassign the port number and ignore the windows warning.
Check the link below.

http://www.modemsite.com/56k/xptip.asp


Reassign COM ports in XP