Cannot install XP on an XP partition??



damoskeet-goog@yahoo.com
07-10-2005, 01:54 AM
Hi all,

I'm working my way through a maze of problems to try and get my Media
Centre back up and running.

Basically, my ATI Radeon drivers seemed to get confused/corrupted after
plugging in a second display, and now the drivers crash each time
Windows start up. In order to check whether it's a hardware problem or
a deep driver problem (uninstalling/reinstalling the drivers didn't
work, and System Restore failed), I've decided to try reinstalling
Windows. I've Ghosted the partition as it is, and am now trying to
reinstall Windows XP over the existing install. The idea is that if it
also doesn't work on a vanilla XP build, it it's time to RMA the card.

So - I've booted off the XP (actually MCE 2005) install CD-ROM, hit f6
and loaded my Promise SATA WinXP drivers when prompted. It's now come
to the partition selection screen, and I can see my IDE (2 partitions)
and SATA (3 partitions) drives on there. My old XP was on SATA,
Partition 1

However - when I choose it, it always reports to me "However, this disk
does not contain a Windows XP-compatible partition". This despite there
being XP installed on it at the moment! The XP OS partition is a
Primary Partition (the rest being a single Extended split into two
logical parts); it's active, and formatted as NTFS. It should install
on here, no?

I've tried deleting and re-creating the partition; nothing. I've tried
using FIXBOOT and BOOTCFG on it, just for the hell of it. I'm not going
to touch FIXMBR, since it reports the drive as nonstandard (probably
due to the SATA controller), and I have 100Gb of data on the other
partitions. Unfortunately I don't have space to move that elsewhere, so
that I could wipe the entire drive.

Can anyone recommend what I can do to be able to reinstall Windows on
this machine? I don't think I'm doing anything other than when I first
installed it, and it's not giving me any other options to try here...

Thanks!


Damian

damoskeet-goog@yahoo.com
07-10-2005, 01:54 AM
I just managed to fix this:

I tried using Recovery Console to format the partition using NTFS, but
it still didn't seem to work. However, at the same time, I unplugged my
IDE drive, which I use for secondary storage. I think someone
recommended this as a solution to a problem with the LBA size.

What I got then, during the bootup sequence, was "Couldn't find NTLDR".
I assume that what it's done is installed the MBR on the IDE drive
rather than the SATA drive; hence it couldn't find or create the MBR on
the SATA drive when trying to install windows (although it wasn't
reporting it as such).

What is strange, is that the CD drive was ahead of the HDD in the
bootup sequence, so it should have loaded Windows installation without
checking the HDD at all.

Anyway - with the IDE drive unplugged, Windows installed successfully.
I'm just waiting to plug it in now, and see what happens.


[d]

Yves Leclerc
07-10-2005, 01:54 AM
CD ROM boots prompts you to see if you want to boot from CD. If you do not
answer the prompt, it will attempt to boot from the next boot devices.

<damoskeet-goog@yahoo.com> wrote in message
news:1118216809.302267.214160@z14g2000cwz.googlegroups.com...
>I just managed to fix this:
>
> I tried using Recovery Console to format the partition using NTFS, but
> it still didn't seem to work. However, at the same time, I unplugged my
> IDE drive, which I use for secondary storage. I think someone
> recommended this as a solution to a problem with the LBA size.
>
> What I got then, during the bootup sequence, was "Couldn't find NTLDR".
> I assume that what it's done is installed the MBR on the IDE drive
> rather than the SATA drive; hence it couldn't find or create the MBR on
> the SATA drive when trying to install windows (although it wasn't
> reporting it as such).
>
> What is strange, is that the CD drive was ahead of the HDD in the
> bootup sequence, so it should have loaded Windows installation without
> checking the HDD at all.
>
> Anyway - with the IDE drive unplugged, Windows installed successfully.
> I'm just waiting to plug it in now, and see what happens.
>
>
> [d]
>


Cannot install XP on an XP partition??