Icon to file type registration



Russell
07-09-2005, 10:11 PM
Hi all, I recently installed a music tab editor, which works very well, but,
I cannot seem to make the file associated icon stick.
The icon does show in the usage area of "folder ooptions> etc, but when I
check My Doc directory for the file type the icon is not being used. Is it
because it is not registered in the icon library, if so, how do I accomplish
that?

Many thanks in anticipation

--
Russell C, retired

Rob Fowler [MSFT]
07-09-2005, 10:11 PM
"Russell" wrote:

> Hi all, I recently installed a music tab editor, which works very well, but,
> I cannot seem to make the file associated icon stick.
> The icon does show in the usage area of "folder ooptions> etc, but when I
> check My Doc directory for the file type the icon is not being used. Is it
> because it is not registered in the icon library, if so, how do I accomplish
> that?

Hi Russell:

It sounds like you've already confirmed that the desired icon is associated
with the file type in Tools > Folder Options... > File Types. If that's the
case, and you're still seeing the wrong icon (I'm assuming your seeing the
default icon used for unassociated file types), you may want to walk through
some of the troubleshooting tips in this Knowledge Base article:

http://support.microsoft.com/default.aspx?scid=kb;en-us;132668

I hope this helps.

Regards,
Rob

Russell
07-09-2005, 10:11 PM
Hi Rob, thanks for that tip, but I could not accomplish the addition of this
from the article 132668:
... add the Max Cached Icons string value with a value data of 2000 to the
following registry key, and then restart your computer:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer
If the icons are still incorrect, delete the ShellIconCache file. The Max
Cached Icons value data range is between 100 and 4096. The default value is
500.

Only because I do not know how to actually add something in the registry, I
have only been able to change or delete registry items before:) So maybe I
will just live with peculiarity rather than risk screwing up my recently
rebuilt machine again :)

Thanks again
--
Russell C, retired


> Hi Russell:
>
> It sounds like you've already confirmed that the desired icon is associated
> with the file type in Tools > Folder Options... > File Types. If that's the
> case, and you're still seeing the wrong icon (I'm assuming your seeing the
> default icon used for unassociated file types), you may want to walk through
> some of the troubleshooting tips in this Knowledge Base article:
>
> http://support.microsoft.com/default.aspx?scid=kb;en-us;132668
>
> I hope this helps.
>
> Regards,
> Rob
>


Icon to file type registration