Help! HP Photosmart 2610 - Print Queue/Event ID 6161 problem



KennyE
07-09-2005, 10:30 PM
I have an issue with the printer I recently purchased, a HP Photosmart 2610,
which is connected to my workgroup network by Ethernet through a
router/switch. I use Windows XP Pro.



PROBLEM ONE



The first problem was that when I printed something (from any PC on the
network), the print job would remain in the queue for about 5 minutes before
disappearing and letting the next job print.



To fix this, we went into the printer drivers themselves and noticed it was
only using one port (9110 if I remember correctly) and was using RAW mode,
not LPR. We tried to add another port but it kept automagically selecting
9110. So then we tried changing to LPR. This stopped the printer working
completely, so we changed back to RAW. Magic - It was fixed! Except for
the new problem it created (see problem two)



PROBLEM TWO



With print jobs disappearing as soon as they had been printed, I confidently
thought I had resolved problem one. That is, until I logged on as a limited
user. I could not print at all. In checking the system, each of these
non-prints generated an Event ID 6161.



In doing some research into Event ID 6161, I found a comment from a
Microsoft guy on a forum somewhere (through Google), saying that you should
check to see if the "C:\WINDOWS\system32\spool\PRINTERS" directory could be
access by limitied users. I checked this, adjusted permissions accordingly,
checked that the limited users could access it, but no luck. Still no
printing



CURRENT SITUATION



The end result is that currently one of my computers on my workgroup can
only print if the user is logged on as an administrator, and the rest of my
computers put print jobs in the queue that remain there for five minutes.



I would be grateful if any learned folks out there could provide me with a
possible solution to both problems. That is, so I can print from any type
of user account and the print jobs disappear immediately after they have
printed.



Regards



Ken

Cari \(MS-MVP\)
07-09-2005, 10:30 PM
Does the router have DHCP enabled and is it correctly assigning an IP
address to the printer?

Does the behavior change if you disable the firewall software?
--
Cari (MS-MVP)
Printing & Imaging



"KennyE" <NotTelling@You> wrote in message
news:42ab69db$1@dnews.tpgi.com.au...
>I have an issue with the printer I recently purchased, a HP Photosmart
>2610, which is connected to my workgroup network by Ethernet through a
>router/switch. I use Windows XP Pro.
>
>
>
> PROBLEM ONE
>
>
>
> The first problem was that when I printed something (from any PC on the
> network), the print job would remain in the queue for about 5 minutes
> before disappearing and letting the next job print.
>
>
>
> To fix this, we went into the printer drivers themselves and noticed it
> was only using one port (9110 if I remember correctly) and was using RAW
> mode, not LPR. We tried to add another port but it kept automagically
> selecting 9110. So then we tried changing to LPR. This stopped the
> printer working completely, so we changed back to RAW. Magic - It was
> fixed! Except for the new problem it created (see problem two)
>
>
>
> PROBLEM TWO
>
>
>
> With print jobs disappearing as soon as they had been printed, I
> confidently thought I had resolved problem one. That is, until I logged
> on as a limited user. I could not print at all. In checking the system,
> each of these non-prints generated an Event ID 6161.
>
>
>
> In doing some research into Event ID 6161, I found a comment from a
> Microsoft guy on a forum somewhere (through Google), saying that you
> should check to see if the "C:\WINDOWS\system32\spool\PRINTERS" directory
> could be access by limitied users. I checked this, adjusted permissions
> accordingly, checked that the limited users could access it, but no luck.
> Still no printing
>
>
>
> CURRENT SITUATION
>
>
>
> The end result is that currently one of my computers on my workgroup can
> only print if the user is logged on as an administrator, and the rest of
> my computers put print jobs in the queue that remain there for five
> minutes.
>
>
>
> I would be grateful if any learned folks out there could provide me with a
> possible solution to both problems. That is, so I can print from any type
> of user account and the print jobs disappear immediately after they have
> printed.
>
>
>
> Regards
>
>
>
> Ken
>
>
>

KennyE
07-09-2005, 10:30 PM
Thanks Cari,

But no luck. The router has DHCP enabled and that works fine. This is also
proven by the fact that it depends on the type of user logged on to a
particular machine affecting whether something will print or not.

I tried disabling the firewall and no change.

Regards

Ken



"Cari (MS-MVP)" <Newsgroups1@coribright.com> wrote in message
news:%23izJinwbFHA.3932@TK2MSFTNGP12.phx.gbl...
> Does the router have DHCP enabled and is it correctly assigning an IP
> address to the printer?
>
> Does the behavior change if you disable the firewall software?
> --
> Cari (MS-MVP)
> Printing & Imaging
>
>
>
> "KennyE" <NotTelling@You> wrote in message
> news:42ab69db$1@dnews.tpgi.com.au...
>>I have an issue with the printer I recently purchased, a HP Photosmart
>>2610, which is connected to my workgroup network by Ethernet through a
>>router/switch. I use Windows XP Pro.
>>
>>
>>
>> PROBLEM ONE
>>
>>
>>
>> The first problem was that when I printed something (from any PC on the
>> network), the print job would remain in the queue for about 5 minutes
>> before disappearing and letting the next job print.
>>
>>
>>
>> To fix this, we went into the printer drivers themselves and noticed it
>> was only using one port (9110 if I remember correctly) and was using RAW
>> mode, not LPR. We tried to add another port but it kept automagically
>> selecting 9110. So then we tried changing to LPR. This stopped the
>> printer working completely, so we changed back to RAW. Magic - It was
>> fixed! Except for the new problem it created (see problem two)
>>
>>
>>
>> PROBLEM TWO
>>
>>
>>
>> With print jobs disappearing as soon as they had been printed, I
>> confidently thought I had resolved problem one. That is, until I logged
>> on as a limited user. I could not print at all. In checking the system,
>> each of these non-prints generated an Event ID 6161.
>>
>>
>>
>> In doing some research into Event ID 6161, I found a comment from a
>> Microsoft guy on a forum somewhere (through Google), saying that you
>> should check to see if the "C:\WINDOWS\system32\spool\PRINTERS" directory
>> could be access by limitied users. I checked this, adjusted permissions
>> accordingly, checked that the limited users could access it, but no luck.
>> Still no printing
>>
>>
>>
>> CURRENT SITUATION
>>
>>
>>
>> The end result is that currently one of my computers on my workgroup can
>> only print if the user is logged on as an administrator, and the rest of
>> my computers put print jobs in the queue that remain there for five
>> minutes.
>>
>>
>>
>> I would be grateful if any learned folks out there could provide me with
>> a possible solution to both problems. That is, so I can print from any
>> type of user account and the print jobs disappear immediately after they
>> have printed.
>>
>>
>>
>> Regards
>>
>>
>>
>> Ken
>>
>>
>>
>
>
>


Help! HP Photosmart 2610 - Print Queue/Event ID 6161 problem