Boot.ini question



KoS
07-09-2005, 11:53 PM
I had Linux and XP on my computer. My XP install was on disk(0) and Linux
was on a second physical drive disk(1). I think this is correct. I had the
GRUB boot loader to have option of selecting the XP or Linux OS. I deleted
the linux drive and formatted it to windows. When I turned my computer on it
does bios check and then it attempts to run GRUB but it is no longer there.
I have installed XP again on the second physical drive and now I get an
option to select an OS and I can get back to my first XP install. What can I
do to fix my boot.ini so that it will just start the first XP and then can
get rid of this second one? Hope this makes sense.

Pegasus \(MVP\)
07-09-2005, 11:53 PM
"KoS" <KoS @discussions.microsoft.com> wrote in message
news:570FBB75-4A32-4ADC-890D-527166AA592F@microsoft.com...
> I had Linux and XP on my computer. My XP install was on disk(0) and Linux
> was on a second physical drive disk(1). I think this is correct. I had
the
> GRUB boot loader to have option of selecting the XP or Linux OS. I
deleted
> the linux drive and formatted it to windows. When I turned my computer on
it
> does bios check and then it attempts to run GRUB but it is no longer
there.
> I have installed XP again on the second physical drive and now I get an
> option to select an OS and I can get back to my first XP install. What
can I
> do to fix my boot.ini so that it will just start the first XP and then can
> get rid of this second one? Hope this makes sense.

It's probably not boot.ini that's wrong but your Master Boot
Record (MBR) - it still contains the GRUB loader. Here are
a couple of ways to replace it with the standard Windows MBR:

- Boot the machine with a Win98 boot disk (www.bootdisk.com),
then type this command: fdisk /mbr
- Boot the machine with a WinXP CD, get into the Recovery
Console, then type this command: fixmbr

Stephen
07-09-2005, 11:53 PM
KoS wrote:
>> I had Linux and XP on my computer. My XP install was on disk(0) and
>> Linux was on a second physical drive disk(1). I think this is
>> correct. I had the GRUB boot loader to have option of selecting the
>> XP or Linux OS. I deleted the linux drive and formatted it to
>> windows. When I turned my computer on it does bios check and then
>> it attempts to run GRUB but it is no longer there. I have installed
>> XP again on the second physical drive and now I get an option to
>> select an OS and I can get back to my first XP install. What can I
>> do to fix my boot.ini so that it will just start the first XP and
>> then can get rid of this second one? Hope this makes sense.

[unofficial] GRUB messes things up - get rid of that atrocious and
contemptible piece of junk.

[advanced] If you want to make sure it is completely and utterly gone get a
zero-fill utility like the one Maxtor offers and zero-fill the drive.Zeroing
out the drive will make sure the repulsive thing is completely gone without
a trace left of its infection.

Doug Knox MS-MVP
07-09-2005, 11:54 PM
Right click My Computer, Properties, Advanced, Startup and Recovery. You'll find the ability to set your default OS and the timeout there. You can also edit your BOOT.INI file from that tab.

--
Doug Knox, MS-MVP Windows Media Center\Windows Powered Smart Display\Security
Win 95/98/Me/XP Tweaks and Fixes
http://www.dougknox.com
--------------------------------
Per user Group Policy Restrictions for XP Home and XP Pro
http://www.dougknox.com/xp/utils/xp_securityconsole.htm
--------------------------------
Please reply only to the newsgroup so all may benefit.
Unsolicited e-mail is not answered.

"KoS" <KoS @discussions.microsoft.com> wrote in message news:570FBB75-4A32-4ADC-890D-527166AA592F@microsoft.com...
>I had Linux and XP on my computer. My XP install was on disk(0) and Linux
> was on a second physical drive disk(1). I think this is correct. I had the
> GRUB boot loader to have option of selecting the XP or Linux OS. I deleted
> the linux drive and formatted it to windows. When I turned my computer on it
> does bios check and then it attempts to run GRUB but it is no longer there.
> I have installed XP again on the second physical drive and now I get an
> option to select an OS and I can get back to my first XP install. What can I
> do to fix my boot.ini so that it will just start the first XP and then can
> get rid of this second one? Hope this makes sense.


Boot.ini question