system tray



Starman
07-09-2005, 11:52 PM
how do you prevent certain programs from loading up at start-up so their
icons don't also appear in the system tray?

Rob graham
07-09-2005, 11:52 PM
"Starman" <iknowbutidontknow@yahoo.com> wrote in message
news:buUme.7923$BR4.7671@news-server.bigpond.net.au...
> how do you prevent certain programs from loading up at start-up so their
> icons don't also appear in the system tray?
>
>
>
This is a common question. Start/Run/type msconfig OK/General tab, check
selective startup and all boxes under it. /Startup tab, uncheck what you
don't want at startup.

Rob Graham

Detlev Dreyer
07-09-2005, 11:52 PM
"Starman" <iknowbutidontknow@yahoo.com> wrote:

> how do you prevent certain programs from loading up at start-up so
> their icons don't also appear in the system tray?

The first approach is to right click or doubleclick these icons in
order to disable to automatic startup in the program options. Use
MSCONFIG as the last resort only when there are no such program options.
Note that some icons (eg. speaker symbol) can be disabled via control
panel only.

--
d-d

TaurArian
07-09-2005, 11:52 PM
Another way to do this would be to go to the program that is in your system
tray/notification area and you may find the settings to remove them from the auto
start, most programs have this listed in the properties section.

Starman wrote:
> how do you prevent certain programs from loading up at start-up so
> their icons don't also appear in the system tray?

Ken Blake
07-09-2005, 11:53 PM
In news:buUme.7923$BR4.7671@news-server.bigpond.net.au,
Starman <iknowbutidontknow@yahoo.com> typed:

> how do you prevent certain programs from loading up at start-up
> so
> their icons don't also appear in the system tray?


On each program you don't want to start automatically, check its
Options to see if it has the choice not to start. Many can easily
and best be stopped that way. If that doesn't work, run MSCONFIG
from the Start | Run line, and on the Startup tab, uncheck the
programs you don't want to start automatically.

However, if I were you, I wouldn't do this just for the purpose
of running the minimum number of programs. Despite what many
people tell you, you should be concerned, not with how *many* of
these programs you run, but *which*. Some of them can hurt
performance severely, but others have no effect on performance.

Don't just stop programs from running willy-nilly. What you
should do is determine what each program is, what its value is to
you, and what the cost in performance is of its running all the
time. You can get more information about these with at
http://castlecops.com/StartupList.html. If you can't find it
there, try google searches and ask about specifics here.

Once you have that information, you can make an intelligent
informed decision about what you want to keep and what you want
to get rid of.


--
Ken Blake - Microsoft MVP Windows: Shell/User
Please reply to the newsgroup

Bruce Chambers
07-09-2005, 11:55 PM
Starman wrote:
> how do you prevent certain programs from loading up at start-up so their
> icons don't also appear in the system tray?
>
>
>


In most cases, with "well-mannered" applications, it's usually as
simple as opening the undesired program and deselecting the option to
"display icon in the system tray" or to "start when Windows starts."

Additionally, Look in the C:\Documents and Settings\All
Users\Start Menu\Programs\Start Up and C:\Documents and
Settings\username\Start Menu\Programs\Start Up folders, and in the
system registry, primarily in the
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run and
HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Run keys.

How to Troubleshoot By Using the Msconfig Utility in Windows XP
http://support.microsoft.com/default.aspx?scid=kb;EN-US;310560


--

Bruce Chambers

Help us help you:
http://dts-l.org/goodpost.htm
http://www.catb.org/~esr/faqs/smart-questions.html

You can have peace. Or you can have freedom. Don't ever count on having
both at once. - RAH

Rock
07-09-2005, 11:55 PM
Starman wrote:

> how do you prevent certain programs from loading up at start-up so their
> icons don't also appear in the system tray?
>
>
>

First step should be to check in the options for the program you don't
want to start and see if there is a setting to tell it not to run at
startup. The next step is to remove any entries you don't want from the
two startup folders:

C:\Documents and Settings\<username>\Start Menu\Programs\Startup
C:\Documents and Settings\All Users\Start Menu\Programs\Startup

For anything else uncheck their entries in the startup tab of msconfig:
Start | Run | Msconfig | Ok


Another option is to remove the reference to them from one of these keys
in the registry:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce

Make sure you have a backup of the registry using a program like ERUNT,
http://home.t-online.de/home/lars.hederer/erunt/ before making any
changes to the registry.

--
Rock
MS MVP Windows - Shell/User


system tray