Many .htm files display MS-Word icon



Stan Brown
07-10-2005, 12:49 AM
Windows XP Pro SP2, MS Office 2003
Default Web browser is Mozilla, not MSIE

In a folder with a lot of .HTM files, a few of them show the Mozilla
icon but most show the MS-Word icon. "Folder Options" -> "File
Types" shows that Mozilla is associated with .HTM and .HTML files,
and when I double-click on one it does correctly open in Mozilla.

How can I correct the icon display, and does anyone have a clue what
caused the problem? In "File Types" I clicked "Advanced" and
re-selected the proper icon file, but even when I terminated and
re-started the Explorer process it still showed the wrong icons for
the majority of .HTM files.

--
Stan Brown, Oak Road Systems, Tompkins County, New York, USA
http://OakRoadSystems.com/
"I feel a wave of morning sickness coming on, and I want to
be standing on your mother's grave when it hits."

Stan Brown
07-10-2005, 12:49 AM
On Sat, 28 May 2005 19:05:43 -0400, I wrote:

>Windows XP Pro SP2, MS Office 2003
>Default Web browser is Mozilla, not MSIE
>
>In a folder with a lot of .HTM files, a few of them show the Mozilla
>icon but most show the MS-Word icon. "Folder Options" -> "File
>Types" shows that Mozilla is associated with .HTM and .HTML files,
>and when I double-click on one it does correctly open in Mozilla.
>
>How can I correct the icon display, and does anyone have a clue what
>caused the problem? In "File Types" I clicked "Advanced" and
>re-selected the proper icon file, but even when I terminated and
>re-started the Explorer process it still showed the wrong icons for
>the majority of .HTM files.

I also tried changing display resolution to force a refresh of
ICONCACHE.DB, then manually deleting ICONCACHE.DB (all copies) and
rebooting. It made no difference.

--
Stan Brown, Oak Road Systems, Tompkins County, New York, USA
http://OakRoadSystems.com/
"I feel a wave of morning sickness coming on, and I want to
be standing on your mother's grave when it hits."

kurttrail
07-10-2005, 12:49 AM
Stan Brown wrote:
> On Sat, 28 May 2005 19:05:43 -0400, I wrote:
>
>> Windows XP Pro SP2, MS Office 2003
>> Default Web browser is Mozilla, not MSIE
>>
>> In a folder with a lot of .HTM files, a few of them show the Mozilla
>> icon but most show the MS-Word icon. "Folder Options" -> "File
>> Types" shows that Mozilla is associated with .HTM and .HTML files,
>> and when I double-click on one it does correctly open in Mozilla.
>>
>> How can I correct the icon display, and does anyone have a clue what
>> caused the problem? In "File Types" I clicked "Advanced" and
>> re-selected the proper icon file, but even when I terminated and
>> re-started the Explorer process it still showed the wrong icons for
>> the majority of .HTM files.
>
> I also tried changing display resolution to force a refresh of
> ICONCACHE.DB, then manually deleting ICONCACHE.DB (all copies) and
> rebooting. It made no difference.

Sounds like the files were generated with Word.

Open up one of the files in Notepad. Does it look like below?

<html xmlns:v="urn:schemas-microsoft-com:vml"
xmlns:o="urn:schemas-microsoft-com:office:office"
xmlns:w="urn:schemas-microsoft-com:office:word"
xmlns="http://www.w3.org/TR/REC-html40">

<head>
<meta http-equiv=Content-Type content="text/html; charset=windows-1252">
<meta name=ProgId content=Word.Document>
<meta name=Generator content="Microsoft Word 11">
<meta name=Originator content="Microsoft Word 11">
<link rel=File-List
href="{TITLE}_files/filelist.xml">
<title>{TITLE}</title>

If so, then edit it to look something like this:

<html>

<head>
<meta http-equiv=Content-Type content="text/html; charset=windows-1252">
<title>TITLE</title>

Then if you have this stuff below that you can just delete:

<!--[if gte mso 9]><xml>
<o:DocumentProperties>
<o:Author></o:Author>
<o:LastAuthor></o:LastAuthor>
<o:Revision></o:Revision>
<o:TotalTime></o:TotalTime>
<o:Created></o:Created>
<o:LastSaved></o:LastSaved>
<o:Pages></o:Pages>
<o:Words></o:Words>
<o:Characters></o:Characters>
<o:Company></o:Company>
<o:Lines></o:Lines>
<o:Paragraphs></o:Paragraphs>
<o:CharactersWithSpaces></o:CharactersWithSpaces>
<o:Version></o:Version>
</o:DocumentProperties>
</xml><![endif]--><!--[if gte mso 9]><xml>
<w:WordDocument>
<w:DontDisplayPageBoundaries/>
<w:SpellingState></w:SpellingState>
<w:GrammarState></w:GrammarState>
<w:PunctuationKerning/>
<w:ValidateAgainstSchemas/>
<w:SaveIfXMLInvalid></w:SaveIfXMLInvalid>
<w:IgnoreMixedContent></w:IgnoreMixedContent>
<w:AlwaysShowPlaceholderText></w:AlwaysShowPlaceholderText>
<w:Compatibility>
<w:BreakWrappedTables/>
<w:SnapToGridInCell/>
<w:WrapTextWithPunct/>
<w:UseAsianBreakRules/>
<w:DontGrowAutofit/>
</w:Compatibility>
<w:BrowserLevel></w:BrowserLevel>
</w:WordDocument>
</xml><![endif]--><!--[if gte mso 9]><xml>
<w:LatentStyles DefLockedState="false" LatentStyleCount="156">
</w:LatentStyles>
</xml><![endif]-->

--
Peace!
Kurt
Self-anointed Moderator
microscum.pubic.windowsexp.gonorrhea
http://microscum.com/mscommunity
"Trustworthy Computing" is only another example of an Oxymoron!
"Produkt-Aktivierung macht frei"

kurttrail
07-10-2005, 12:49 AM
kurttrail wrote:
> Stan Brown wrote:
>> On Sat, 28 May 2005 19:05:43 -0400, I wrote:
>>
>>> Windows XP Pro SP2, MS Office 2003
>>> Default Web browser is Mozilla, not MSIE
>>>
>>> In a folder with a lot of .HTM files, a few of them show the Mozilla
>>> icon but most show the MS-Word icon. "Folder Options" -> "File
>>> Types" shows that Mozilla is associated with .HTM and .HTML files,
>>> and when I double-click on one it does correctly open in Mozilla.
>>>
>>> How can I correct the icon display, and does anyone have a clue what
>>> caused the problem? In "File Types" I clicked "Advanced" and
>>> re-selected the proper icon file, but even when I terminated and
>>> re-started the Explorer process it still showed the wrong icons for
>>> the majority of .HTM files.
>>
>> I also tried changing display resolution to force a refresh of
>> ICONCACHE.DB, then manually deleting ICONCACHE.DB (all copies) and
>> rebooting. It made no difference.
>
> Sounds like the files were generated with Word.
>
> Open up one of the files in Notepad. Does it look like below?
>
> <html xmlns:v="urn:schemas-microsoft-com:vml"
> xmlns:o="urn:schemas-microsoft-com:office:office"
> xmlns:w="urn:schemas-microsoft-com:office:word"
> xmlns="http://www.w3.org/TR/REC-html40">
>
> <head>
> <meta http-equiv=Content-Type content="text/html;
> charset=windows-1252"> <meta name=ProgId content=Word.Document>
> <meta name=Generator content="Microsoft Word 11">
> <meta name=Originator content="Microsoft Word 11">
> <link rel=File-List
> href="{TITLE}_files/filelist.xml">
> <title>{TITLE}</title>
>
> If so, then edit it to look something like this:
>
> <html>
>
> <head>
> <meta http-equiv=Content-Type content="text/html;
> charset=windows-1252"> <title>TITLE</title>
>
> Then if you have this stuff below that you can just delete:
>
> <!--[if gte mso 9]><xml>
> <o:DocumentProperties>
> <o:Author></o:Author>
> <o:LastAuthor></o:LastAuthor>
> <o:Revision></o:Revision>
> <o:TotalTime></o:TotalTime>
> <o:Created></o:Created>
> <o:LastSaved></o:LastSaved>
> <o:Pages></o:Pages>
> <o:Words></o:Words>
> <o:Characters></o:Characters>
> <o:Company></o:Company>
> <o:Lines></o:Lines>
> <o:Paragraphs></o:Paragraphs>
> <o:CharactersWithSpaces></o:CharactersWithSpaces>
> <o:Version></o:Version>
> </o:DocumentProperties>
> </xml><![endif]--><!--[if gte mso 9]><xml>
> <w:WordDocument>
> <w:DontDisplayPageBoundaries/>
> <w:SpellingState></w:SpellingState>
> <w:GrammarState></w:GrammarState>
> <w:PunctuationKerning/>
> <w:ValidateAgainstSchemas/>
> <w:SaveIfXMLInvalid></w:SaveIfXMLInvalid>
> <w:IgnoreMixedContent></w:IgnoreMixedContent>
> <w:AlwaysShowPlaceholderText></w:AlwaysShowPlaceholderText>
> <w:Compatibility>
> <w:BreakWrappedTables/>
> <w:SnapToGridInCell/>
> <w:WrapTextWithPunct/>
> <w:UseAsianBreakRules/>
> <w:DontGrowAutofit/>
> </w:Compatibility>
> <w:BrowserLevel></w:BrowserLevel>
> </w:WordDocument>
> </xml><![endif]--><!--[if gte mso 9]><xml>
> <w:LatentStyles DefLockedState="false" LatentStyleCount="156">
> </w:LatentStyles>
> </xml><![endif]-->


This might speed things up for you, if this is your problem.

http://www.microsoft.com/downloads/details.aspx?FamilyID=209ADBEE-3FBD-482C-83B0-96FB79B74DED&displaylang=EN

--
Peace!
Kurt
Self-anointed Moderator
microscum.pubic.windowsexp.gonorrhea
http://microscum.com/mscommunity
"Trustworthy Computing" is only another example of an Oxymoron!
"Produkt-Aktivierung macht frei"

Stan Brown
07-10-2005, 12:49 AM
On Sat, 28 May 2005 20:58:49 -0400, "kurttrail"
<dontemailme@anywhereintheknowuniverse.org> wrote:

>Stan Brown wrote:
>> On Sat, 28 May 2005 19:05:43 -0400, I wrote:
>>
>>> Windows XP Pro SP2, MS Office 2003
>>> Default Web browser is Mozilla, not MSIE
>>>
>>> In a folder with a lot of .HTM files, a few of them show the Mozilla
>>> icon but most show the MS-Word icon.
>
>Sounds like the files were generated with Word.
>
>Open up one of the files in Notepad. Does it look like below?

Good catch, Kurt! There weren't most of the lines you mentioned, but
there was a <META NAME="Generator" CONTENT="Microsoft Word 97">
line. When I removed it from one file and hit F5 in explorer, the
icon changed to the correct one.

Follow-up question: Why is XP _reading_into_a_file_ toe decide which
icon to show? I thought that was supposed to be based strictly on
the extension.

--
Stan Brown, Oak Road Systems, Tompkins County, New York, USA
http://OakRoadSystems.com/
"I feel a wave of morning sickness coming on, and I want to
be standing on your mother's grave when it hits."

Stan Brown
07-10-2005, 12:49 AM
On Sun, 29 May 2005 10:49:21 -0400, I wrote:

(about .HTM files showing with the MS-Word icon)

>Good catch, Kurt! There weren't most of the lines you mentioned, but
>there was a <META NAME="Generator" CONTENT="Microsoft Word 97">
>line. When I removed it from one file and hit F5 in explorer, the
>icon changed to the correct one.

P.S. I didn't create these files myself, but had downloaded them
from Web sites.

Thanks for the offer of a filter tool, but I'll just run a batch
file to remove that line from the files where it occurs.

>Follow-up question: Why is XP _reading_into_a_file_ toe decide which
>icon to show? I thought that was supposed to be based strictly on
>the extension.


--
Stan Brown, Oak Road Systems, Tompkins County, New York, USA
http://OakRoadSystems.com/
"I feel a wave of morning sickness coming on, and I want to
be standing on your mother's grave when it hits."

kurttrail
07-10-2005, 12:49 AM
Stan Brown wrote:
> On Sat, 28 May 2005 20:58:49 -0400, "kurttrail"
> <dontemailme@anywhereintheknowuniverse.org> wrote:
>
>> Stan Brown wrote:
>>> On Sat, 28 May 2005 19:05:43 -0400, I wrote:
>>>
>>>> Windows XP Pro SP2, MS Office 2003
>>>> Default Web browser is Mozilla, not MSIE
>>>>
>>>> In a folder with a lot of .HTM files, a few of them show the
>>>> Mozilla icon but most show the MS-Word icon.
>>
>> Sounds like the files were generated with Word.
>>
>> Open up one of the files in Notepad. Does it look like below?
>
> Good catch, Kurt! There weren't most of the lines you mentioned,

I was pulling up what Word 2003 adds to a html file. A lot of useless
nonsense!

> but
> there was a <META NAME="Generator" CONTENT="Microsoft Word 97">
> line. When I removed it from one file and hit F5 in explorer, the
> icon changed to the correct one.
>
> Follow-up question: Why is XP _reading_into_a_file_ toe decide which
> icon to show? I thought that was supposed to be based strictly on
> the extension.

So it will open up the Office editing program it was created with. It
is useful when it comes to creating html slideshows with Powerpoint.
It's usefulness when it comes to Word is debatable at best.

--
Peace!
Kurt
Self-anointed Moderator
microscum.pubic.windowsexp.gonorrhea
http://microscum.com/mscommunity
"Trustworthy Computing" is only another example of an Oxymoron!
"Produkt-Aktivierung macht frei"

Wesley Vogel
07-10-2005, 12:50 AM
Incorrect or generic Windows icon displayed for HTM, HTML and MHT files
http://windowsxp.mvps.org/htmicon.htm

--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

In news:g2uh91hkf88k1u0viqru5eueksk5lme3bf@4ax.com,
Stan Brown <the_stan_brown@fastmail.fm> hunted and pecked:
> Windows XP Pro SP2, MS Office 2003
> Default Web browser is Mozilla, not MSIE
>
> In a folder with a lot of .HTM files, a few of them show the Mozilla
> icon but most show the MS-Word icon. "Folder Options" -> "File
> Types" shows that Mozilla is associated with .HTM and .HTML files,
> and when I double-click on one it does correctly open in Mozilla.
>
> How can I correct the icon display, and does anyone have a clue what
> caused the problem? In "File Types" I clicked "Advanced" and
> re-selected the proper icon file, but even when I terminated and
> re-started the Explorer process it still showed the wrong icons for
> the majority of .HTM files.
>
> --
> Stan Brown, Oak Road Systems, Tompkins County, New York, USA
> http://OakRoadSystems.com/
> "I feel a wave of morning sickness coming on, and I want to
> be standing on your mother's grave when it hits."


Many .htm files display MS-Word icon