Help: html files display generic icon



Catherine
07-10-2005, 12:48 AM
(I use Windows XP Home Edition, Service Pack II)

For the past few days, in all folder views, my html files no longer display
an icon, only the generic icon as though no program was associated with them.
Yet in the folder options, file types tab, IE is the program associated with
html files. I have tried various solutions on my own, without success. My
desktop on the other hand does display html files with the correct icon.

Could this problem be related to installing Adobe's Creative Suite a week
ago? I can't remember any change in icons happening at that time, but that is
the only explanation I can think of.

Thanks for your help!

Catherine
07-10-2005, 12:48 AM
Catherine again: I found the solution in a previous string, where "Ramesh"
gave a link to a Windows XP troubleshooting site. The page is
"http://windowsxp.mvps.org/htmicon.htm". I followed the instructions and my
problem is now solved. Thank you!

"Catherine" wrote:

> (I use Windows XP Home Edition, Service Pack II)
>
> For the past few days, in all folder views, my html files no longer display
> an icon, only the generic icon as though no program was associated with them.
> Yet in the folder options, file types tab, IE is the program associated with
> html files. I have tried various solutions on my own, without success. My
> desktop on the other hand does display html files with the correct icon.
>
> Could this problem be related to installing Adobe's Creative Suite a week
> ago? I can't remember any change in icons happening at that time, but that is
> the only explanation I can think of.
>
> Thanks for your help!
>

t.cruise
07-10-2005, 12:48 AM
If HTM and HTML files ARE associated with Internet Explorer, and you want to change the
icons for displayed files of that file type back to the default Internet Explorer icon:
Open Windows Explorer, click the Tools menu, click Folder Options, click the File Types
tab, scroll down to the HTM and HTML entries on the list. First click on HTM, then click
the ADVANCED button, then click the Change Icon button, (you might get an error dialog box
saying a certain file cannot be found, just click the OK button if that happens), and the
default shell32.dll with a bunch of icons will probably open. Click the Browse button at
the top right of that Change Icon box, at the bottom of the next dialog box where it says
Files of Type: click the arrow for the drop down menu and select: Programs, then at the
top of that same box where it says Look In: go to the path C:\Program Files\Internet
Explorer and double click the file IEXPLORE.EXE. (If Windows is installed on a drive other
than C:\ use that drive letter for the path). A window with a bunch of icons contain in
the IE executable file will open, click on the icon with the e on the document with the
turned down right corner once to highlight it, click the OK button, and click the OK and
APPLY buttons on any remaining windows. Do, the same for the HTML listing as well...
--

T.C.
t__cruise@[NoSpam]hotmail.com
Remove [NoSpam] to reply



"Catherine" <Catherine@discussions.microsoft.com> wrote in message
news:122A51AC-5D9A-4401-951A-EE29BDECDFE1@microsoft.com...
> (I use Windows XP Home Edition, Service Pack II)
>
> For the past few days, in all folder views, my html files no longer display
> an icon, only the generic icon as though no program was associated with them.
> Yet in the folder options, file types tab, IE is the program associated with
> html files. I have tried various solutions on my own, without success. My
> desktop on the other hand does display html files with the correct icon.
>
> Could this problem be related to installing Adobe's Creative Suite a week
> ago? I can't remember any change in icons happening at that time, but that is
> the only explanation I can think of.
>
> Thanks for your help!
>

Ramesh, MS-MVP
07-10-2005, 12:49 AM
Thanks for the feedback Catherine.

--
Ramesh, Microsoft MVP
Windows XP Shell/User
http://windowsxp.mvps.org


"Catherine" <Catherine@discussions.microsoft.com> wrote in message
news:8F719B1B-9E7A-421B-B39B-5DC35031EBAF@microsoft.com...
> Catherine again: I found the solution in a previous string, where "Ramesh"
> gave a link to a Windows XP troubleshooting site. The page is
> "http://windowsxp.mvps.org/htmicon.htm". I followed the instructions and
> my
> problem is now solved. Thank you!
>
> "Catherine" wrote:
>
>> (I use Windows XP Home Edition, Service Pack II)
>>
>> For the past few days, in all folder views, my html files no longer
>> display
>> an icon, only the generic icon as though no program was associated with
>> them.
>> Yet in the folder options, file types tab, IE is the program associated
>> with
>> html files. I have tried various solutions on my own, without success. My
>> desktop on the other hand does display html files with the correct icon.
>>
>> Could this problem be related to installing Adobe's Creative Suite a week
>> ago? I can't remember any change in icons happening at that time, but
>> that is
>> the only explanation I can think of.
>>
>> Thanks for your help!
>>


Help: html files display generic icon