Wndows authorisation for an FTP server



Dave Neve
07-10-2005, 12:46 AM
Hello


I have installed an FTP server on my computer but Windows won't let me in to
my folders although I am an administrator.(see post 25 May)

I was kindly given the following info from S Sengupta (MVP)

(Start>Run>Type in:gpedit.msc>Ok, and expanding Computer
Configuration->Windows Settings->Security Settings->Local
Policies->User Rights Assignment. The "Allow Login
through Terminal Services" right will be on the right-
hand pane, double-click it and 'Add User or Group'-there you add the
account.

but I don't understand which account to add.

There seems to be several contenders like 'remote interactive login' or
'anonymous login' or even 'authenticated user'

After all, I log in to my server (after being redirected by DeeEnEss) so I
am indentified but not directly by Windows.

Can someone help me out?

Thanks in advance

Dave Neve

Mark Dormer
07-10-2005, 12:46 AM
First, it would help if you mentioned what FTP server on what operating
system.
I assume XP and IIS

If anonymous access is being allowed then;
The account used to login will be displayed on the Security Accounts tab of
the properties of the FTP Site in IIS manager. If you don't want anonymous
access then untick the box on this tab.

To login using a username and password
Using IE ftp to the site then select from the menu File--Login As
Enter your username and password.

The FTP server authenticates you to the FTP server, it doesn't bypass any
filesystem permissions.
If your directories are on an NTFS volume then "your anonymous account"
needs read permissions at least.


Regards
Mark Dormer





"Dave Neve" <NoAddressForSpammers@Nofs.fr> wrote in message
news:OSjaPZoYFHA.3364@TK2MSFTNGP12.phx.gbl...
> Hello
>
>
> I have installed an FTP server on my computer but Windows won't let me in
to
> my folders although I am an administrator.(see post 25 May)
>
> I was kindly given the following info from S Sengupta (MVP)
>
> (Start>Run>Type in:gpedit.msc>Ok, and expanding Computer
> Configuration->Windows Settings->Security Settings->Local
> Policies->User Rights Assignment. The "Allow Login
> through Terminal Services" right will be on the right-
> hand pane, double-click it and 'Add User or Group'-there you add the
> account.
>
> but I don't understand which account to add.
>
> There seems to be several contenders like 'remote interactive login' or
> 'anonymous login' or even 'authenticated user'
>
> After all, I log in to my server (after being redirected by DeeEnEss) so I
> am indentified but not directly by Windows.
>
> Can someone help me out?
>
> Thanks in advance
>
> Dave Neve
>
>
>
>

Dave Neve
07-10-2005, 12:46 AM
Hi

I have XP Pro but I don't understand 'IIS'.

The software for the FTP server is TYPsoft and I use DeeEnEss synamic
updater to link to DYNdns.

Getting down to the nitty gritty, I don't really want to activate 'anonymous
account' as this suggests 'open house' if I get a virus.

Also, does 'anonymous account ' mean that anyone can log in to the computer
if they are sitting at my desk?

Ideally, I'd like the FTP server to recognize me (which it does) and then
inform Windows that it is me (administrator) so that I can access the file.

Any further pointers please?

Thanks

Dave Neve


"Mark Dormer" <markd@mvpsx.org> a écrit dans le message de news:
OV64KooYFHA.2884@tk2msftngp13.phx.gbl...
> First, it would help if you mentioned what FTP server on what operating
> system.
> I assume XP and IIS
>
> If anonymous access is being allowed then;
> The account used to login will be displayed on the Security Accounts tab
> of
> the properties of the FTP Site in IIS manager. If you don't want anonymous
> access then untick the box on this tab.
>
> To login using a username and password
> Using IE ftp to the site then select from the menu File--Login As
> Enter your username and password.
>
> The FTP server authenticates you to the FTP server, it doesn't bypass any
> filesystem permissions.
> If your directories are on an NTFS volume then "your anonymous account"
> needs read permissions at least.
>
>
> Regards
> Mark Dormer
>
>
>
>
>
> "Dave Neve" <NoAddressForSpammers@Nofs.fr> wrote in message
> news:OSjaPZoYFHA.3364@TK2MSFTNGP12.phx.gbl...
>> Hello
>>
>>
>> I have installed an FTP server on my computer but Windows won't let me in
> to
>> my folders although I am an administrator.(see post 25 May)
>>
>> I was kindly given the following info from S Sengupta (MVP)
>>
>> (Start>Run>Type in:gpedit.msc>Ok, and expanding Computer
>> Configuration->Windows Settings->Security Settings->Local
>> Policies->User Rights Assignment. The "Allow Login
>> through Terminal Services" right will be on the right-
>> hand pane, double-click it and 'Add User or Group'-there you add the
>> account.
>>
>> but I don't understand which account to add.
>>
>> There seems to be several contenders like 'remote interactive login' or
>> 'anonymous login' or even 'authenticated user'
>>
>> After all, I log in to my server (after being redirected by DeeEnEss) so
>> I
>> am indentified but not directly by Windows.
>>
>> Can someone help me out?
>>
>> Thanks in advance
>>
>> Dave Neve
>>
>>
>>
>>
>
>


Wndows authorisation for an FTP server