Permission for simple file sharing folders blocked on Workgroup



Conejon
07-09-2005, 11:46 PM
When I try to share folders over home WORKGROUP (both computers running XP
Pro), linking a laptop and a desktop, I get an error message that the Desktop
PC is not accessible and I might not have permission to use this network
resource. I have tried toggling back and forth the simple file sharing
permissioning in Folder Options but it doesn't help. The computers show up in
each other's Network and I haven't changed any other settings. I recently had
to reinstall the whole drive from a backup image, but otherwise everything is
working fine. HELP!!! Any suggestions?

pjp
07-09-2005, 11:46 PM
Have you actually shared anything on the pc's, e.g. at least a folder when
browsing or a printer for printing?

"Conejon" <Conejon@discussions.microsoft.com> wrote in message
news:C33DD311-4644-4550-97BA-60479E16496D@microsoft.com...
> When I try to share folders over home WORKGROUP (both computers running XP
> Pro), linking a laptop and a desktop, I get an error message that the
> Desktop
> PC is not accessible and I might not have permission to use this network
> resource. I have tried toggling back and forth the simple file sharing
> permissioning in Folder Options but it doesn't help. The computers show up
> in
> each other's Network and I haven't changed any other settings. I recently
> had
> to reinstall the whole drive from a backup image, but otherwise everything
> is
> working fine. HELP!!! Any suggestions?

frodo@theshire.org
07-09-2005, 11:47 PM
Toggling between Simple FIle Sharing and regular may be your issue. What
is important is WHEN you made the share - if SFS is on when you make the
share it gets a certain set of permissions, if it is off then it gets a
different set. Changing SFS afterwards doesn't change those settings.

Do the accounts have passwords - you can't do file sharing from an account
that doesn't have a password.

Your best bet for success is to 1) turn off the shares, 3) choose to use
SFS or not, then 3) run the Network Setup Wizzard, it will make sure that
all the necessary things have been done to make file sharing work for you.
Then remake your shares. Should work just fine.

Note the wizzard will turn on some services you may think you don't need.
But you do. The Windows Firewall Service is one of them. Even if you
don't actually enable the firewall itself (and are using a 3rd party
firewall), you still need this service. As well as Application
Layer Gateway and Computer Browser.

Once it's working, if browsing other pc's in the workgroup is slow try
this:

http://www.michna.com/kb/WxSlowNetworkBrowsing.htm

Conejon
07-09-2005, 11:47 PM
The shared folders from the Desktop do appear in the Laptop's Network Places
folder; they just cannot be opened.

"pjp" wrote:

> Have you actually shared anything on the pc's, e.g. at least a folder when
> browsing or a printer for printing?
>
> "Conejon" <Conejon@discussions.microsoft.com> wrote in message
> news:C33DD311-4644-4550-97BA-60479E16496D@microsoft.com...
> > When I try to share folders over home WORKGROUP (both computers running XP
> > Pro), linking a laptop and a desktop, I get an error message that the
> > Desktop
> > PC is not accessible and I might not have permission to use this network
> > resource. I have tried toggling back and forth the simple file sharing
> > permissioning in Folder Options but it doesn't help. The computers show up
> > in
> > each other's Network and I haven't changed any other settings. I recently
> > had
> > to reinstall the whole drive from a backup image, but otherwise everything
> > is
> > working fine. HELP!!! Any suggestions?
>
>
>

Conejon
07-09-2005, 11:47 PM
I'll give it a try and let you know, but thanks very much!

"frodo@theshire.org" wrote:

> Toggling between Simple FIle Sharing and regular may be your issue. What
> is important is WHEN you made the share - if SFS is on when you make the
> share it gets a certain set of permissions, if it is off then it gets a
> different set. Changing SFS afterwards doesn't change those settings.
>
> Do the accounts have passwords - you can't do file sharing from an account
> that doesn't have a password.
>
> Your best bet for success is to 1) turn off the shares, 3) choose to use
> SFS or not, then 3) run the Network Setup Wizzard, it will make sure that
> all the necessary things have been done to make file sharing work for you.
> Then remake your shares. Should work just fine.
>
> Note the wizzard will turn on some services you may think you don't need.
> But you do. The Windows Firewall Service is one of them. Even if you
> don't actually enable the firewall itself (and are using a 3rd party
> firewall), you still need this service. As well as Application
> Layer Gateway and Computer Browser.
>
> Once it's working, if browsing other pc's in the workgroup is slow try
> this:
>
> http://www.michna.com/kb/WxSlowNetworkBrowsing.htm
>
>

Conejon
07-09-2005, 11:47 PM
Ran Network Wizard but the problem still not fixed. Shared folders appear in
Laptop's Network Places but unable to open them as "may not have access
privileges".

"frodo@theshire.org" wrote:

> Toggling between Simple FIle Sharing and regular may be your issue. What
> is important is WHEN you made the share - if SFS is on when you make the
> share it gets a certain set of permissions, if it is off then it gets a
> different set. Changing SFS afterwards doesn't change those settings.
>
> Do the accounts have passwords - you can't do file sharing from an account
> that doesn't have a password.
>
> Your best bet for success is to 1) turn off the shares, 3) choose to use
> SFS or not, then 3) run the Network Setup Wizzard, it will make sure that
> all the necessary things have been done to make file sharing work for you.
> Then remake your shares. Should work just fine.
>
> Note the wizzard will turn on some services you may think you don't need.
> But you do. The Windows Firewall Service is one of them. Even if you
> don't actually enable the firewall itself (and are using a 3rd party
> firewall), you still need this service. As well as Application
> Layer Gateway and Computer Browser.
>
> Once it's working, if browsing other pc's in the workgroup is slow try
> this:
>
> http://www.michna.com/kb/WxSlowNetworkBrowsing.htm
>
>

Frog2000
07-09-2005, 11:48 PM
I am having exactly the same trouble with my 2 Del Dimensions 4600/4700.
Computer FLEX works exactly as it should with no access denied problems when
viewing SAM (the other computer). I am able to set up new network places
using a normal tree structure. On SAM I can see both computers in My
workgroup Computers but am unable to acces FLEX without being barred by the
Access Denied problem. I am able to view files on SAM on SAM. What makes this
particularly mistifying is that about a month ago the problem did not exist.
I was able to access both computers in the Workgroup Display normally from
both computers. I can print to each computer without problems. Any thoughts
anyone?

"frodo@theshire.org" wrote:

> Toggling between Simple FIle Sharing and regular may be your issue. What
> is important is WHEN you made the share - if SFS is on when you make the
> share it gets a certain set of permissions, if it is off then it gets a
> different set. Changing SFS afterwards doesn't change those settings.
>
> Do the accounts have passwords - you can't do file sharing from an account
> that doesn't have a password.
>
> Your best bet for success is to 1) turn off the shares, 3) choose to use
> SFS or not, then 3) run the Network Setup Wizzard, it will make sure that
> all the necessary things have been done to make file sharing work for you.
> Then remake your shares. Should work just fine.
>
> Note the wizzard will turn on some services you may think you don't need.
> But you do. The Windows Firewall Service is one of them. Even if you
> don't actually enable the firewall itself (and are using a 3rd party
> firewall), you still need this service. As well as Application
> Layer Gateway and Computer Browser.
>
> Once it's working, if browsing other pc's in the workgroup is slow try
> this:
>
> http://www.michna.com/kb/WxSlowNetworkBrowsing.htm
>
>

frodo@theshire.org
07-09-2005, 11:48 PM
Are you using Simple File Sharing (SFS) or not?

Under SFS, the local machine "logs onto" the remote machine using its
Guest account - it must be enabled for it to work. Some folks like to
disable the Guest account as a security measure. Running the Network
Setup Wizzard (w/ SFS enabled) will ensure Guest is enabled, and ensure
that all group policies re: using the guest account are set correctly.
The main "weakness" of SFS is that if something is shared it is shared w/
EVERYONE; any network user can access the share. In a typical home
environment that's not so bad. JUST MAKE SURE YOUR GATEWAY TO THE
INTERNET DOESN'T PERMIT INTERNET USERS TO GET THRU TO YOUR LOCAL
NETWORK!!!! NOR YOUR WIRELESS ACCESS POINT, WHICH IS TYPICALLY ALREADY
INSIDE THE LOCAL NET. [ie, check your router settings carefully].

Under Regular File Sharing (RFS), the local machine must have an account
on the remote machine with which it can log in. The simplest thing to do
in a home environment is make a user account on both/all machines, using
the same exact user name and password. Using RFS, each share can have
access permission assigned on a user by user basis, so you can share a
folder with one remote user but not all. Getting the permissions right
can be a bit daughnting, but the defaults usually work well (as a staring
point).

So, if you can see the share folder on the remote machine, but can't open
it, I suspect the privledges are not set correctly. As a starter, set the
provledge for the EVERYONE object to access and read.

====

As I said before, whenever I have problems of this sort (more than I'd
like ;-) I just run the network setup wizzard. Read the prompts carefully
and make sure you describe your set up correctly. And note that it ALWAYS
wants to rename your workgroup MSHOME; don't just fly past that screen,
renenter your real workgroup name.

Good Luck.

====

FWIW, a good/the_best XP book is "Win XP Inside Out" by Ed Bott et al.
the "old" first edition can be found real cheap at discount book stores,
the new 2nd edition runs about $40. Both have the eBook on CD ROM, the
1st edition's is in .chm format, the 2nd's is a .pdf (the .chm was more
convienient actually).

Frog2000
07-09-2005, 11:49 PM
Thanks for your quick reply frodo. I have solved the problem with the help of
alamb200@hotmail.com which was on another thread. I reprint the 'fix' here
----------------------------------------------------------------------------------
Hi

I don't know if anyone is still watching this newsgroup or has the same
problem as I have had but I am now back up and working with the aid of
the following web site http://www.michna.com/kb/wxnet.htm this was
fantastic.

In my case it was to do with the following registry key
"HKLM\SYSTEM\CurrentControlSet\Control\Lsa"
The value name was "RestrictAnonymous" which is a DWORD in my case this
was set to 1 which stops anonymous access I changed this to 0 and reset
the guest accounts password to blank and all started working.

I hope this helps someone else in the same situation I was in
----------------------------------------------------------------------------------
The pain is over and I can now move on. I have also managed to get SQL
server working correctly as well so thanks once again

Frog2000

"frodo@theshire.org" wrote:

> Are you using Simple File Sharing (SFS) or not?
>
> Under SFS, the local machine "logs onto" the remote machine using its
> Guest account - it must be enabled for it to work. Some folks like to
> disable the Guest account as a security measure. Running the Network
> Setup Wizzard (w/ SFS enabled) will ensure Guest is enabled, and ensure
> that all group policies re: using the guest account are set correctly.
> The main "weakness" of SFS is that if something is shared it is shared w/
> EVERYONE; any network user can access the share. In a typical home
> environment that's not so bad. JUST MAKE SURE YOUR GATEWAY TO THE
> INTERNET DOESN'T PERMIT INTERNET USERS TO GET THRU TO YOUR LOCAL
> NETWORK!!!! NOR YOUR WIRELESS ACCESS POINT, WHICH IS TYPICALLY ALREADY
> INSIDE THE LOCAL NET. [ie, check your router settings carefully].
>
> Under Regular File Sharing (RFS), the local machine must have an account
> on the remote machine with which it can log in. The simplest thing to do
> in a home environment is make a user account on both/all machines, using
> the same exact user name and password. Using RFS, each share can have
> access permission assigned on a user by user basis, so you can share a
> folder with one remote user but not all. Getting the permissions right
> can be a bit daughnting, but the defaults usually work well (as a staring
> point).
>
> So, if you can see the share folder on the remote machine, but can't open
> it, I suspect the privledges are not set correctly. As a starter, set the
> provledge for the EVERYONE object to access and read.
>
> ====
>
> As I said before, whenever I have problems of this sort (more than I'd
> like ;-) I just run the network setup wizzard. Read the prompts carefully
> and make sure you describe your set up correctly. And note that it ALWAYS
> wants to rename your workgroup MSHOME; don't just fly past that screen,
> renenter your real workgroup name.
>
> Good Luck.
>
> ====
>
> FWIW, a good/the_best XP book is "Win XP Inside Out" by Ed Bott et al.
> the "old" first edition can be found real cheap at discount book stores,
> the new 2nd edition runs about $40. Both have the eBook on CD ROM, the
> 1st edition's is in .chm format, the 2nd's is a .pdf (the .chm was more
> convienient actually).
>

Frog2000
07-09-2005, 11:49 PM
Thanks for your quick reply - I have managaged to find the answer which works
for me in another thread. It was from Alamb200@hotmail.com and I have copied
it here. Thanks Alamb200
----------------------------------------------------------------------------------------
Hi

I don't know if anyone is still watching this newsgroup or has the same
problem as I have had but I am now back up and working with the aid of
the following web site http://www.michna.com/kb/wxnet.htm this was
fantastic.

In my case it was to do with the following registry key
"HKLM\SYSTEM\CurrentControlSet\Control\Lsa"
The value name was "RestrictAnonymous" which is a DWORD in my case this
was set to 1 which stops anonymous access I changed this to 0 and reset
the guest accounts password to blank and all started working.

I hope this helps someone else in the same situation I was
--------------------------------------------------------------------------------------------

So many thanks. I have also managed to get SQL Server going correctly as
well - The pain is over!!

"frodo@theshire.org" wrote:

> Are you using Simple File Sharing (SFS) or not?
>
> Under SFS, the local machine "logs onto" the remote machine using its
> Guest account - it must be enabled for it to work. Some folks like to
> disable the Guest account as a security measure. Running the Network
> Setup Wizzard (w/ SFS enabled) will ensure Guest is enabled, and ensure
> that all group policies re: using the guest account are set correctly.
> The main "weakness" of SFS is that if something is shared it is shared w/
> EVERYONE; any network user can access the share. In a typical home
> environment that's not so bad. JUST MAKE SURE YOUR GATEWAY TO THE
> INTERNET DOESN'T PERMIT INTERNET USERS TO GET THRU TO YOUR LOCAL
> NETWORK!!!! NOR YOUR WIRELESS ACCESS POINT, WHICH IS TYPICALLY ALREADY
> INSIDE THE LOCAL NET. [ie, check your router settings carefully].
>
> Under Regular File Sharing (RFS), the local machine must have an account
> on the remote machine with which it can log in. The simplest thing to do
> in a home environment is make a user account on both/all machines, using
> the same exact user name and password. Using RFS, each share can have
> access permission assigned on a user by user basis, so you can share a
> folder with one remote user but not all. Getting the permissions right
> can be a bit daughnting, but the defaults usually work well (as a staring
> point).
>
> So, if you can see the share folder on the remote machine, but can't open
> it, I suspect the privledges are not set correctly. As a starter, set the
> provledge for the EVERYONE object to access and read.
>
> ====
>
> As I said before, whenever I have problems of this sort (more than I'd
> like ;-) I just run the network setup wizzard. Read the prompts carefully
> and make sure you describe your set up correctly. And note that it ALWAYS
> wants to rename your workgroup MSHOME; don't just fly past that screen,
> renenter your real workgroup name.
>
> Good Luck.
>
> ====
>
> FWIW, a good/the_best XP book is "Win XP Inside Out" by Ed Bott et al.
> the "old" first edition can be found real cheap at discount book stores,
> the new 2nd edition runs about $40. Both have the eBook on CD ROM, the
> 1st edition's is in .chm format, the 2nd's is a .pdf (the .chm was more
> convienient actually).
>

frodo@theshire.org
07-09-2005, 11:50 PM
That is the reg key that the Network Setup Wizzard will undo; having a
password on the guest account I think it would not undo; that's sure to
prevent SFS from working. Glad ya got it working, I know how frustrating
it can be, been there, done that!

Most directions for sttting this sort of thing up work well with a FRESH
XP install, but on a system that's over a year old, that's been working
fine, and now you're trying to get a home network working for the very
first time, it can be a bear. All those fantastic "security" tweaks
you've added over the years suddenly don't look so good when you're
actually trying to gain access to your system remotely.


Permission for simple file sharing folders blocked on Workgroup