ie security: can't view source in browser



randyr
07-09-2005, 11:45 PM
I have windows xp sp2 with autoupdate on, so I'm assuming the most recent
security updates. I am not sure when but at some point recently I no longer
have the ability to view source on a web page. I am assuming this is a
security issue with ie, as I have another related issue with using a citrix
client.
When I use the citrix client it cannot find an ica file which I think it
writes each session.

my guess is that some security setting has stopped ie from being able to
write temporary files. I have the same problem on both my work and homw
computer so I am pretty sure it has to do with security settings.

I have tried adding a site to my trusted sites with no success. I have also
tried setting the security settings in the browser to low and had no change
in this behaviour.

thanks

--
randyr

Jon
07-09-2005, 11:45 PM
Have a read through this page

http://www.winguides.com/registry/display.php/1246/

Jon


"randyr" <randyr@online.nospam> wrote in message
news:4ADECE9D-C49A-4A1D-ACAA-F40E79E23DF5@microsoft.com...
>I have windows xp sp2 with autoupdate on, so I'm assuming the most recent
> security updates. I am not sure when but at some point recently I no
> longer
> have the ability to view source on a web page. I am assuming this is a
> security issue with ie, as I have another related issue with using a
> citrix
> client.
> When I use the citrix client it cannot find an ica file which I think it
> writes each session.
>
> my guess is that some security setting has stopped ie from being able to
> write temporary files. I have the same problem on both my work and homw
> computer so I am pretty sure it has to do with security settings.
>
> I have tried adding a site to my trusted sites with no success. I have
> also
> tried setting the security settings in the browser to low and had no
> change
> in this behaviour.
>
> thanks
>
> --
> randyr

t.cruise
07-09-2005, 11:45 PM
Did you put a shortcut for Notepad on your desktop? I had a similar problem. The problem
was: The IE Tool menu/Programs tab had Notepad set for the HTML editor. There is a
Windows XP bug: If there's a Notepad shortcut on the desktop, and Notepad is selected as
the default HTML editor on the IE Tools menu, Internet Options, Programs tab, the source
will not open with Notepad using View menu/Source in IE. You click View menu/Source and
nothing happens. So, I downloaded EditPad Lite (an alternative to Notepad):

http://www.editpadlite.com/editpadlite.html

made a shortcut for that applet on my desktop, deleted the Notepad shortcut from my
desktop, but still kept Notepad for my default HTML editor. When I rebooted, the problem
was gone. Source now opens with Notepad. I need a shortcut on my desktop for a simple
text editor, which is why I opted to download and install EditPad Lite (FREE). If you
have no reason for a desktop shortcut for Notepad, then just delete the shortcut, reboot,
and don't bother with downloading and installing an alternative simple text editor.

Though that was my fix for what was causing my problem, your problem might have another
cause and fix. Perhaps notepad.exe has been deleted, or moved, or corrupted by viruses
which attack and/or rename Notepad.exe. The above is predicated on the fact that Notepad
is your default HTML editor.
--

T.C.
t__cruise@[NoSpam]hotmail.com
Remove [NoSpam] to reply



"randyr" <randyr@online.nospam> wrote in message
news:4ADECE9D-C49A-4A1D-ACAA-F40E79E23DF5@microsoft.com...
> I have windows xp sp2 with autoupdate on, so I'm assuming the most recent
> security updates. I am not sure when but at some point recently I no longer
> have the ability to view source on a web page. I am assuming this is a
> security issue with ie, as I have another related issue with using a citrix
> client.
> When I use the citrix client it cannot find an ica file which I think it
> writes each session.
>
> my guess is that some security setting has stopped ie from being able to
> write temporary files. I have the same problem on both my work and homw
> computer so I am pretty sure it has to do with security settings.
>
> I have tried adding a site to my trusted sites with no success. I have also
> tried setting the security settings in the browser to low and had no change
> in this behaviour.
>
> thanks
>
> --
> randyr

Jon
07-09-2005, 11:45 PM
Wordpad is also another good alternative (personally prefer it) to notepad

Change the default key at

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\View Source
Editor\Editor Name

from

C:\WINDOWS\notepad.exe

to

C:\Program Files\Windows NT\Accessories\wordpad.exe


Jon



"t.cruise" <t__cruise@[NoSpam]hotmail.com> wrote in message
news:OHRHq%23hYFHA.2312@TK2MSFTNGP14.phx.gbl...
> Did you put a shortcut for Notepad on your desktop? I had a similar
> problem. The problem
> was: The IE Tool menu/Programs tab had Notepad set for the HTML editor.
> There is a
> Windows XP bug: If there's a Notepad shortcut on the desktop, and Notepad
> is selected as
> the default HTML editor on the IE Tools menu, Internet Options, Programs
> tab, the source
> will not open with Notepad using View menu/Source in IE. You click View
> menu/Source and
> nothing happens. So, I downloaded EditPad Lite (an alternative to
> Notepad):
>
> http://www.editpadlite.com/editpadlite.html
>
> made a shortcut for that applet on my desktop, deleted the Notepad
> shortcut from my
> desktop, but still kept Notepad for my default HTML editor. When I
> rebooted, the problem
> was gone. Source now opens with Notepad. I need a shortcut on my desktop
> for a simple
> text editor, which is why I opted to download and install EditPad Lite
> (FREE). If you
> have no reason for a desktop shortcut for Notepad, then just delete the
> shortcut, reboot,
> and don't bother with downloading and installing an alternative simple
> text editor.
>
> Though that was my fix for what was causing my problem, your problem might
> have another
> cause and fix. Perhaps notepad.exe has been deleted, or moved, or
> corrupted by viruses
> which attack and/or rename Notepad.exe. The above is predicated on the
> fact that Notepad
> is your default HTML editor.
> --
>
> T.C.
> t__cruise@[NoSpam]hotmail.com
> Remove [NoSpam] to reply
>
>
>
> "randyr" <randyr@online.nospam> wrote in message
> news:4ADECE9D-C49A-4A1D-ACAA-F40E79E23DF5@microsoft.com...
>> I have windows xp sp2 with autoupdate on, so I'm assuming the most recent
>> security updates. I am not sure when but at some point recently I no
>> longer
>> have the ability to view source on a web page. I am assuming this is a
>> security issue with ie, as I have another related issue with using a
>> citrix
>> client.
>> When I use the citrix client it cannot find an ica file which I think it
>> writes each session.
>>
>> my guess is that some security setting has stopped ie from being able to
>> write temporary files. I have the same problem on both my work and homw
>> computer so I am pretty sure it has to do with security settings.
>>
>> I have tried adding a site to my trusted sites with no success. I have
>> also
>> tried setting the security settings in the browser to low and had no
>> change
>> in this behaviour.
>>
>> thanks
>>
>> --
>> randyr
>
>

t.cruise
07-09-2005, 11:46 PM
True, but Wordpad is a almost a full word processor. I just wanted a quick loading plain
text applet, on the par with notepad, which is why a chose a free third party Notepad
replacement.
--

T.C.
t__cruise@[NoSpam]hotmail.com
Remove [NoSpam] to reply



"Jon" <Email_Address@SomewhereOrOther.com> wrote in message
news:O#lOUTiYFHA.2076@TK2MSFTNGP15.phx.gbl...
> Wordpad is also another good alternative (personally prefer it) to notepad
>
> Change the default key at
>
> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\View Source
> Editor\Editor Name
>
> from
>
> C:\WINDOWS\notepad.exe
>
> to
>
> C:\Program Files\Windows NT\Accessories\wordpad.exe
>
>
> Jon
>
>
>
> "t.cruise" <t__cruise@[NoSpam]hotmail.com> wrote in message
> news:OHRHq%23hYFHA.2312@TK2MSFTNGP14.phx.gbl...
> > Did you put a shortcut for Notepad on your desktop? I had a similar
> > problem. The problem
> > was: The IE Tool menu/Programs tab had Notepad set for the HTML editor.
> > There is a
> > Windows XP bug: If there's a Notepad shortcut on the desktop, and Notepad
> > is selected as
> > the default HTML editor on the IE Tools menu, Internet Options, Programs
> > tab, the source
> > will not open with Notepad using View menu/Source in IE. You click View
> > menu/Source and
> > nothing happens. So, I downloaded EditPad Lite (an alternative to
> > Notepad):
> >
> > http://www.editpadlite.com/editpadlite.html
> >
> > made a shortcut for that applet on my desktop, deleted the Notepad
> > shortcut from my
> > desktop, but still kept Notepad for my default HTML editor. When I
> > rebooted, the problem
> > was gone. Source now opens with Notepad. I need a shortcut on my desktop
> > for a simple
> > text editor, which is why I opted to download and install EditPad Lite
> > (FREE). If you
> > have no reason for a desktop shortcut for Notepad, then just delete the
> > shortcut, reboot,
> > and don't bother with downloading and installing an alternative simple
> > text editor.
> >
> > Though that was my fix for what was causing my problem, your problem might
> > have another
> > cause and fix. Perhaps notepad.exe has been deleted, or moved, or
> > corrupted by viruses
> > which attack and/or rename Notepad.exe. The above is predicated on the
> > fact that Notepad
> > is your default HTML editor.
> > --
> >
> > T.C.
> > t__cruise@[NoSpam]hotmail.com
> > Remove [NoSpam] to reply
> >
> >
> >
> > "randyr" <randyr@online.nospam> wrote in message
> > news:4ADECE9D-C49A-4A1D-ACAA-F40E79E23DF5@microsoft.com...
> >> I have windows xp sp2 with autoupdate on, so I'm assuming the most recent
> >> security updates. I am not sure when but at some point recently I no
> >> longer
> >> have the ability to view source on a web page. I am assuming this is a
> >> security issue with ie, as I have another related issue with using a
> >> citrix
> >> client.
> >> When I use the citrix client it cannot find an ica file which I think it
> >> writes each session.
> >>
> >> my guess is that some security setting has stopped ie from being able to
> >> write temporary files. I have the same problem on both my work and homw
> >> computer so I am pretty sure it has to do with security settings.
> >>
> >> I have tried adding a site to my trusted sites with no success. I have
> >> also
> >> tried setting the security settings in the browser to low and had no
> >> change
> >> in this behaviour.
> >>
> >> thanks
> >>
> >> --
> >> randyr
> >
> >
>
>


ie security: can't view source in browser