Numlock on at Boot - wont switch off.



M_Hood
07-09-2005, 11:45 PM
Hi, I have recently upgraded several Samsung V20 laptops to XP SP2. This is
working fine except at initial startup when the user is prompted to press
CTRL ALT DEL to log in, the num lock is staying permanently on. I have went
through the BIOS and ensured this is set to OFF, however it still stays on!!
I have searched the Samsung website for updated BIOS but nothing available.

Is it possible to curb this through a setting in Windows itself??

Any advice appreciated as the staff are getting restless even though its not
exactly a hardship to press the Num Lock key before logging in !!

Ramesh, MS-MVP
07-09-2005, 11:45 PM
Set InitialKeyboardIndicators to 0
http://support.microsoft.com/kb/154529/EN-US/

--
Ramesh, Microsoft MVP
Windows XP Shell/User
http://windowsxp.mvps.org


"M_Hood" <MHood@discussions.microsoft.com> wrote in message
news:1600B6F7-7436-4AED-B293-AE6FBCB997A1@microsoft.com...
> Hi, I have recently upgraded several Samsung V20 laptops to XP SP2. This
> is
> working fine except at initial startup when the user is prompted to press
> CTRL ALT DEL to log in, the num lock is staying permanently on. I have
> went
> through the BIOS and ensured this is set to OFF, however it still stays
> on!!
> I have searched the Samsung website for updated BIOS but nothing
> available.
>
> Is it possible to curb this through a setting in Windows itself??
>
> Any advice appreciated as the staff are getting restless even though its
> not
> exactly a hardship to press the Num Lock key before logging in !!

Don Schmidt
07-09-2005, 11:45 PM
This is from my 98 days. It may work.


Found this along the way:

Start
Run
REGEDIT

HKEY_CURRENT_USER
Control Panel
Keyboard
Right click on Keyboard, select New String Value
Enter NumLock enter to save,
Double Left click on NumLock and enter ON
save with OK
Reboot and you're done.

This works for me.



--
Don
Vancouver, USA


"M_Hood" <MHood@discussions.microsoft.com> wrote in message
news:1600B6F7-7436-4AED-B293-AE6FBCB997A1@microsoft.com...
> Hi, I have recently upgraded several Samsung V20 laptops to XP SP2. This
> is
> working fine except at initial startup when the user is prompted to press
> CTRL ALT DEL to log in, the num lock is staying permanently on. I have
> went
> through the BIOS and ensured this is set to OFF, however it still stays
> on!!
> I have searched the Samsung website for updated BIOS but nothing
> available.
>
> Is it possible to curb this through a setting in Windows itself??
>
> Any advice appreciated as the staff are getting restless even though its
> not
> exactly a hardship to press the Num Lock key before logging in !!

Joan Archer
07-09-2005, 11:45 PM
I think you'll find that if the user shuts down with the num lock on then
it will be on when booting, try shutting down with it off and see if that
works.
Joan


M_Hood wrote:
> Hi, I have recently upgraded several Samsung V20 laptops to XP SP2.
> This is working fine except at initial startup when the user is
> prompted to press CTRL ALT DEL to log in, the num lock is staying
> permanently on. I have went through the BIOS and ensured this is set
> to OFF, however it still stays on!! I have searched the Samsung
> website for updated BIOS but nothing available.
>
> Is it possible to curb this through a setting in Windows itself??
>
> Any advice appreciated as the staff are getting restless even though
> its not exactly a hardship to press the Num Lock key before logging
> in !!

Don Schmidt
07-09-2005, 11:45 PM
I meant to change the word "on" to "off" (sans quotes)


--
Don
"Some mornings it's just not worth chewing through the leather straps."



"Don Schmidt" <RetiredEngineer@pnb.telco> wrote in message
news:119bn99vdnp502@corp.supernews.com...
> This is from my 98 days. It may work.
>
>
> Found this along the way:
>
> Start
> Run
> REGEDIT
>
> HKEY_CURRENT_USER
> Control Panel
> Keyboard
> Right click on Keyboard, select New String Value
> Enter NumLock enter to save,
> Double Left click on NumLock and enter ON
> save with OK
> Reboot and you're done.
>
> This works for me.
>
>
>
> --
> Don
> Vancouver, USA
>
>
> "M_Hood" <MHood@discussions.microsoft.com> wrote in message
> news:1600B6F7-7436-4AED-B293-AE6FBCB997A1@microsoft.com...
>> Hi, I have recently upgraded several Samsung V20 laptops to XP SP2. This
>> is
>> working fine except at initial startup when the user is prompted to press
>> CTRL ALT DEL to log in, the num lock is staying permanently on. I have
>> went
>> through the BIOS and ensured this is set to OFF, however it still stays
>> on!!
>> I have searched the Samsung website for updated BIOS but nothing
>> available.
>>
>> Is it possible to curb this through a setting in Windows itself??
>>
>> Any advice appreciated as the staff are getting restless even though its
>> not
>> exactly a hardship to press the Num Lock key before logging in !!
>
>

Don Schmidt
07-09-2005, 11:45 PM
Another choice.

Go into the BIOS (usually it's the DEL key during bootup) and you can turn
the Number Lock off.


--
Don
Vancouver, USA


"Don Schmidt" <RetiredEngineer@pnb.telco> wrote in message
news:119bntv80b12b5a@corp.supernews.com...
>I meant to change the word "on" to "off" (sans quotes)
>
>
> --
> Don
> "Some mornings it's just not worth chewing through the leather straps."
>
>
>
> "Don Schmidt" <RetiredEngineer@pnb.telco> wrote in message
> news:119bn99vdnp502@corp.supernews.com...
>> This is from my 98 days. It may work.
>>
>>
>> Found this along the way:
>>
>> Start
>> Run
>> REGEDIT
>>
>> HKEY_CURRENT_USER
>> Control Panel
>> Keyboard
>> Right click on Keyboard, select New String Value
>> Enter NumLock enter to save,
>> Double Left click on NumLock and enter ON
>> save with OK
>> Reboot and you're done.
>>
>> This works for me.
>>
>>
>>
>> --
>> Don
>> Vancouver, USA
>>
>>
>> "M_Hood" <MHood@discussions.microsoft.com> wrote in message
>> news:1600B6F7-7436-4AED-B293-AE6FBCB997A1@microsoft.com...
>>> Hi, I have recently upgraded several Samsung V20 laptops to XP SP2. This
>>> is
>>> working fine except at initial startup when the user is prompted to
>>> press
>>> CTRL ALT DEL to log in, the num lock is staying permanently on. I have
>>> went
>>> through the BIOS and ensured this is set to OFF, however it still stays
>>> on!!
>>> I have searched the Samsung website for updated BIOS but nothing
>>> available.
>>>
>>> Is it possible to curb this through a setting in Windows itself??
>>>
>>> Any advice appreciated as the staff are getting restless even though its
>>> not
>>> exactly a hardship to press the Num Lock key before logging in !!
>>
>>
>
>

Steve N.
07-09-2005, 11:45 PM
Don Schmidt wrote:

> Another choice.
>
> Go into the BIOS (usually it's the DEL key during bootup) and you can turn
> the Number Lock off.
>
>

Please re-read the OP, that's already been tried.

Steve

Steve N.
07-09-2005, 11:45 PM
Joan Archer wrote:

> I think you'll find that if the user shuts down with the num lock on then
> it will be on when booting, try shutting down with it off and see if that
> works.
> Joan
>

This is true except that the preserved Num Lock status is not set until
the user logs in and the OP is having the problem before login.

Steve

>
> M_Hood wrote:
>
>>Hi, I have recently upgraded several Samsung V20 laptops to XP SP2.
>>This is working fine except at initial startup when the user is
>>prompted to press CTRL ALT DEL to log in, the num lock is staying
>>permanently on. I have went through the BIOS and ensured this is set
>>to OFF, however it still stays on!! I have searched the Samsung
>>website for updated BIOS but nothing available.
>>
>>Is it possible to curb this through a setting in Windows itself??
>>
>>Any advice appreciated as the staff are getting restless even though
>>its not exactly a hardship to press the Num Lock key before logging
>>in !!
>
>
>

M_Hood
07-09-2005, 11:46 PM
Thankyou everyone for your replies.

The fix is as follows, courtesy of Ramesh:

Open Regedit
HKEY_USERS\.Default\ Control Panel\Keyboard
Edit value for InitialKeyboardIndicators to 0 (set it to 2 if you WANT
Numlock to be on before login)

Steve N.
07-09-2005, 11:47 PM
M_Hood wrote:

> Thankyou everyone for your replies.
>
> The fix is as follows, courtesy of Ramesh:
>
> Open Regedit
> HKEY_USERS\.Default\ Control Panel\Keyboard
> Edit value for InitialKeyboardIndicators to 0 (set it to 2 if you WANT
> Numlock to be on before login)
>

Excellent. Thanks to Ramesh and to you for the followup post.

Steve

Ramesh, MS-MVP
07-09-2005, 11:48 PM
Thanks for posting back, M_Hood.

--
Ramesh, Microsoft MVP
Windows XP Shell/User
http://windowsxp.mvps.org


"M_Hood" <MHood@discussions.microsoft.com> wrote in message
news:759EE384-3A6D-4D54-8B62-02FEB0118613@microsoft.com...
> Thankyou everyone for your replies.
>
> The fix is as follows, courtesy of Ramesh:
>
> Open Regedit
> HKEY_USERS\.Default\ Control Panel\Keyboard
> Edit value for InitialKeyboardIndicators to 0 (set it to 2 if you WANT
> Numlock to be on before login)
>

Ramesh, MS-MVP
07-09-2005, 11:48 PM
Thank you! Steve.

--
Ramesh, Microsoft MVP
Windows XP Shell/User
http://windowsxp.mvps.org


"Steve N." <me@here.now> wrote in message
news:LBLle.1475$MI4.228@newsread2.news.pas.earthlink.net...
> M_Hood wrote:
>
>> Thankyou everyone for your replies.
>>
>> The fix is as follows, courtesy of Ramesh:
>>
>> Open Regedit
>> HKEY_USERS\.Default\ Control Panel\Keyboard
>> Edit value for InitialKeyboardIndicators to 0 (set it to 2 if you WANT
>> Numlock to be on before login)
>>
>
> Excellent. Thanks to Ramesh and to you for the followup post.
>
> Steve
>


Numlock on at Boot - wont switch off.