Re: taskbar icons disappear occasionally



Tony Guan
07-09-2005, 09:26 PM
Dear all,

Let me put my problem in another way.

Ideally,there should be 4 icons in the systray-Windows Firewall icon,AC
power icon,Windows messenger,Volume icon.
In most cases, there will be only Windows messenger & Windows Firewall icon
on the taskbar after boot. And sometimes, Windows Firewall will not occure
too.

But when I kill explorer.exe process and re-run it. All the 4 icons will be
there!

Can someone tell me what on earth the problem is?

I guess the systray.exe has bugs, but when I rename it, the problem is the
same, except that the AC power icon & volume icon will never occure. As far
as I know, that's normal because systray.exe is in charge of the two
icons(but not limited to).

Dear sir, please help me without asking some stupid questions!

--
BRGs
Tony Guan

"KM" <konstmor@nospam_yahoo.com> 写入消息新闻:uRx5eawRFHA.2664@TK2MSFTNGP15.phx.gbl...
> Tony,
>
>> Just to clarify, the "Hide inactive icons" option on the Taskbar
>> Properties is NOT set at your runtime now, right?
>> ---right
>
>
> You can check the following value at run time for the autlogon account:
> [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer],
> "EnableAutoTray"
> This value must be set to dword:0 for you.
> If it set to 1, or not set - the default behaviour will be to hide
> inactive icons on the systray.
>
>> I want to build a debug image in virtual PC, hoping to learn what's
>> running at that time. (for my target device has no COM interface for
>> debug).
>
> By "debug" waht do you mean?
> Please keep in mind that Debug Repository (the Repository with debug
> binaries of XP) is not provided with XPe.
>
> KM
>
>> BRGs
>> Tony Guan
>> "KM" <konstmor@nospam_yahoo.com> 写入消息新闻:OQmKk7jRFHA.576@TK2MSFTNGP15.phx.gbl...
>>> Tony,
>>>
>>> Just to clarify, the "Hide inactive icons" option on the Taskbar
>>> Properties is NOT set at your runtime now, right?
>>>
>>> Also, did you try *Autologon* with non-blank password set? Does the
>>> problem appear there as well?
>>>
>>> KM
>>>
>>>> KM,
>>>>
>>>> No, I didn't set the option.
>>>>
>>>> Yes, I know there are no connection between the password and the icons,
>>>> they are just the surface. What I wonder is that the login process
>>>> interferes with the startup program loading procedure.
>>>>
>>>> But I have no way to prove it. May someone can tell me some details?
>>>> Thanks & RGRs
>>>>
>>>> Tony
>>>>
>>>> "KM" <konstmor@nospam_yahoo.com> 写入消息新闻:e9ct0ZdRFHA.2792@TK2MSFTNGP10.phx.gbl...
>>>>> Tony,
>>>>>
>>>>> I don't know if and where there are connections between the icons and
>>>>> blank password.
>>>>>
>>>>> But do you have "Hide inactive icons" option set in the Taskbar
>>>>> properties? If so, clear it up.
>>>>>
>>>>> --
>>>>> Regards,
>>>>> KM, BSquare Corp.
>>>>>
>>>>>
>>>>>> AND to frustrate me further is that I have done the 2 check points:
>>>>>>
>>>>>> - check if you set "Show Notifications on Task bar" option of "User
>>>>>> Interface Core" component's settings
>>>>>> - add "Tray Icon Add/Remove Support" component
>>>>>>
>>>>>> "Tony Guan" <tony@fic-sh.com.cn> 写入消息新闻:%23tEJQOYRFHA.2348@tk2msftngp13.phx.gbl...
>>>>>> > Hi there,
>>>>>> > I built an XPE image,when it boots, logon with a mouse click(the
>>>>>> > password
>>>>>> > is blank), the number of the icons which are supposed to show on
>>>>>> > the right
>>>>>> > bottome corner of the taskbar changes everytime. For example, the
>>>>>> > audio
>>>>>> > volume icon will disappear sometimes.(I am sure the checkbox of the
>>>>>> > 'display icon on the taskbar' for audio divice is checked).
>>>>>> > But when I set a password for Administrator, and input it everytime
>>>>>> > for
>>>>>> > logon, all the icons show up.
>>>>>> > What is going on? Can anybody give a explanation?
>>>>>> > How to fix it up?
>>>>>> >
>>>>>> > Thanks & RGRs
>>>>>> > Tony Guan
>>>>>> >
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>
>


Re: taskbar icons disappear occasionally