Changing the "default" file association



Arcfus Barcwinkle
07-10-2005, 12:30 AM
I've just installed Omnipage Pro. I've discovered that it has altered
all of the image file associations on my machine. (God, that pisses me
off when they do that!)

I'd like to change the default back. I already know how to do this:
Tools/Folder Options/File Types
Select type
Change association

But once that's done, in that dialog box is this text:
"You have customized files with extension 'JPG'. To restore these files
to their default type (OmniPage Image File), click Restore."

I want to undo whatever happened that made WinXP believe that OmniPage
is the default type.

One other thing is that I can't change the icon. The only way to do
that is via the "Advanced" button, but once you change the association
away from its default, that button changes to "Restore".

Ramesh, MS-MVP
07-10-2005, 12:30 AM
Arcfus,

Click the "Restore" button in the File Types dialog, and click OK. Then to
fix the association settings, try the fix from here:
http://www.dougknox.com/xp/file_assoc.htm

For all other file types, you may use this tool:
http://windowsxp.mvps.org/imgassofix.htm

--
Ramesh, Microsoft MVP
Windows XP Shell/User
http://windowsxp.mvps.org


"Arcfus Barcwinkle" <arcfus@flink.com> wrote in message
news:pleh811rbpccfgiq0lsd6oggdch36avh0k@4ax.com...
> I've just installed Omnipage Pro. I've discovered that it has altered
> all of the image file associations on my machine. (God, that pisses me
> off when they do that!)
>
> I'd like to change the default back. I already know how to do this:
> Tools/Folder Options/File Types
> Select type
> Change association
>
> But once that's done, in that dialog box is this text:
> "You have customized files with extension 'JPG'. To restore these files
> to their default type (OmniPage Image File), click Restore."
>
> I want to undo whatever happened that made WinXP believe that OmniPage
> is the default type.
>
> One other thing is that I can't change the icon. The only way to do
> that is via the "Advanced" button, but once you change the association
> away from its default, that button changes to "Restore".

Jim
07-10-2005, 12:30 AM
"Arcfus Barcwinkle" <arcfus@flink.com> wrote in message
news:pleh811rbpccfgiq0lsd6oggdch36avh0k@4ax.com...
> I've just installed Omnipage Pro. I've discovered that it has altered
> all of the image file associations on my machine. (God, that pisses me
> off when they do that!)
>
Lots of programs do that in the mistaken belief that we want our file
associations changed to their miserable product.
> I'd like to change the default back. I already know how to do this:
> Tools/Folder Options/File Types
> Select type
> Change association
>
> But once that's done, in that dialog box is this text:
> "You have customized files with extension 'JPG'. To restore these files
> to their default type (OmniPage Image File), click Restore."
>
> I want to undo whatever happened that made WinXP believe that OmniPage
> is the default type.
>
> One other thing is that I can't change the icon. The only way to do
> that is via the "Advanced" button, but once you change the association
> away from its default, that button changes to "Restore".
The steps you have taken did not modify the registry. The "restore" button
reverts to the registry setting.
I have had some luck by removing the file type. Then recreate it.
I haven't tried the other solutions so cannot comment on them.
Jim

Wayne H. Wilhelm
07-10-2005, 12:31 AM
The replies so far seem to all refer to restoring the association back to
default. Since the default has already been changed to Omnipage Pro (which
you don't want), you need to change the default association itself.

If you're having trouble with your approach, try this approach:

Open "My Pictures". Locate any JPG file. Right-click and select:

| Open With | Choose Program |

for "Choose Program", don't select any in the list. At the bottom of the
list of programs to choose from is a choice for "Choose Program". This
option allows you to browse your HD for the specific application (any
application) of your choice. When you locate the program you desire to be
the default application for opening JPG files, left-click once to highlight
it. Before applying the change, be sure to checkmark the option,

"Always use the selected program to open this kind of file".

Doing so in this manner changes the default program for opening the
specified file type. Repeat for any other file types as needed.
--
Cordially,
Wayne H. Wilhelm
Personal Web: http://www.quadracalc.com


"Arcfus Barcwinkle" wrote:

> I've just installed Omnipage Pro. I've discovered that it has altered
> all of the image file associations on my machine. (God, that pisses me
> off when they do that!)
>
> I'd like to change the default back. I already know how to do this:
> Tools/Folder Options/File Types
> Select type
> Change association
>
> But once that's done, in that dialog box is this text:
> "You have customized files with extension 'JPG'. To restore these files
> to their default type (OmniPage Image File), click Restore."
>
> I want to undo whatever happened that made WinXP believe that OmniPage
> is the default type.
>
> One other thing is that I can't change the icon. The only way to do
> that is via the "Advanced" button, but once you change the association
> away from its default, that button changes to "Restore".
>

Peter Foldes
07-10-2005, 12:31 AM
First go to Omnipage Pro and deselect all associations from its option list
that you desire. Then follow the advice given by Ramesh

--
Peter

Please reply to newsgroup for the benefit of others.

"Arcfus Barcwinkle" <arcfus@flink.com> wrote in message
news:pleh811rbpccfgiq0lsd6oggdch36avh0k@4ax.com...
> I've just installed Omnipage Pro. I've discovered that it has altered
> all of the image file associations on my machine. (God, that pisses me
> off when they do that!)
>
> I'd like to change the default back. I already know how to do this:
> Tools/Folder Options/File Types
> Select type
> Change association
>
> But once that's done, in that dialog box is this text:
> "You have customized files with extension 'JPG'. To restore these files
> to their default type (OmniPage Image File), click Restore."
>
> I want to undo whatever happened that made WinXP believe that OmniPage
> is the default type.
>
> One other thing is that I can't change the icon. The only way to do
> that is via the "Advanced" button, but once you change the association
> away from its default, that button changes to "Restore".


Changing the "default" file association