Version error when trying to install MS05-020 patch (IE Cumulative)on runtime image



Eberhard Schefold
07-09-2005, 10:25 PM
I am trying to install the patch

890923/MS05-020 "Cumulative Security Update for Internet
Explorer" IE6[1].0sp1-KB890923-Windows-2000-XP-x86-ENU.exe

on an XPE runtime image with the Desktop QFE Installer included. I get a

KB890923 Setup Error: The version of Internet Explorer you have
installed does not match the update you are trying to install.

IE reports its version as 6.00.2900.2180, just the version documented in
MS05-020.

I had downloaded the patch from the XPE OEM site. All other patches
meant for use with the Desktop QFE Installer install fine.

I would appreciate your ideas. :-O

KM
07-09-2005, 10:25 PM
Eberhard,

From MS05-20 KB (http://support.microsoft.com/kb/890923): ".... However, if
the computer does not have update rollup 873377, update rollup 889669, or a
hotfix that was released after security bulletin MS04-038, and you want to
install the hotfixes included in cumulative security update 890923, you must
follow the instructions in Microsoft Knowledge Base article 897225.
Otherwise, your hotfixes will be removed. ..".

I guess you may want to try to follow sugegstions from the 897225 article:
http://support.microsoft.com/kb/897225.

KM

>I am trying to install the patch
>
> 890923/MS05-020 "Cumulative Security Update for Internet Explorer"
> IE6[1].0sp1-KB890923-Windows-2000-XP-x86-ENU.exe
>
> on an XPE runtime image with the Desktop QFE Installer included. I get a
>
> KB890923 Setup Error: The version of Internet Explorer you have
> installed does not match the update you are trying to install.
>
> IE reports its version as 6.00.2900.2180, just the version documented in
> MS05-020.
>
> I had downloaded the patch from the XPE OEM site. All other patches meant
> for use with the Desktop QFE Installer install fine.
>
> I would appreciate your ideas. :-O

Eberhard Schefold
07-09-2005, 10:25 PM
KM wrote:

> From MS05-20 KB (http://support.microsoft.com/kb/890923): ".... However, if
> the computer does not have update rollup 873377, update rollup 889669, or a
> hotfix that was released after security bulletin MS04-038, and you want to
> install the hotfixes included in cumulative security update 890923, you must
> follow the instructions in Microsoft Knowledge Base article 897225.
> Otherwise, your hotfixes will be removed. ..".
>
> I guess you may want to try to follow sugegstions from the 897225 article:
> http://support.microsoft.com/kb/897225.

Thank you for your posting, but I'm afraid I don't quite understand it.
Here is what I understand from the bulletin:

The MS05-020 contains (a) "regular" Security updates, and (b) hotfixes.
The "regular" updates are always installed. The hotfixes are installed
only if certain special conditions are met. KB article 897225 describes
how to make sure that the hotfixes are installed.

This does not explain to me why the MS05-020 fails completely. I don't
necessarily want to install the hotfixes if this is not the behaviour on
a "normal" XP Professional machine, i.e. a machine without the special
conditions mentioned above. I don't see any hint why setup of the
"regular" Security updates should fail.

Could you (or anybody) try to clarify this for me? Thanks!

KM
07-09-2005, 10:26 PM
Eberhard,

>> I guess you may want to try to follow suggestions from the 897225 article: http://support.microsoft.com/kb/897225.
>
> Thank you for your posting, but I'm afraid I don't quite understand it.

Actually, I wasn't adding anything more than it said in the KB. Sorry this is not a fix for you but rather a suggestion to try.

> Here is what I understand from the bulletin:
>
> The MS05-020 contains (a) "regular" Security updates, and (b) hotfixes. The "regular" updates are always installed. The hotfixes
> are installed only if certain special conditions are met. KB article 897225 describes how to make sure that the hotfixes are
> installed.

Well.. The KB doesn't explicetely say if and when the update will fail but there are definitely a lot of "if's" there.
I never trusted the Desktop Installer mehanism on XPe as there may be too many differences between XPe image and XP Pro.

I basically suggested you to add [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer],"QFEInstalled"=dword:1 per KB897225
before you install the 890923.

Microsoft folks may be more knowledgable here about the MS05-020.

> This does not explain to me why the MS05-020 fails completely. I don't necessarily want to install the hotfixes if this is not the
> behaviour on a "normal" XP Professional machine, i.e. a machine without the special conditions mentioned above. I don't see any
> hint why setup of the "regular" Security updates should fail.

Have you tried the same MS patch on XP Pro SP2?
The reason I am asking this is that I've seen some IE Cumulative patches falling on a XP Pro machine (SP1, SP2) with exactly the
same error message you mentioned. Although, I don't recall trying the MS05-020.

Also, you may want to check the versions of the binaries (Dlls) in your image and the update. (not only IE version but all Dlls to
be updated)

KM

Dan
07-09-2005, 10:26 PM
I had the same problem when I tried to install
IE6[1].0sp1-KB890923-Windows-2000-XP-x86-ENU.exe

I tried the regular WindowsXP-KB890923-x86-ENU.exe and it seemed to work ok.
Why wouldn't MS offer to OEMs this QFE which is just for XP? Or maybe
IE6[1].0sp1-KB890923-Windows-2000-XP-x86-ENU.exe has another problem?

Regards, Dan


"KM" wrote:

> Eberhard,
>
> >> I guess you may want to try to follow suggestions from the 897225 article: http://support.microsoft.com/kb/897225.
> >
> > Thank you for your posting, but I'm afraid I don't quite understand it.
>
> Actually, I wasn't adding anything more than it said in the KB. Sorry this is not a fix for you but rather a suggestion to try.
>
> > Here is what I understand from the bulletin:
> >
> > The MS05-020 contains (a) "regular" Security updates, and (b) hotfixes. The "regular" updates are always installed. The hotfixes
> > are installed only if certain special conditions are met. KB article 897225 describes how to make sure that the hotfixes are
> > installed.
>
> Well.. The KB doesn't explicetely say if and when the update will fail but there are definitely a lot of "if's" there.
> I never trusted the Desktop Installer mehanism on XPe as there may be too many differences between XPe image and XP Pro.
>
> I basically suggested you to add [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer],"QFEInstalled"=dword:1 per KB897225
> before you install the 890923.
>
> Microsoft folks may be more knowledgable here about the MS05-020.
>
> > This does not explain to me why the MS05-020 fails completely. I don't necessarily want to install the hotfixes if this is not the
> > behaviour on a "normal" XP Professional machine, i.e. a machine without the special conditions mentioned above. I don't see any
> > hint why setup of the "regular" Security updates should fail.
>
> Have you tried the same MS patch on XP Pro SP2?
> The reason I am asking this is that I've seen some IE Cumulative patches falling on a XP Pro machine (SP1, SP2) with exactly the
> same error message you mentioned. Although, I don't recall trying the MS05-020.
>
> Also, you may want to check the versions of the binaries (Dlls) in your image and the update. (not only IE version but all Dlls to
> be updated)
>
> KM
>
>
>


Version error when trying to install MS05-020 patch (IE Cumulative)on runtime image