C:\Documents and Settings\All Users\Documents: Access denied



KheeChun
07-10-2005, 12:30 AM
I logged on as the administrator of the computer, by right I should be able
to access any folder I want. But Iwhen I tried to access C:\Documents and
Settings\All Users\Documents, It says that I do not have permission to access
it. My attempt to access it through MSDos also failed.
How can I solve this problem?
Thank you.

Wayne H. Wilhelm
07-10-2005, 12:30 AM
I've checked under both Windows XP Home edition and XP Professional edition.
Neither show

C:\Documents and > Settings\All Users\Documents

There is a 'Shared Documents' folder which is accessible. If you have both
folders, then the 'Documents' folder might be defective. If so, perform a HD
scan.

When you refer to MSDOS, are you talking about Repair Console or are you
referring to running Command.com from within Windows? Command.com from
within Windows won't yield anything more than what you already get from
Windows Explorer.

If a 'Documents' folder was created by another user and that user protected
the folder, even an Administrator won't be able to access it. You would have
to signon under the account of the user who created it along with the
password that was used when the folder was created.
--
Cordially,
Wayne H. Wilhelm
Personal Web: http://www.quadracalc.com


"KheeChun" wrote:

> I logged on as the administrator of the computer, by right I should be able
> to access any folder I want. But Iwhen I tried to access C:\Documents and
> Settings\All Users\Documents, It says that I do not have permission to access
> it. My attempt to access it through MSDos also failed.
> How can I solve this problem?
> Thank you.

Rock
07-10-2005, 12:30 AM
KheeChun wrote:

> I logged on as the administrator of the computer, by right I should be able
> to access any folder I want. But Iwhen I tried to access C:\Documents and
> Settings\All Users\Documents, It says that I do not have permission to access
> it. My attempt to access it through MSDos also failed.
> How can I solve this problem?
> Thank you.

See this article about taking ownership:

HOW TO: Take Ownership of a File or Folder in Windows XP
http://support.microsoft.com/?id=308421

Or click on Start then Help and Support. Type ownership in the search box.

--
Rock
MS MVP Windows - Shell/User

KheeChun
07-10-2005, 12:37 AM
Dear Wilhelm and Rock
Thanks for your help although your methods suggested didn't work for me, but
you all have indirectly lead me to the solution for this problem.
Just to share with everyone about the solution for it, I actually went to
the properties of the folder to find for the security tab as suggested by
Rock, but I couldn't (perhaps that is only available for WinXP Pro only),
instead there is a sharing tab. I clicked on the "shared documents" link, and
the "documents" folder automatically renamed itself into "shared documents".
Form then on, I could access it but not change the files in it or create new
files. I solved this by enabling sharing of this folder and allow other users
to modify the contents of it, and that's it, problem solved.
I hope this is useful for people who faces the similar problems.
Thank you.

Rock
07-10-2005, 12:37 AM
KheeChun wrote:
> Dear Wilhelm and Rock
> Thanks for your help although your methods suggested didn't work for me, but
> you all have indirectly lead me to the solution for this problem.
> Just to share with everyone about the solution for it, I actually went to
> the properties of the folder to find for the security tab as suggested by
> Rock, but I couldn't (perhaps that is only available for WinXP Pro only),
> instead there is a sharing tab. I clicked on the "shared documents" link, and
> the "documents" folder automatically renamed itself into "shared documents".
> Form then on, I could access it but not change the files in it or create new
> files. I solved this by enabling sharing of this folder and allow other users
> to modify the contents of it, and that's it, problem solved.
> I hope this is useful for people who faces the similar problems.
> Thank you.

To ge the security tab, if XP Pro, turn off simple file sharing - open
my computer or explorer, choose View; untic Use simple file sharing.

For XP Home boot into safe mode to see the security tab.
--
Rock
MS MVP Windows - Shell/User

Bob423
07-10-2005, 12:50 AM
KheeChun, Wihelm and Rock,

I read with great interest KheeChun's solution because I have the exact
same problem (access denied to "Documents and Settings\All
users\Documents" folder when logged on as Administrator) but when I did
what KheeChun did, instead of XP renaming the folder to "Shared
Documents" it just repeated that the folder "Documents" is not
accessible, Access is denied.

I got into this mess when I tried to install Adobe Photoshop CS2 and
the updater wouldn't install claiming didn't have permission to access
this folder. I also do not have a "Shared Folders" folder when I open
My Computer, all I see are two folders in the "Files Stored on This
Computer" section:
- Documents
- Rob's Documents

There's no Shared Folders folder. Perhaps it was deleted inadvertently?
Can I just rename "Documents" into "Shared Documents" manually?

Thanks, Bob


--
Bob423

Bob423
07-10-2005, 12:50 AM
Just to add to my note above, what actually happened was that my "Shared
Documents" folder in All Users was renamed (somehow!) to "Documents" and
then I was denied all access to the folder even though I am logged on as
an Administrator.

I'm running Windows XP Home (all the latest updates), Norton
Anti-Virus, Spy Sweeper, Norton Firewall. System shows clean with on
the latest sweeps.

Anybody got any ideas??

Thanks, Bob


--
Bob423

Wayne H. Wilhelm
07-10-2005, 01:24 AM
My apologies for not seeing this latest post of yours a month ago.
Unfortunately, you aren't likely to see this added note. If you do, great!

The referenced folder under all users:

(1) Documents
(2) Shared Documents

These two folders are precisely, exactly, the same.

If you have shared options set, the Documents folder is renamed to "Shared
Documents". If the shared options are removed, then the "Shared Documents"
folder is renamed back to "Documents" (without the "Shared" portion).
--
Cordially,
Wayne H. Wilhelm
Personal Web: http://www.quadracalc.com


"Bob423" wrote:

>
> Just to add to my note above, what actually happened was that my "Shared
> Documents" folder in All Users was renamed (somehow!) to "Documents" and
> then I was denied all access to the folder even though I am logged on as
> an Administrator.
>
> I'm running Windows XP Home (all the latest updates), Norton
> Anti-Virus, Spy Sweeper, Norton Firewall. System shows clean with on
> the latest sweeps.
>
> Anybody got any ideas??
>
> Thanks, Bob
>
>
> --
> Bob423
>


C:\Documents and Settings\All Users\Documents: Access denied