disabling CTRL+ALT+DEL with custom GINA



AK
07-09-2005, 09:25 PM
Hi,

I know this has been asked lot of times in newsgroup and I tried lot of
things. We have a custom GINA modified from GINAStub. Now I do not want
any message to Pop up if user presses CTRL+ALT+DEL. Returning
WLX_SAS_ACTION_NONE in WlxLoggedOnSAS only prevents logoff / shut down
etc, but the message box showing all the options still comes.
I have not included the Task Manager component in the image also. Is
there any way to prevent the message box poping up?

Thanks for any help.
AK

KM
07-09-2005, 09:25 PM
AK,

> I know this has been asked lot of times in newsgroup and I tried lot of
> things. We have a custom GINA modified from GINAStub. Now I do not want
> any message to Pop up if user presses CTRL+ALT+DEL. Returning
> WLX_SAS_ACTION_NONE in WlxLoggedOnSAS only prevents logoff / shut down

That should do it if you handle WLX_SAS_TYPE_CTRL_ALT_DEL Sas type and
replaced MsGina.dll in registry by your own.

> etc, but the message box showing all the options still comes.

What message box you are reffering to?
If it is "Task Manager has been disabled by ...", then please check out the
"Remove Task Manager" policy in GPEdit or directly in registry:
[HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System],"DisableTaskMgr".
Either remove the registry value or set it to 0 (dword).

> I have not included the Task Manager component in the image also. Is
> there any way to prevent the message box poping up?


If the message box is the one mentioned above, you may want to return the
taskmgr.exe back to your image.

After all you have a low level way to disable the key combination by
implementing a keyboard driver or writing a keyboard hook.

KM

AK
07-09-2005, 09:25 PM
Hi KM,

I am referring to Windows Security Dialog Box, which says "Use the Task
Manager to close the application which is not responding". It appears
when we press CTRL+ALT+DEL and shows six options, log off, shut down,
cancel, lock, task manager etc...

I do not want CTRL+ALT+DEL to respond and display this dialog box.

Thanks

KM
07-09-2005, 09:25 PM
AK,

Can you show us your implementation of the WlxLoggedOutSAS?
Since you went with Gina stub approach, you may still be calling to original MSGINA WlxLoggedOutSAS entry point. Do you?

Also, do you have GinaDLL value set in registry under Winlogon key?

KM

> Hi KM,
>
> I am referring to Windows Security Dialog Box, which says "Use the Task
> Manager to close the application which is not responding". It appears
> when we press CTRL+ALT+DEL and shows six options, log off, shut down,
> cancel, lock, task manager etc...
>
> I do not want CTRL+ALT+DEL to respond and display this dialog box.

AK
07-09-2005, 09:25 PM
Hi KM,

Thanks, that was the mistake. Even though I was returning
WLX_SAS_ACTION_NONE I was calling original GINA call. Now I corrected
that and CTRL+ALT+DEL does nothing.

But if Press the keys then ir refreshes the screen. I believe that to
remove that flash I need to filter the keys in a keyboard driver.
Right?

Is there any stub available for that?

Thanks


disabling CTRL+ALT+DEL with custom GINA