Language Bar does not appear



Gene
07-09-2005, 11:14 PM
I have two customers who cannot get the Language Bar to appear on their
desktops (or in the Taskbar) of Windows XP. They have added multiple
keyboards in the Text Services and Input Languages dialog box (of the
Regional and Languages Options Control Panel). They have different problems,
but with the same result--no Language Toolbar.

1. When customer 1 opens the Text Services and Input Languages dialog box
and clicks on the Language Bar... button all four check boxes are greyed
out; he cannot check any of them. I had him go to the Advanced tab of the
Text Services and Input languages dialog where we found "Turn off advanced
text services" was checked. I had him uncheck it and Apply the change. When
he went back to the Settings tab he could click on the Language Bar button
but all four options were still greyed out. When he went back to the
Advanced tab "Turn off advanced text services" was again checked. It seems
no matter what he does the "Turn off advanced text services" re-checks
itself (resets). I had him right click on the Taskbar and in the pop-up
context menu choose Toolbars. The Language Bar was not checked so he checked
it. The Language Bar still did not appear. The Taskbar was not locked.

2. When customer 2 added the French language and then clicked on the
Language Bar... button the first, third, and fourth options were (correctly)
checked, but the Language Bar did not appear on the desktop. On the Advanced
tab the "Turn off advanced text services" was (correctly) not checked. I had
her check it, Apply it, uncheck it, and Apply it. This did not help. When
she right clicks on the Windows Taskbar, and in the context menu selects
Toolbars, the Language Bar is not there--is not an option--but it should be.
The Taskbar is not locked and the Quick Launch toolbar can be selected (made
active) or deselected, but the Language Toolbar simply is not there. I had
her launch Word. Word tells you what input language is active in its Status
Bar, and it correctly said English. I had her use the Language Toolbar's
hotkey (Shift+left-Alt) to change to the French keyboard, and Word's status
bar correctly told her the French input langauge was selected, and she could
type French. Pressing Shift+Alt changed back to English. So the keyboard is
installed and does work. But other programs do not have a Status bar like
Word does, so the Windows Language Toolbar needs to work.

I cannot figure out how to get the Language Bar to appear in the Taskbar (or
in the upper right corner of the screen) for these two customers. Can anyone
help?

Thanks,
Gene


Language Bar does not appear