Links and Startmenu



Franz Leu
07-09-2005, 09:24 PM
Hi group

I just can not find what I am doing wrong. I have issues with the start menu
and with placing links into it.
- The links I create as custom resources with CD are not localized, and
therefore they do not show up in the start menu (they are place under start
Menu instead of being localized to appear under Startmenu - german version).
- I select to show "Run" ... to show up in the start menu, but they do not.

Does anybody have a idea what I am doing wrong?
Thanks
Franz

KM
07-09-2005, 09:24 PM
Franz,

As the shortcut destination you are probably using something like %16406 %, right?
It is going to expand to %allusersprofile%\Start Menu.

I think you may want to try the following as the dstpath:
%allusersprofile%\Startmenu (german version)


(or the same for %usersprofile%)

--
Regards,
KM, BSquare Corp.


> Hi group
>
> I just can not find what I am doing wrong. I have issues with the start menu
> and with placing links into it.
> - The links I create as custom resources with CD are not localized, and
> therefore they do not show up in the start menu (they are place under start
> Menu instead of being localized to appear under Startmenu - german version).
> - I select to show "Run" ... to show up in the start menu, but they do not.
>
> Does anybody have a idea what I am doing wrong?
> Thanks
> Franz
>

Franz Leu
07-09-2005, 09:24 PM
KM,

You're right, I was using something like %16406%/xxxxx
Do you have a link where I can find a listing of the other possible
variables.
Eventually I am writing them wrong or ... upon building the Image they are
always placed under c:\windows\%yyyy%.

Thanks for your help.
Franz

"KM" <konstmor@nospam_yahoo.com> schrieb im Newsbeitrag
news:%23cK4bewWFHA.3864@tk2msftngp13.phx.gbl...
> Franz,
>
> As the shortcut destination you are probably using something like %16406
> %, right?
> It is going to expand to %allusersprofile%\Start Menu.
>
> I think you may want to try the following as the dstpath:
> %allusersprofile%\Startmenu (german version)
>
>
> (or the same for %usersprofile%)
>
> --
> Regards,
> KM, BSquare Corp.
>
>
>> Hi group
>>
>> I just can not find what I am doing wrong. I have issues with the start
>> menu
>> and with placing links into it.
>> - The links I create as custom resources with CD are not localized, and
>> therefore they do not show up in the start menu (they are place under
>> start
>> Menu instead of being localized to appear under Startmenu - german
>> version).
>> - I select to show "Run" ... to show up in the start menu, but they do
>> not.
>>
>> Does anybody have a idea what I am doing wrong?
>> Thanks
>> Franz
>>
>
>

KM
07-09-2005, 09:24 PM
Franz,

I think this is all I've got:
http://gosh.msfnhosting.com/using_runonceex.htm
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/xpehelp/html/xerefpredefinedsystemenvironmentvariables.asp
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/install/hh/install/create-inf_2f47a10b-cb46-472f-a0e8-d1dad435d0f4.xml.asp

The RunOnceEx links is probably most informative.

KM

PS. These values are defined in setupapi.h - the best source for the dirid info.

> KM,
>
> You're right, I was using something like %16406%/xxxxx
> Do you have a link where I can find a listing of the other possible variables.
> Eventually I am writing them wrong or ... upon building the Image they are always placed under c:\windows\%yyyy%.
>
> Thanks for your help.
> Franz
>
> "KM" <konstmor@nospam_yahoo.com> schrieb im Newsbeitrag news:%23cK4bewWFHA.3864@tk2msftngp13.phx.gbl...
>> Franz,
>>
>> As the shortcut destination you are probably using something like %16406 %, right?
>> It is going to expand to %allusersprofile%\Start Menu.
>>
>> I think you may want to try the following as the dstpath:
>> %allusersprofile%\Startmenu (german version)
>>
>>
>> (or the same for %usersprofile%)
>>
>> --
>> Regards,
>> KM, BSquare Corp.
>>
>>
>>> Hi group
>>>
>>> I just can not find what I am doing wrong. I have issues with the start menu
>>> and with placing links into it.
>>> - The links I create as custom resources with CD are not localized, and
>>> therefore they do not show up in the start menu (they are place under start
>>> Menu instead of being localized to appear under Startmenu - german version).
>>> - I select to show "Run" ... to show up in the start menu, but they do not.
>>>
>>> Does anybody have a idea what I am doing wrong?
>>> Thanks
>>> Franz
>>>
>>
>>
>

Franz Leu
07-09-2005, 09:24 PM
KM

Thanks a lot!

Franz

"KM" <konstmor@nospam_yahoo.com> schrieb im Newsbeitrag
news:e2gXN%23IXFHA.2288@TK2MSFTNGP14.phx.gbl...
> Franz,
>
> I think this is all I've got:
> http://gosh.msfnhosting.com/using_runonceex.htm
> http://msdn.microsoft.com/library/default.asp?url=/library/en-us/xpehelp/html/xerefpredefinedsystemenvironmentvariables.asp
> http://msdn.microsoft.com/library/default.asp?url=/library/en-us/install/hh/install/create-inf_2f47a10b-cb46-472f-a0e8-d1dad435d0f4.xml.asp
>
> The RunOnceEx links is probably most informative.
>
> KM
>
> PS. These values are defined in setupapi.h - the best source for the dirid
> info.
>
>> KM,
>>
>> You're right, I was using something like %16406%/xxxxx
>> Do you have a link where I can find a listing of the other possible
>> variables.
>> Eventually I am writing them wrong or ... upon building the Image they
>> are always placed under c:\windows\%yyyy%.
>>
>> Thanks for your help.
>> Franz
>>
>> "KM" <konstmor@nospam_yahoo.com> schrieb im Newsbeitrag
>> news:%23cK4bewWFHA.3864@tk2msftngp13.phx.gbl...
>>> Franz,
>>>
>>> As the shortcut destination you are probably using something like %16406
>>> %, right?
>>> It is going to expand to %allusersprofile%\Start Menu.
>>>
>>> I think you may want to try the following as the dstpath:
>>> %allusersprofile%\Startmenu (german version)
>>>
>>>
>>> (or the same for %usersprofile%)
>>>
>>> --
>>> Regards,
>>> KM, BSquare Corp.
>>>
>>>
>>>> Hi group
>>>>
>>>> I just can not find what I am doing wrong. I have issues with the start
>>>> menu
>>>> and with placing links into it.
>>>> - The links I create as custom resources with CD are not localized, and
>>>> therefore they do not show up in the start menu (they are place under
>>>> start
>>>> Menu instead of being localized to appear under Startmenu - german
>>>> version).
>>>> - I select to show "Run" ... to show up in the start menu, but they do
>>>> not.
>>>>
>>>> Does anybody have a idea what I am doing wrong?
>>>> Thanks
>>>> Franz
>>>>
>>>
>>>
>>
>
>


Links and Startmenu