Tunneling RDP over SSH



Andy
07-09-2005, 11:10 PM
Hi,

I'm trying to remote desktop into one of my clients sites which is behind a
corporate firewall. I am running an SSH server, and in the past I have been
able to tunnel port 3389 to my server from their client machine. Normally, I
have my client download plink from putty and execute this command:
plink -l username -R 4444:localhost:3389 mydomain.com

And then from here I can remote desktop into localhost:4444 on my server and
bypass their firewall.

But it seems that this firewall is still blocking me somehow. When I have
the client turn on verbose output in plink, it appears to work but then the
connection is somehow cut off right away. When they login they get:

Access granted
Opened channel for session
Requesting remote port 4444 forward to localhost:3389
Remote port forwarding from 4444 enabled

And then when I try to connect to localhost:4444 on my server, I get this:

Attempting to forward remote port to localhost:3389
Forwarded port opened successfully
Forwarded port closed

So, I'm wondering if I need to forward more ports or if there is anyway to
debug what is going on here. Perhaps I need to forward some UDP ports?

Thanks for your help.

(By the way, the client is running Windows XP Pro with Remote desktop
enabled and his personal firewalls have been disabled. My server is a
Windows 2000 box.)

Jeffrey Randow (MVP)
07-10-2005, 10:34 AM
Have you taken a look at this:
http://www.bluestream.org/Networking/SSHTunnelRDP.htm
---
Jeffrey Randow (Windows Networking MVP)
jeffreyr-support@remotenetworktechnology.com
http://www.networkblog.net (My Networking Blog)
http://www.remotenetworktechnology.com (Support Site)

On Thu, 7 Jul 2005 07:01:09 -0700, "Andy"
<Andy@discussions.microsoft.com> wrote:

>Hi,
>
>I'm trying to remote desktop into one of my clients sites which is behind a
>corporate firewall. I am running an SSH server, and in the past I have been
>able to tunnel port 3389 to my server from their client machine. Normally, I
>have my client download plink from putty and execute this command:
>plink -l username -R 4444:localhost:3389 mydomain.com
>
>And then from here I can remote desktop into localhost:4444 on my server and
>bypass their firewall.
>
>But it seems that this firewall is still blocking me somehow. When I have
>the client turn on verbose output in plink, it appears to work but then the
>connection is somehow cut off right away. When they login they get:
>
>Access granted
>Opened channel for session
>Requesting remote port 4444 forward to localhost:3389
>Remote port forwarding from 4444 enabled
>
>And then when I try to connect to localhost:4444 on my server, I get this:
>
>Attempting to forward remote port to localhost:3389
>Forwarded port opened successfully
>Forwarded port closed
>
>So, I'm wondering if I need to forward more ports or if there is anyway to
>debug what is going on here. Perhaps I need to forward some UDP ports?
>
>Thanks for your help.
>
>(By the way, the client is running Windows XP Pro with Remote desktop
>enabled and his personal firewalls have been disabled. My server is a
>Windows 2000 box.)


Tunneling RDP over SSH